Sharepoint Online Issues while applying search configurations during Provisioning a site

%3CLINGO-SUB%20id%3D%22lingo-sub-45673%22%20slang%3D%22en-US%22%3ESharepoint%20Online%20Issues%20while%20applying%20search%20configurations%20during%20Provisioning%20a%20site%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-45673%22%20slang%3D%22en-US%22%3E%3CP%3EI%20am%20facing%20the%20issue%20while%20applying%20the%20provisioning%20template%20to%20a%20site%20with%20Search%20Settings%20only.%20The%20issue%20does%20not%20occur%20all%20the%20time.%20Have%20anyone%20faced%20this%20issue%20earlier%3F%3C%2FP%3E%3CPRE%3Eat%20Microsoft.SharePoint.Client.ClientRequest.ProcessResponseStream(Stream%20responseStream)%0A%20%20%20at%20Microsoft.SharePoint.Client.ClientRequest.ProcessResponse()%0A%20%20%20at%20Microsoft.SharePoint.Client.ClientRequest.ExecuteQueryToServer(ChunkStringBuilder%20sb)%0A%20%20%20at%20Microsoft.SharePoint.Client.ClientRequest.ExecuteQuery()%0A%20%20%20at%20Microsoft.SharePoint.Client.ClientRuntimeContext.ExecuteQuery()%0A%20%20%20at%20Microsoft.SharePoint.Client.ClientContext.ExecuteQuery()%0A%20%20%20at%20Microsoft.SharePoint.Client.ClientContextExtensions.ExecuteQueryImplementation(ClientRuntimeContext%20clientContext%2C%20Int32%20retryCount%2C%20Int32%20delay)%0A%20%20%20at%20Microsoft.SharePoint.%3CSTRONG%3EClient.SearchExtensions.SetSearchConfigurationImplementation%3C%2FSTRONG%3E(ClientRuntimeContext%20context%2C%20SearchObjectLevel%20searchObjectLevel%2C%20String%20searchConfiguration)%0A%20%20%20at%20OfficeDevPnP.Core.Framework.Provisioning.ObjectHandlers.ObjectSearchSettings.ProvisionObjects(Web%20web%2C%20ProvisioningTemplate%20template%2C%20TokenParser%20parser%2C%20ProvisioningTemplateApplyingInformation%20applyingInformation)%0A%20%20%20at%20OfficeDevPnP.Core.Framework.Provisioning.ObjectHandlers.SiteToTemplateConversion.ApplyRemoteTemplate(Web%20web%2C%20ProvisioningTemplate%20template%2C%20ProvisioningTemplateApplyingInformation%20provisioningInfo)%0A%20%20%20at%20Microsoft.SharePoint.Client.WebExtensions.ApplyProvisioningTemplate(Web%20web%2C%20ProvisioningTemplate%20template%2C%20ProvisioningTemplateApplyingInformation%20applyingInformation)%3C%2FPRE%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-45799%22%20slang%3D%22en-US%22%3ERe%3A%20Sharepoint%20Online%20Issues%20while%20applying%20search%20configurations%20during%20Provisioning%20a%20site%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-45799%22%20slang%3D%22en-US%22%3E%3CP%3EOk%20since%20it%20does%20not%20happen%20all%20the%20time%20i%20can%20confirm%20seeing%20this%20sometimes%20with%20a%20unstable%20internet%20connection%20or%20during%20update%20of%20office365%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-45713%22%20slang%3D%22en-US%22%3ERe%3A%20Sharepoint%20Online%20Issues%20while%20applying%20search%20configurations%20during%20Provisioning%20a%20site%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-45713%22%20slang%3D%22en-US%22%3E%3CP%3EI%20do%20recognize%20this%20behavior%20but%20never%20investigated%20the%20root-cause.%20So%20far%20when%20failing%20I%20consider%20the%20Search%20service%20to%20be%20in%20a%20temporary%20state%20(%22busy%20with%20something%22%20or%20maintenance)%20that%20causes%20this%20issue.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20understand%20you%20already%20have%20a%20dedicated%20Provisioning%20Template%20for%20Search%20Settings%20so%20depending%20on%20the%20way%20you%20apply%20your%20template%20you%20could%20maybe%20implement%20some%20sort%20of%20retry-mechanism%20in%20applying%20your%20template%20to%20work%20around%20this.%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-45696%22%20slang%3D%22en-US%22%3ERe%3A%20Sharepoint%20Online%20Issues%20while%20applying%20search%20configurations%20during%20Provisioning%20a%20site%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-45696%22%20slang%3D%22en-US%22%3ESorry%2C%20I%20cannot%20post%20the%20xml.%20The%20issue%20is%20it%20does%20not%20happen%20all%20the%20time.%20It%20fails%20sometimes%20only.%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-45685%22%20slang%3D%22en-US%22%3ERe%3A%20Sharepoint%20Online%20Issues%20while%20applying%20search%20configurations%20during%20Provisioning%20a%20site%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-45685%22%20slang%3D%22en-US%22%3E%3CP%3ECould%20you%20please%20post%20your%20provisioning%20xml%3F%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-569955%22%20slang%3D%22en-US%22%3ERe%3A%20Sharepoint%20Online%20Issues%20while%20applying%20search%20configurations%20during%20Provisioning%20a%20site%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-569955%22%20slang%3D%22en-US%22%3E%3CP%3EI%20am%20seeing%20the%20same%20error%20and%20it%20seems%20very%20random.%20We%20did%20put%205%20retry%20but%20even%20after%20that%20sometime%20it%20fails.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EIs%20there%20a%20way%20we%20can%20get%20detailed%20error%20log%20from%20ULS%20or%20something%3F%3C%2FP%3E%3C%2FLINGO-BODY%3E
Highlighted
Contributor

I am facing the issue while applying the provisioning template to a site with Search Settings only. The issue does not occur all the time. Have anyone faced this issue earlier?

at Microsoft.SharePoint.Client.ClientRequest.ProcessResponseStream(Stream responseStream)
   at Microsoft.SharePoint.Client.ClientRequest.ProcessResponse()
   at Microsoft.SharePoint.Client.ClientRequest.ExecuteQueryToServer(ChunkStringBuilder sb)
   at Microsoft.SharePoint.Client.ClientRequest.ExecuteQuery()
   at Microsoft.SharePoint.Client.ClientRuntimeContext.ExecuteQuery()
   at Microsoft.SharePoint.Client.ClientContext.ExecuteQuery()
   at Microsoft.SharePoint.Client.ClientContextExtensions.ExecuteQueryImplementation(ClientRuntimeContext clientContext, Int32 retryCount, Int32 delay)
   at Microsoft.SharePoint.Client.SearchExtensions.SetSearchConfigurationImplementation(ClientRuntimeContext context, SearchObjectLevel searchObjectLevel, String searchConfiguration)
   at OfficeDevPnP.Core.Framework.Provisioning.ObjectHandlers.ObjectSearchSettings.ProvisionObjects(Web web, ProvisioningTemplate template, TokenParser parser, ProvisioningTemplateApplyingInformation applyingInformation)
   at OfficeDevPnP.Core.Framework.Provisioning.ObjectHandlers.SiteToTemplateConversion.ApplyRemoteTemplate(Web web, ProvisioningTemplate template, ProvisioningTemplateApplyingInformation provisioningInfo)
   at Microsoft.SharePoint.Client.WebExtensions.ApplyProvisioningTemplate(Web web, ProvisioningTemplate template, ProvisioningTemplateApplyingInformation applyingInformation)
5 Replies
Highlighted

Could you please post your provisioning xml?

Highlighted
Sorry, I cannot post the xml. The issue is it does not happen all the time. It fails sometimes only.
Highlighted

I do recognize this behavior but never investigated the root-cause. So far when failing I consider the Search service to be in a temporary state ("busy with something" or maintenance) that causes this issue.

 

I understand you already have a dedicated Provisioning Template for Search Settings so depending on the way you apply your template you could maybe implement some sort of retry-mechanism in applying your template to work around this. 

Highlighted

Ok since it does not happen all the time i can confirm seeing this sometimes with a unstable internet connection or during update of office365

Highlighted

I am seeing the same error and it seems very random. We did put 5 retry but even after that sometime it fails.

 

Is there a way we can get detailed error log from ULS or something?