SOLVED

SharePoint Column Formatting "@me" not resolving

New Contributor

(This post has been solved, as the error has disappeared.)

 

Hi there,

 

2 months ago I have built a workflow for a customer, where I use a SharePoint column to either display the item's status, or a Flow button if the item is in a certain state and the current user is responsible for that state. I did this by comparing the "@me" value (user's email address) with another people picker column. I have done that several times by now and it worked this time as well. 

 

As of today though, the "@me" value does not resolve any more, but is interpreted as a string. The "@currentField" is working however, so this seems to be an isolated error. I have tested with 2 different accounts and browser contexts on the same tenant. I also moved on to test this on another tenant. Has SharePoint somehow changed its implementation recently?

 

See SharePoint column formatting documentation for evidence that it should work: https://docs.microsoft.com/en-us/sharepoint/dev/declarative-customization/column-formatting

 

Also see my 2 attached screenshots showing the currently different behavior between "@me" and "@currentField" :

SP ColumnFormatting [at]me error.pngSP ColumnFormatting [at]currentField working.png

 

 

If this error persists, I would need to rebuild the whole workflow with a different approach. Please help.

 

1 Reply
best response confirmed by ICT_M_Sch (New Contributor)
Solution

I created this post on friday. As I came back to work and opened up my browser again on monday, this happened:

 

clipboard_image_0.png

 

This obviously means It was, in fact, a bug. And secondly, that it seems to work again. I will mark this post as solved, BUT the resolution from "@me" might break again in the future. So I recommend to anyone planning to use column formatting functionally in a workflow, to refrain from doing so. In my experience the functionality has proven unreliable.