Search API is not returning result when using wildcard (*) before the key words

%3CLINGO-SUB%20id%3D%22lingo-sub-2523106%22%20slang%3D%22en-US%22%3ESearch%20API%20is%20not%20returning%20result%20when%20using%20wildcard%20(*)%20before%20the%20key%20words%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2523106%22%20slang%3D%22en-US%22%3E%3CP%3ESearch%20API%20is%20not%20returning%20result%20when%20using%20wildcard%20(*)%20before%20the%20key%20words%3C%2FP%3E%3CP%3EScenario%3A%201.%3C%2FP%3E%3CP%3EUsing%20below%20query%20SharePoint%20Search%20API%20returning%20correct%20result%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3Ea.%20%3CA%20href%3D%22https%3A%2F%2Fcontoso.sharepoint.com%2Fsites%2Ftestsite%2F_api%2Fsearch%2Fquery%3Fquerytext%3D%2527contentclass%3ASTS_Site%2520contentclass%3ASTS_Web%2520Title%3Ates*%2520Path%3Ahttps%3A%2F%2Fcontoso.sharepoint.com*%2527%26amp%3Bselectproperties%3D%2527SiteId%2CTitle%2CPath%2527%26amp%3Browlimit%3D5%22%20target%3D%22_blank%22%20rel%3D%22nofollow%20noopener%20noreferrer%22%3Ehttps%3A%2F%2Fcontoso.sharepoint.com%2Fsites%2Ftestsite%2F_api%2Fsearch%2Fquery%3Fquerytext%3D%2527contentclass%3ASTS_Site%2520contentclass%3ASTS_Web%2520Title%3Ates*%2520Path%3Ahttps%3A%2F%2Fcontoso.sharepoint.com*%2527%26amp%3Bselectproperties%3D%2527SiteId%2CTitle%2CPath%2527%26amp%3Browlimit%3D5%3C%2FA%3E%3C%2FP%3E%3CP%3EResults%3A%20TestSite%20site%20is%20returning%20in%20the%20result%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E2.%20Using%20below%20query%20SharePoint%20Search%20API%20returning%20no%20results%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3Ea.%20%3CA%20href%3D%22https%3A%2F%2Fcontoso.sharepoint.com%2Fsites%2Ftestsite%2F_api%2Fsearch%2Fquery%3Fquerytext%3D%2527contentclass%3ASTS_Site%2520contentclass%3ASTS_Web%2520Title%3A*tes*%2520Path%3Ahttps%3A%2F%2Fcontoso.sharepoint.com*%2527%26amp%3Bselectproperties%3D%2527SiteId%2CTitle%2CPath%2527%26amp%3Browlimit%3D5%22%20target%3D%22_blank%22%20rel%3D%22nofollow%20noopener%20noreferrer%22%3Ehttps%3A%2F%2Fcontoso.sharepoint.com%2Fsites%2Ftestsite%2F_api%2Fsearch%2Fquery%3Fquerytext%3D%2527contentclass%3ASTS_Site%2520contentclass%3ASTS_Web%2520Title%3A*tes*%2520Path%3Ahttps%3A%2F%2Fcontoso.sharepoint.com*%2527%26amp%3Bselectproperties%3D%2527SiteId%2CTitle%2CPath%2527%26amp%3Browlimit%3D5%3C%2FA%3E%3C%2FP%3E%3CP%3EResults%3A%20Returning%20no%20records%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EPreviously%20Scenario%202%20is%20returning%20the%20value%20but%20suddenly%20it%E2%80%99s%20stop%20returning%20results%2Frecords%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EEnvironment%3A%20M365%20Site%3C%2FP%3E%3C%2FLINGO-BODY%3E
Senior Member

Search API is not returning result when using wildcard (*) before the key words

Scenario: 1.

Using below query SharePoint Search API returning correct result

 

a. https://contoso.sharepoint.com/sites/testsite/_api/search/query?querytext=%27contentclass:STS_Site%2...

Results: TestSite site is returning in the result

 

2. Using below query SharePoint Search API returning no results

 

a. https://contoso.sharepoint.com/sites/testsite/_api/search/query?querytext=%27contentclass:STS_Site%2...

Results: Returning no records

 

Previously Scenario 2 is returning the value but suddenly it’s stop returning results/records

 

Environment: M365 Site

0 Replies