Intermittent internal server error from SharePoint API

%3CLINGO-SUB%20id%3D%22lingo-sub-1712902%22%20slang%3D%22en-US%22%3EIntermittent%20internal%20server%20error%20from%20SharePoint%20API%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1712902%22%20slang%3D%22en-US%22%3E%3CP%3EHi%2C%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI'm%20seeing%20a%20rather%20strange%20issue%20where%20intermittently%20I%20get%20a%20500%20Internal%20server%20error%20from%20the%20Sharepoint%20API%20when%20trying%20to%26nbsp%3B%22ListItemAllFields%22.%20The%20response%20from%20the%20api%20doesn't%20contain%20much%20info%20regarding%20this%20error.%20The%20structure%20of%20the%20url%20being%20used%20is%20something%20like%20this%20%3CA%20href%3D%22https%3A%2F%2Fdomain.sharepoint.com%2Fsites%2Flibrary%2F_api%2Fweb%2FGetFileByServerRelativeUrl('%2Fsites%2Flibrary%2Ffilepath%2Ffilename')%2FListItemAllFields%26quot%3B%22%20target%3D%22_blank%22%20rel%3D%22nofollow%20noopener%20noreferrer%22%3Ehttps%3A%2F%2Fdomain.sharepoint.com%2Fsites%2Flibrary%2F_api%2Fweb%2FGetFileByServerRelativeUrl('%2Fsites%2Flibrary%2Ffilepath%2Ffilename')%2FListItemAllFields%3C%2FA%3E%3C%2FP%3E%3CP%3EHas%20anyone%20seen%20this%20issue%3F%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E
Occasional Visitor

Hi,

 

I'm seeing a rather strange issue where intermittently I get a 500 Internal server error from the Sharepoint API when trying to "ListItemAllFields". The response from the api doesn't contain much info regarding this error. The structure of the url being used is something like this https://domain.sharepoint.com/sites/library/_api/web/GetFileByServerRelativeUrl('/sites/library/file...

Has anyone seen this issue?

 

 

0 Replies