Formatted view - hideColumnHeader not working in list webpart

%3CLINGO-SUB%20id%3D%22lingo-sub-1129633%22%20slang%3D%22en-US%22%3EFormatted%20view%20-%20hideColumnHeader%20not%20working%20in%20list%20webpart%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1129633%22%20slang%3D%22en-US%22%3E%3CP%3EI%20have%20a%20list%20webpart%20on%20a%20modern%20site%20which%20has%20a%20view%20formatted%20with%20some%20JSON%3C%2FP%3E%3CP%3EThe%20list%20column%20header%20displays%20even%20though%20the%20property%26nbsp%3BhideColumnHeader%20is%20set%20to%20true%20(this%20just%20started%20happening%20-%20was%20fine%20before)%3C%2FP%3E%3CP%3EIt%20is%20OK%20on%20the%20list%20page%20-AllItems.aspx%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20style%3D%22width%3A%20400px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Fgxcuf89792.i.lithium.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F167276iFFC957B0B060BF01%2Fimage-size%2Fmedium%3Fv%3D1.0%26amp%3Bpx%3D400%22%20alt%3D%22clipboard_image_0.png%22%20title%3D%22clipboard_image_0.png%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3Ebut%20on%20webpart%20page%20list%20column%20header%20displays%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20style%3D%22width%3A%20400px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Fgxcuf89792.i.lithium.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F167277i82E2907FA82B5FE9%2Fimage-size%2Fmedium%3Fv%3D1.0%26amp%3Bpx%3D400%22%20alt%3D%22clipboard_image_1.png%22%20title%3D%22clipboard_image_1.png%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3EI%20am%20using%20%3CA%20title%3D%22example%22%20href%3D%22https%3A%2F%2Fdocs.microsoft.com%2Fen-us%2Fsharepoint%2Fdev%2Fdeclarative-customization%2Fview-formatting%23get-started-with-view-formatting%22%20target%3D%22_self%22%20rel%3D%22noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%22%3Eexample%20here%3C%2FA%3E%20to%20test%3C%2FP%3E%3CP%3Eanybody%20have%20any%20ideas%3F%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-1129633%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EFormatting%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EView%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1131144%22%20slang%3D%22en-US%22%3ERe%3A%20Formatted%20view%20-%20hideColumnHeader%20not%20working%20in%20list%20webpart%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1131144%22%20slang%3D%22en-US%22%3EI%20noticed%20the%20same%20issue.%20hideColumnHeader%20and%20hideListHeader%20both%20are%20not%20working%20on%20Web%20Part%20Lists%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1132387%22%20slang%3D%22en-US%22%3ERe%3A%20Formatted%20view%20-%20hideColumnHeader%20not%20working%20in%20list%20webpart%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1132387%22%20slang%3D%22en-US%22%3E%3CP%3EIt%20seems%20to%20be%20a%20new%20and%20exciting%20bug%20introduced%20in%20the%20last%20week%20or%20so!%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1133065%22%20slang%3D%22en-US%22%3ERe%3A%20Formatted%20view%20-%20hideColumnHeader%20not%20working%20in%20list%20webpart%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1133065%22%20slang%3D%22en-US%22%3E%3CP%3ESame%20issue%20happening%20with%20our%20site.%26nbsp%3B%20%26nbsp%3B%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F364209%22%20target%3D%22_blank%22%3E%40RealPaddy%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1133155%22%20slang%3D%22en-US%22%3ERE%3A%20Formatted%20view%20-%20hideColumnHeader%20not%20working%20in%20list%20webpart%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1133155%22%20slang%3D%22en-US%22%3ESame%20issue%20for%20my%20customers%20on%20multiple%20tenants...%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1136022%22%20slang%3D%22en-US%22%3ERe%3A%20Formatted%20view%20-%20hideColumnHeader%20not%20working%20in%20list%20webpart%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1136022%22%20slang%3D%22en-US%22%3EI%20have%20opened%20a%20Ticket%20with%20Microsoft%20Support-%20I%20will%20post%20back%20updates%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1137364%22%20slang%3D%22en-US%22%3ERe%3A%20Formatted%20view%20-%20hideColumnHeader%20not%20working%20in%20list%20webpart%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1137364%22%20slang%3D%22en-US%22%3E%3CP%3EI%20am%20hardcore%20following%20this.%20Literally%20went%20live%20using%20this%20json%20formatting%20and%20it%20began%20to%20not%20do%20its%20job.%20I%20am%20Heart%20broken.%20Never%20easy%20to%20use%20SharePoint%20XD%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1138108%22%20slang%3D%22en-US%22%3ERe%3A%20Formatted%20view%20-%20hideColumnHeader%20not%20working%20in%20list%20webpart%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1138108%22%20slang%3D%22en-US%22%3EHi%2C%20any%20news%3F%20I've%20place%20a%20ticket%20on%20the%20portal%20and%20they%20call%20me%20back%20to%20tell%20me%20I%20need%20to%20call%20the%20dev%20team%20support%20for%20this.%20Did%20you%20talk%20to%20the%20dev%20team%3F%3CBR%20%2F%3E%3CBR%20%2F%3EThanks!%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1138383%22%20slang%3D%22en-US%22%3ERe%3A%20Formatted%20view%20-%20hideColumnHeader%20not%20working%20in%20list%20webpart%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1138383%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F24099%22%20target%3D%22_blank%22%3E%40Martin%20Coupal%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20have%20not%20spoken%20to%20anybody%20-%20have%20just%20got%20the%20Microsoft%20acknowledgement%20email%20response%20for%20opening%20the%20ticket%3C%2FP%3E%3CP%3Ecase%20%23%2018466765%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1139029%22%20slang%3D%22en-US%22%3ERe%3A%20Formatted%20view%20-%20hideColumnHeader%20not%20working%20in%20list%20webpart%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1139029%22%20slang%3D%22en-US%22%3E%3CP%3EHi%20All%2C%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20got%20the%20same%20issue.%20I%20am%20frequently%20visiting%20this%20page%20to%20see%20any%20updates.%3C%2FP%3E%3CP%3EPlease%20keep%20posted%20the%20updates.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThanks%20in%20advance.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1139373%22%20slang%3D%22en-US%22%3ERe%3A%20Formatted%20view%20-%20hideColumnHeader%20not%20working%20in%20list%20webpart%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1139373%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F364209%22%20target%3D%22_blank%22%3E%40RealPaddy%3C%2FA%3E%26nbsp%3BClosely%20following%20this%20also.%20Thanks%20for%20raising%20a%20ticket.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1139722%22%20slang%3D%22en-US%22%3ERe%3A%20Formatted%20view%20-%20hideColumnHeader%20not%20working%20in%20list%20webpart%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1139722%22%20slang%3D%22en-US%22%3E%3CP%3EI%20am%20having%20the%20same%20issue%20on%20multiple%20tenants.%26nbsp%3B%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F364209%22%20target%3D%22_blank%22%3E%40RealPaddy%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1142174%22%20slang%3D%22de-DE%22%3ERe%3A%20Formatted%20view%20-%20hideColumnHeader%20not%20working%20in%20list%20webpart%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1142174%22%20slang%3D%22de-DE%22%3E%3CP%3EI%20have%20the%20same%20issue%2C%20hope%20they%20fix%20it%20fast%2C%20thanks%20for%20open%20a%20ticket%20%3A)%3C%2Fimg%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1144668%22%20slang%3D%22en-US%22%3ERe%3A%20Formatted%20view%20-%20hideColumnHeader%20not%20working%20in%20list%20webpart%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1144668%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F364209%22%20target%3D%22_blank%22%3E%40RealPaddy%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThis%20issue%20has%20also%20been%20flagged%20on%20GitHub%26nbsp%3B%26nbsp%3B%3CA%20href%3D%22https%3A%2F%2Fgithub.com%2FSharePoint%2Fsp-dev-list-formatting%2Fissues%2F208%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%22%3Ehttps%3A%2F%2Fgithub.com%2FSharePoint%2Fsp-dev-list-formatting%2Fissues%2F208%3C%2FA%3E%26nbsp%3Bso%20hopefully%20the%20right%20people%20are%20in%20the%20loop!%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1149328%22%20slang%3D%22en-US%22%3ERe%3A%20Formatted%20view%20-%20hideColumnHeader%20not%20working%20in%20list%20webpart%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1149328%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F364209%22%20target%3D%22_blank%22%3E%40RealPaddy%3C%2FA%3E%26nbsp%3BThey%20keep%20on%20suggesting%20we%20use%20the%20sp-dev-docs%20github%20for%20these%20general%20bugs.%20The%20latest%20update%20is%20here%3A%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Fgithub.com%2FSharePoint%2Fsp-dev-docs%2Fissues%2F5251%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%22%3Ehttps%3A%2F%2Fgithub.com%2FSharePoint%2Fsp-dev-docs%2Fissues%2F5251%3C%2FA%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EClaiming%20it%20will%20take%20a%20couple%20of%20weeks%20to%20be%20implemented!%20It's%20also%20confusing%20because%20it's%20hard%20to%20verify%20the%20authority%20of%20the%20people%20making%20claims%2C%20unless%20it's%20someone%20obvious%20like%20Chris%20Kent.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1152604%22%20slang%3D%22en-US%22%3ERe%3A%20Formatted%20view%20-%20hideColumnHeader%20not%20working%20in%20list%20webpart%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1152604%22%20slang%3D%22en-US%22%3E%3CP%3E%26nbsp%3B%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F361257%22%20target%3D%22_blank%22%3E%40dfurler%3C%2FA%3E%26nbsp%3B%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F364209%22%20target%3D%22_blank%22%3E%40RealPaddy%3C%2FA%3E%26nbsp%3BAnd%20others%20in%20the%20thread.%20This%20issue%20has%20been%20fixed%20an%20is%20in%20the%20deployment%20pipeline%20and%20should%20reach%20production%20in%20a%20week%20(if%20not%20already).%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1153958%22%20slang%3D%22en-US%22%3ERe%3A%20Formatted%20view%20-%20hideColumnHeader%20not%20working%20in%20list%20webpart%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1153958%22%20slang%3D%22en-US%22%3EThanks!%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1154042%22%20slang%3D%22en-US%22%3ERe%3A%20Formatted%20view%20-%20hideColumnHeader%20not%20working%20in%20list%20webpart%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1154042%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F391288%22%20target%3D%22_blank%22%3E%40SVaibhav%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20think%20this%20might%20be%20related%20to%20the%20list%20web%20part%20no%20longer%20respecting%20the%20turning%20off%20checkboxes%20in%20tabular%20view%20settings%20as%20well.%20Do%20you%20know%20if%20this%20will%20also%20be%20fixed%20with%20the%20update%3F%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1154142%22%20slang%3D%22en-US%22%3ERe%3A%20Formatted%20view%20-%20hideColumnHeader%20not%20working%20in%20list%20webpart%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1154142%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F391288%22%20target%3D%22_blank%22%3E%40SVaibhav%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CP%3Ethanks%20for%20the%20update%20-%20I%20will%20verify%20fix%20when%20it%20comes%20through%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1154651%22%20slang%3D%22en-US%22%3ERe%3A%20Formatted%20view%20-%20hideColumnHeader%20not%20working%20in%20list%20webpart%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1154651%22%20slang%3D%22en-US%22%3E%3CP%3EHi%26nbsp%3B%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F393719%22%20target%3D%22_blank%22%3E%40XopherDesign%3C%2FA%3E%2C%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3EIf%20you%20are%20referring%20to%20the%20%22hideSelection%22%20property%20of%20view%20formatter%2C%20I%20see%20it%20working%20fine%20now.%20Do%20let%20me%20know%20if%20you%20meant%20something%20else!%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1156176%22%20slang%3D%22en-US%22%3ERe%3A%20Formatted%20view%20-%20hideColumnHeader%20not%20working%20in%20list%20webpart%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1156176%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F391288%22%20target%3D%22_blank%22%3E%40SVaibhav%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20was%20actually%20talking%20about%20the%20Edit%20View%20-%26gt%3B%20Tabular%20View%20-%26gt%3B%20Allow%20individual%20item%20checkboxes.%20This%20used%20to%20be%20respected%20by%20the%20modern%20list%20webpart%20when%20you%20unchecked%20it.%20But%20about%20the%20same%20time%20the%20list%20formatting%20hideColumnHeader%20stopped%20working%20this%20stopped%20working%20as%20well.%20Basically%20I%20see%20no%20way%20to%20get%20rid%20of%20checkboxes%20on%20the%20list%20webpart%20and%20still%20have%20it%20work%20in%20conjunction%20with%20the%20list%20properties%20web%20part.%3C%2FP%3E%3CP%3EWhen%20you%20link%20a%20list%20and%20list%20properties%20web%20parts%2C%20it%20makes%20no%20sense%20to%20allow%20multiple%20selections.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1157686%22%20slang%3D%22en-US%22%3ERe%3A%20Formatted%20view%20-%20hideColumnHeader%20not%20working%20in%20list%20webpart%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1157686%22%20slang%3D%22en-US%22%3E%3CP%3EHi%26nbsp%3B%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F393719%22%20target%3D%22_blank%22%3E%40XopherDesign%3C%2FA%3E%2C%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3EThanks%20for%20clarifying.%20I%20think%20this%20was%20also%20fixed%20with%20the%20same%20change%20which%20was%20done%20to%20fix%20the%20%22hideColumnHeader%22%20property%20on%20webpart%20as%20I%20am%20unable%20to%20reproduce%20this%20on%20my%20test%20list%20and%20looks%20like%20everything%20is%20working%20fine.%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3EKindly%20re-verify%20this%20too%20at%20your%20end%20once%20(the%20final%20fix%20can%20take%20a%20week%20to%20reach%20all%20the%20production%20environments).%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1158540%22%20slang%3D%22en-US%22%3ERe%3A%20Formatted%20view%20-%20hideColumnHeader%20not%20working%20in%20list%20webpart%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1158540%22%20slang%3D%22en-US%22%3E%3CP%3Ehello%26nbsp%3B%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F391288%22%20target%3D%22_blank%22%3E%40SVaibhav%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ESadly%2C%20it%20is%20still%20producing%20the%20same%20error.%20When%20you%20are%20in%20list%20view%2C%20yes%20it%20will%20show%20the%20right%20formatting%20when%20using%20%22hideColumnHeader%22%20but%20if%20you%20embed%20the%20list%20onto%20a%20page%2C%20that%20formatting%20reverts%20back%20and%20shows%20the%20Column%20Headers.%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1162609%22%20slang%3D%22en-US%22%3ERe%3A%20Formatted%20view%20-%20hideColumnHeader%20not%20working%20in%20list%20webpart%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1162609%22%20slang%3D%22en-US%22%3E%3CP%3EHi%26nbsp%3B%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F543375%22%20target%3D%22_blank%22%3E%40HelloWorld15%3C%2FA%3E%2C%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3EAs%20I%20have%20mentioned%20earlier%20too%2C%20the%20fix%20can%20take%20up%20to%20a%20week%20to%20reach%20all%20the%20clients%20(all%20production%20environment).%20We%20have%20already%20verified%20this%20at%20our%20end%20with%20the%20internal%20test%20sites.%20Kindly%20wait%20for%20a%20couple%20of%20days%20and%20verify%20the%20same%20at%20your%20end.%3C%2FP%3E%0A%3CP%3EIf%20the%20problem%20still%20exists%2C%20feel%20free%20to%20report%20it%20back.%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3EThanks%2C%3C%2FP%3E%0A%3CP%3ESwapnil%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1163183%22%20slang%3D%22en-US%22%3ERe%3A%20Formatted%20view%20-%20hideColumnHeader%20not%20working%20in%20list%20webpart%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1163183%22%20slang%3D%22en-US%22%3E%3CP%3EConfirmed%20fixed%20on%20my%20tenant.%20Thanks!%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1165453%22%20slang%3D%22en-US%22%3ERe%3A%20Formatted%20view%20-%20hideColumnHeader%20not%20working%20in%20list%20webpart%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1165453%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F391288%22%20target%3D%22_blank%22%3E%40SVaibhav%3C%2FA%3E%26nbsp%3Bboth%20issues%20confirmed%20fixed%20in%20my%20client's%20government%20cloud%20tenant.%3C%2FP%3E%3CP%3EWe%20had%20opened%20a%20case%20and%20closed%20it%20out%20today.%3C%2FP%3E%3CP%3EThanks%2C%3C%2FP%3E%3CP%3EChris%3C%2FP%3E%3C%2FLINGO-BODY%3E
Highlighted
Occasional Contributor

I have a list webpart on a modern site which has a view formatted with some JSON

The list column header displays even though the property hideColumnHeader is set to true (this just started happening - was fine before)

It is OK on the list page -AllItems.aspx

 

clipboard_image_0.png

 

but on webpart page list column header displays

clipboard_image_1.png

I am using example here to test

anybody have any ideas?

 

 

 

 

25 Replies
Highlighted
I noticed the same issue. hideColumnHeader and hideListHeader both are not working on Web Part Lists
Highlighted

It seems to be a new and exciting bug introduced in the last week or so! 

Highlighted

Same issue happening with our site.   @RealPaddy 

Highlighted
Same issue for my customers on multiple tenants...
Highlighted
I have opened a Ticket with Microsoft Support- I will post back updates
Highlighted

I am hardcore following this. Literally went live using this json formatting and it began to not do its job. I am Heart broken. Never easy to use SharePoint XD

Highlighted
Hi, any news? I've place a ticket on the portal and they call me back to tell me I need to call the dev team support for this. Did you talk to the dev team?

Thanks!
Highlighted

@Martin Coupal 

I have not spoken to anybody - have just got the Microsoft acknowledgement email response for opening the ticket

case # 18466765

 

Highlighted

Hi All,

 

I got the same issue. I am frequently visiting this page to see any updates.

Please keep posted the updates.

 

Thanks in advance.

Highlighted

@RealPaddy Closely following this also. Thanks for raising a ticket.

Highlighted

I am having the same issue on multiple tenants. @RealPaddy 

Highlighted

I have the same issue, hope they fix it fast, thanks for open a ticket :)

Highlighted

@RealPaddy 

This issue has also been flagged on GitHub  https://github.com/SharePoint/sp-dev-list-formatting/issues/208 so hopefully the right people are in the loop!

Highlighted

@RealPaddy They keep on suggesting we use the sp-dev-docs github for these general bugs. The latest update is here:

 

https://github.com/SharePoint/sp-dev-docs/issues/5251

 

Claiming it will take a couple of weeks to be implemented! It's also confusing because it's hard to verify the authority of the people making claims, unless it's someone obvious like Chris Kent.

Highlighted

 @dfurler @RealPaddy And others in the thread. This issue has been fixed an is in the deployment pipeline and should reach production in a week (if not already).

Highlighted
Highlighted

@SVaibhav 

I think this might be related to the list web part no longer respecting the turning off checkboxes in tabular view settings as well. Do you know if this will also be fixed with the update?

Highlighted

@SVaibhav 

thanks for the update - I will verify fix when it comes through

Highlighted

Hi @XopherDesign,

 

If you are referring to the "hideSelection" property of view formatter, I see it working fine now. Do let me know if you meant something else!