AIP Scanner - Unable to authenticate and setup Microsoft Azure Information Protection

Occasional Contributor

Hi All,

 

I'm getting stuck in below issues to test AIP Scanner.

 

Error

Set-AIPAuthentication : 

 

zwethuko_0-1624342986858.jpeg

 

 

As I worked through below the steps I had faced the following issue and cannot move forward.

 

https://github.com/MicrosoftDocs/Azure-RMSDocs/blob/master/Azure-RMSDocs/deploy-aip-scanner-configur...

or

https://alberthoitingh.com/2020/07/21/azure-information-protection-scanner-2/

 

I have done these steps

  1. Install Win Server 2019 & SQL Express on VM Workstation.
  2. Install AIP Client
  3. Install AIP Client on PowerShell and it's running in services.msc

              Install-AIPScanner -SqlServerInstance AIPSCANNER\SQLEXPRESS -Profile Cluster1

  1. Create AD on premise (GG.COM) and installed AD Connect (Express Setting) to Azure AD (testing.onmicrosoft.com)
  2. Create User on premise (aipscanner) role (Administrator) and sync to Azure AD (aipscanner@testing.onmicrosoft.com) and assigned E5 license.
  3. Login with GG\aipscanner  on Win Server 2019.
  4. Get APPID, App Secret, Tenant ID from Azure Portal
  5. I tried to get the token run below the command but no ok.

 

$pscreds = Get-Credential "testingtenant101.onmicrosoft.com\aipscanner"

 

Set-AIPAuthentication

-AppId "bac7ce5e-7a0b-40da-bb89-888888888"

-AppSecret "6192e5b8-afb0-49bc-9a0e-888888888"

-TenantId "623c0945-6ee5-42a1-8894-888888888"

-DelegatedUser aipscanner@testing.onmicrosoft.com -OnBehalfOf $pscreds

zwethuko_1-1624342986861.jpeg

 

I think something wrong in authentication on-premise to azure (-DelegatedUser). Please kindly help me to move forward.

 

0 Replies