Displaying "Person or Groups" columns from SPO

%3CLINGO-SUB%20id%3D%22lingo-sub-103715%22%20slang%3D%22en-US%22%3EDisplaying%20%22Person%20or%20Groups%22%20columns%20from%20SPO%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-103715%22%20slang%3D%22en-US%22%3E%3CP%3EI%20am%20trying%20to%20create%20a%20PowerApp%20that%20has%20a%20field%20that%2C%26nbsp%3Bamong%20other%20olumns%2C%26nbsp%3Bshould%20show%20a%20user%20from%20SharePoint%20Online.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EMost%26nbsp%3Bcolumns%20from%20the%20connected%20SP%20list%26nbsp%3Bare%20shown%20in%20PowerApps%2C%20but%20all%20%22Person%26nbsp%3Bor%20Groups%22%26nbsp%3Bcolumns%20are%20not%20there.%20I%20have%20tried%26nbsp%3Bto%20change%20the%20the%20columns%26nbsp%3Bfrom%20%22Name%20(with%20presence)%22%20to%26nbsp%3B%22Name%22%2C%20%22User%20name%22%20etc.%20but%20to%20no%20avail.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20assume%20that%20I%20am%20doing%20something%20wrong%2C%20but%20what%3F%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-103715%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EPowerApps%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3ESharePoint%20Online%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-103733%22%20slang%3D%22en-US%22%3ERe%3A%20Displaying%20%22Person%20or%20Groups%22%20columns%20from%20SPO%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-103733%22%20slang%3D%22en-US%22%3E%3CP%3EHI%20%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F28745%22%20target%3D%22_blank%22%3E%40Jakob%20Rohde%3C%2FA%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20might%20just%20have%20reproduced%20your%20problem.%3C%2FP%3E%3CP%3EIn%20the%20Value1%20below%20DisplayName%20was%20selected.%20I%20chnaged%20it%20to%20Email%20and%20then%20changed%20it%20back%20to%20DisplayName%20and%20now%20the%20user%20name%20is%20displayed%20correctly%20in%20my%20form.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20style%3D%22width%3A%20283px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Fgxcuf89792.i.lithium.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F19674i6F77C769927E45ED%2Fimage-size%2Flarge%3Fv%3D1.0%26amp%3Bpx%3D999%22%20alt%3D%22DisplayName.PNG%22%20title%3D%22DisplayName.PNG%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-103726%22%20slang%3D%22en-US%22%3ERe%3A%20Displaying%20%22Person%20or%20Groups%22%20columns%20from%20SPO%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-103726%22%20slang%3D%22en-US%22%3E%3CP%3EHi%20%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F28745%22%20target%3D%22_blank%22%3E%40Jakob%20Rohde%3C%2FA%3E%2C%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EHave%20you%20tried%20using%20the%20Data%20table%20control%20and%20Forms%3F%20Or%20are%20you%20using%20other%20controls%3F%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20style%3D%22width%3A%20134px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Fgxcuf89792.i.lithium.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F19673i4F329C80EA542543%2Fimage-size%2Flarge%3Fv%3D1.0%26amp%3Bpx%3D999%22%20alt%3D%22FormsControl.PNG%22%20title%3D%22FormsControl.PNG%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20just%20tried%20a%20Form%20and%20found%20that%20my%20user%20fields%20do%20appear%20as%20drop%20downs.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E
Frequent Contributor

I am trying to create a PowerApp that has a field that, among other olumns, should show a user from SharePoint Online.

 

Most columns from the connected SP list are shown in PowerApps, but all "Person or Groups" columns are not there. I have tried to change the the columns from "Name (with presence)" to "Name", "User name" etc. but to no avail.

 

I assume that I am doing something wrong, but what?

2 Replies

Hi @Jakob Rohde,

 

Have you tried using the Data table control and Forms? Or are you using other controls?

FormsControl.PNG

 

I just tried a Form and found that my user fields do appear as drop downs.

 

 

 

 

 

HI @Jakob Rohde

 

I might just have reproduced your problem.

In the Value1 below DisplayName was selected. I chnaged it to Email and then changed it back to DisplayName and now the user name is displayed correctly in my form.

 

DisplayName.PNG