Creating HTML Table from Filtered Array

%3CLINGO-SUB%20id%3D%22lingo-sub-126041%22%20slang%3D%22en-US%22%3ECreating%20HTML%20Table%20from%20Filtered%20Array%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-126041%22%20slang%3D%22en-US%22%3E%3CP%3EHello%2C%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EHoping%20this%20is%20easy.%20I%20get%20some%20SharePoint%20items%20using%20%22Get%20Items%22%2C%20I%20then%20Filter%20that%20array%20based%20upon%20an%20ID%20in%20the%20last%20using%20%22Filter%20Array.%22%20All%20good%20up%20to%20there.%20I%20then%20want%20to%20%22Create%20HTML%20Table%22%20based%20upon%20the%20filtered%20Array%2C%20but%20I%20cannot%20figure%20out%20what%20%3CEM%3Evalues%3C%2FEM%3E%20I%20should%20be%20putting%20in%20the%20Custom%20Columns.%20If%20i%20use%20the%20content%20from%20%22Get%20Items%22%20it%20creates%20a%20loop%20which%20I%20don't%20want.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThanks%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-126041%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EMicrosoft%20Flow%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1765768%22%20slang%3D%22en-US%22%3ERe%3A%20Creating%20HTML%20Table%20from%20Filtered%20Array%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1765768%22%20slang%3D%22en-US%22%3E%3CP%3EHi%20Joe%2C%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20realize%20this%20is%20an%20old%20and%20unanswered%20post%20-%20but%20did%20you%20get%20this%20issue%20figured%20out%3F%26nbsp%3B%20I%20have%20the%20same%20use-case%20and%20I%20am%20kind%20of%20stuck.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-2130084%22%20slang%3D%22en-US%22%3ERe%3A%20Creating%20HTML%20Table%20from%20Filtered%20Array%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2130084%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F1426%22%20target%3D%22_blank%22%3E%40Joe%20Fedorowicz%3C%2FA%3E%26nbsp%3BI'm%20having%20the%20same%20issue%3B%20did%20you%20ever%20resolve%20this%3F%20When%20I%20add%20values%20from%20the%20Get%20items%20phase%2C%20I%20get%20an%20Apply%20to%20each%20added%20to%20my%20Create%20HTML%20table%20step%20which%20I%20don't%20want.%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-2157745%22%20slang%3D%22en-US%22%3ERe%3A%20Creating%20HTML%20Table%20from%20Filtered%20Array%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2157745%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F965400%22%20target%3D%22_blank%22%3E%40cschneider1820%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20did%20finally%20get%20mine%20to%20work.%26nbsp%3B%20I%20created%20a%20quick%20example%20(%20mine%20wasn't%20as%20easily%20shareable%20).%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EPopulate%20array%20variable.%26nbsp%3B%20In%20this%20example%2C%20just%20insert%203%20%22rows%22%3A%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20image-alt%3D%22coyote_ptm_0-1614044229265.png%22%20style%3D%22width%3A%20400px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F256868iD5AFAB1049372B6A%2Fimage-size%2Fmedium%3Fv%3D1.0%26amp%3Bpx%3D400%22%20role%3D%22button%22%20title%3D%22coyote_ptm_0-1614044229265.png%22%20alt%3D%22coyote_ptm_0-1614044229265.png%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3EFilter%20array%3A%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20image-alt%3D%22coyote_ptm_1-1614044292337.png%22%20style%3D%22width%3A%20400px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F256869i2853677A4EB92E3A%2Fimage-size%2Fmedium%3Fv%3D1.0%26amp%3Bpx%3D400%22%20role%3D%22button%22%20title%3D%22coyote_ptm_1-1614044292337.png%22%20alt%3D%22coyote_ptm_1-1614044292337.png%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3EThe%20%22is%20equal%20to%22%20in%20advanced%20is%3A%20%22%40equals(item()%3F%5B'DocumentID'%5D%2C%2010)%22%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ESend%20output%20from%20%22Filter%20Array%22%20to%20%22Create%20HTML%20Table%22%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20image-alt%3D%22coyote_ptm_2-1614044380877.png%22%20style%3D%22width%3A%20400px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F256870i98ED4AA9D76ABA79%2Fimage-size%2Fmedium%3Fv%3D1.0%26amp%3Bpx%3D400%22%20role%3D%22button%22%20title%3D%22coyote_ptm_2-1614044380877.png%22%20alt%3D%22coyote_ptm_2-1614044380877.png%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThe%20%22From%20Body%22%20%3D%20'%40%7Bbody('Filter_array')%7D'%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThe%20%22Value%22%20%3D%20'%3C%2FP%3E%3CDIV%3E%3CDIV%3E%3CSPAN%3Eitem()%3F%5B%3C%2FSPAN%3E%3CSPAN%3E'DocumentID'%3C%2FSPAN%3E%3CSPAN%3E%5D'%3C%2FSPAN%3E%3C%2FDIV%3E%3CDIV%3E%26nbsp%3B%3C%2FDIV%3E%3CDIV%3E%3CSPAN%3EHere's%20the%20output%20of%20run%20for%20create%20html%20table.%3C%2FSPAN%3E%3C%2FDIV%3E%3CDIV%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20image-alt%3D%22coyote_ptm_3-1614044547108.png%22%20style%3D%22width%3A%20400px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F256871i8285A2F04F9054FC%2Fimage-size%2Fmedium%3Fv%3D1.0%26amp%3Bpx%3D400%22%20role%3D%22button%22%20title%3D%22coyote_ptm_3-1614044547108.png%22%20alt%3D%22coyote_ptm_3-1614044547108.png%22%20%2F%3E%3C%2FSPAN%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EHope%20this%20helps.%3C%2FP%3E%3C%2FDIV%3E%3C%2FDIV%3E%3C%2FLINGO-BODY%3E
Frequent Contributor

Hello, 

 

Hoping this is easy. I get some SharePoint items using "Get Items", I then Filter that array based upon an ID in the last using "Filter Array." All good up to there. I then want to "Create HTML Table" based upon the filtered Array, but I cannot figure out what values I should be putting in the Custom Columns. If i use the content from "Get Items" it creates a loop which I don't want.

 

Thanks

3 Replies

Hi Joe,

 

I realize this is an old and unanswered post - but did you get this issue figured out?  I have the same use-case and I am kind of stuck.

 

 

@Joe Fedorowicz I'm having the same issue; did you ever resolve this? When I add values from the Get items phase, I get an Apply to each added to my Create HTML table step which I don't want. 

@cschneider1820 

 

I did finally get mine to work.  I created a quick example ( mine wasn't as easily shareable ).

 

Populate array variable.  In this example, just insert 3 "rows":

coyote_ptm_0-1614044229265.png

Filter array:

coyote_ptm_1-1614044292337.png

The "is equal to" in advanced is: "@equals(item()?['DocumentID'], 10)"

 

Send output from "Filter Array" to "Create HTML Table"

coyote_ptm_2-1614044380877.png

 

The "From Body" = '@{body('Filter_array')}'

 

The "Value" = '

item()?['DocumentID']'
 
Here's the output of run for create html table.
coyote_ptm_3-1614044547108.png

 

 

Hope this helps.