MSIX Packaging Tool - Package Analyzer

Brass Contributor

I was using the 1.2023.1005 release of MSIX Packaging Tool after the October and November announcements and trying to experiment with the new Package Analyzer capabilities with a packaged MSIX through the Package Editor options.


However, when I initiate the Analyze Package option from the Package Editor, it moves through creating the temporary MSIX package, which I can see is created in %Appdata%/Local/Temp/MsixPackagingTool/DiagOutDir/Logs_*number*\ along with a number of other files including a config.json & other manifest files.

However once it moves the progress to Install MSIX Package it seems to stall.  The log file in the same temporary folder location, denotes the last entries show that it successfully signed the .MSIX package without warnings or errors, however there is no further information listed showing it is doing something.


I am carrying this analysis out in a HyperV virtual machine and have tried increasing the assigned memory from 2048mb to 4096mb and it isn't trying to use all that much of that.


In the absence of an up to date HyperV Quick Create iso image with an up to date MSIX Packaging Tool configured with this update, I have configured this in a disconnected environment.

I have since seen the recent updates including some bug fixes with version 1.2023.1212.0 and initially having installed this update, one of the MSIX packages I was trying to analyse passed through all the expected steps and return no fixup recommendations.  However checking other packages has resulted in the same progress bar stuck at Installing MSIX Package and after reverting the snapshots and trying with the same successful package it has hit similar issues.

Clearing the temporary files in the Settings area, doesn't appear to have helped either.

Are there any checks I need to make in terms of configuration to make this more reliable?

9 Replies
You might want to try the following PowerShell cmd: Get-AppXLog
This cmd will show progress via the log entries of the installation attempt and might provide a clue to the issue. You may also have to manually check the event viewer Microsoft\Windows\AppXPackagingOM logs for additional logging not included in the above.

Thanks for this @TIMOTHY MANGAN, having checked the event viewer over, the last entry in the AppXDeploymentServer\Operational area highlights some information that there some remaining cost associated with the Deployment Add operation on my package that potentially un-accounted for?

I have something similar to the article mentioned here.

Performance summary of Deployment Add operation on Package DemoApp_3.10.0.0_x64__xxxxxxxxxxxxx:
Overall time: 12984 ms
Enqueue cost: 531 ms
Dequeue delay: 78 ms
Bundle processing cost: 0 ms
Indexing cost: 625 ms
Resolve dependency cost: 31 ms
Check approval cost: 47 ms
Evaluation cost: 985 ms
Hardlinking evaluation cost: 31 ms
Gap: 15 ms
Stage required cost: 7203 ms
Flushing and closing files cost: 0 ms
Gap: 157 ms
Machine register cost: 265 ms
Stage user data cost: 78 ms
Gap: 47 ms
Registration cost: 1313 ms
Gap: 78 ms
Repository commit transaction cost: 1047 ms
Gap: 390 ms
Data flush cost: 16 ms
Post DeStage repository commit transaction cost: 0 ms
Remaining cost: 94 ms

The performance information you posted looks "normal". The "Gaps" seem to be just times that the performance logging knows were spent (by looking at telemetry timestamps that are recorded) but have no specific information about how it was spent.

You would be looking for warning/error events which would indicate potential issues..
I had to use the Get-AppxLog -all parameter to see the related output, but the information above seemed to be the last time stamped relevant output. Prior to that it appears have finished the Add operation, and I am able to launch the application from the start menu, but I see no way to nudge the "Installing MSIX Package" prompt along along. If I cancel it, i can't resume again, as selecting "Analyze Package" again fails as the application is already installed.

That's what I expected to find, although there are no errors, and the only warnings appear in AppxPackaging/Operational related to Declared namespaces which are inapplicable, and will be ignored during manifest processing.

I have some earlier errors prior to me starting the analysis related to AppExecutionAlias directory missing, with an an error code 0x8007010B, but appears at points where I had upgraded the MSIX Packaging Tool in the disconnected environment with the latest stable release.

Hi @GrahamGB 

This does not look like a Package Analyzer issue. 
We have replied to this thread - Re: What is the "gap" and how do I eliminate it? - Microsoft Community Hub, suggesting uninstalling the package, then retry the Package Analyzer and see if the issue persists. 


@Fizaami, i've tried closing the MSIX Packaging tool down uninstalled the MSIX package that had been installed from the Temp folder but after re-launching MSIX Packaging Tool, the Package Analyzer still cycles at the same point suggesting it hasn't finished installing.

I have also used the "Delete all temp files and logs generated" from within the Data and Settings options before re-attempting to no-avail.

Does the Package Analyzer rely on internet connectivity in some way? Are there any considerations for disconnected environments?


The Package Analyzer has the same experience for both connected and disconnected environments.
Are you observing this issue just for this particular package or is it happening for others as well?

It's happening for others as well @fizaazmi.