MSIX Hero - access to the path is denied

Copper Contributor

Hi All,


I'm kinda new to MSIX and app Attach for Azure Virtual Desktop, but I couldn't find any results so far searching the interwebs, so I hope you could help :)


I'm currently trying to create an MSIX app and App Attach volume of the application: Veeam ONE Client 11a.


I used the following tools for this:

  • MSIX packaging Tool : to create the MSIX package from the .exe
  • MSIX Hero: to create the app Attach volume (.vhd)


Now, I used the MSIX packaging tool to generate the MSIX package, which worked like a charm. I uninstalled the software and ran the msix package to see if it installs correctly, which it does.


But now, when I try to create the App Attach volume, using MSIX Hero, it throws me the following error message in the process of creation: "Access to the path 'f:\System Volume Information" is denied"


The process to create an app Attach volume isn't complicated at all, using MSIX Hero, you just:

  • Start MSIX Hero
  • Click on "Create app attach volume"
  • Select the msix package you want to create an app attach volume for
  • You press "Create Volume for app attach" and wait until the volume is created.

The first step it does is "unpacking MSIX" and during this step I can see in windows explorer/ disk management that an F:\ drive is created for a few seconds and disappears again, throwing the error message right after.


The silent command line that was used by MSIX hero, if this could bring any value:

msixherocli.exe appattach --createScripts --directory <output-directory> --package C:\Users\xxxxxxxx\Desktop\VeeamONEClient_11a\VeeamONEClient_11.0.1.0_x64__7ya6h5j0jvb2y.msix


I already tried:

  • Creating a VHDX instead of the recommended VHD file type,
  • Putting the MSIX package on C:\temp or the desktop to see if it had to do with permissions.
  • Recreating the MSIX package


Maybe to mention this detail, currently I'm creating these packages on an Azure VM (win11 21H2).


Thank you in advance,



3 Replies

@DavDef thank you for your question. MSIX hero looks like it's a third party tool, so troubleshooting that might be something you'd have to bring up with the owner of that tool. If you're interested in using Microsoft's tool, we do have a tool called Msixmgr which can help you create the VHD also. Azure has documentation on it- Using MSIXMGR tool - Azure | Microsoft Learn



MSIX Hero uses internally msixmgr.exe, and the error is actually coming originally from it. This is some rare scenario, including this report I heard of only one another user (albeit on an earlier version of Windows) reporting this. 


The relevant part in source code is here


You can try to start msixmgr directly, MSIX Hero should use the following arguments:

-packagePath <path-to-msix> -destination <destination> -vhdSize <calculated-vhd-size> -applyacls -create


Could you also open an issue in GitHub?



I never got this problem until today and still couldn't find a solution.

Using MSIX 3.0 or the latest version of msixmgr I can no longer create VHD or VHDX images. When I try the msixmgr command line I get this error that leads me nowhere:

Successfully created virtual disk
Stopping the Shell Hardware Detection service
Stopping dependent services if necessary.
Successfully initialized and partitioned the disk.
Formatting the disk.
Formatting the disk failed with error code: 12
Visit to translate error code
Starting the Shell Hardware Detection service
Successfully started the Shell Hardware Detection Service
Creating the VHD(X) file C:\Users\B...\Your Application-x64.vhd failed with HRESULT 0x80004005
Best-effort attempt to delete the incomplete VHD(X) file C:\Users\...\Your Application-x64.vhd succeeded.

I have plenty of available space on my machine and this is a small 1 MB package that I am testing for the conversion.