Installation through manifest (.appinstaller file) fails with code 0x80072F76

Copper Contributor

Dear community, 


We are rather new to the entire AppInstaller realm and have run into a situation we simply cannot get our heads around. We have an application we have packaged as an .msix and would like to install by the use of a manifest-file (.appinstalled XML file) we serve from the applications server (which we also develop).


Below is an example of the .appinstaller-file (which our local AppInstaller-components on our local Windows 11 machines won't install successfully using). Same behavior on all hosts so likely no “broken” AppInstaller-component causing this.


If we, however, download the .msix-packages manually from the same URL. ( as stated in the manifest it installs without any problems.. 


The appropriate certificates are in place as far as we can tell and no "complaints" about failing certificate chains are appearing. 


The full error message we get is "App installation failed with error message: Appinstaller operation failed with error code 0x80072F76. Detail: Unknown error (0x80072f76)"


This has worked properly before (we believe) and we feel as this is something that "just happed" one day. Perhaps caused by an update of the AppInstalled-component, or not - regardless - we need to understand what and why this is happening. 


<?xml version="1.0" encoding="utf-8"?>
Uri="" xmlns="">
<!--AppInstaller file generated by VidiView on 5/23/2023 3:14:01 PM UTC-->
Publisher="CN=Distributed Medical AB, O=Distributed Medical AB, S=Skåne län, C=SE"
ProcessorArchitecture="x64" />
Publisher="CN=Microsoft Corporation, O=Microsoft Corporation, L=Redmond, S=Washington, C=US"
ProcessorArchitecture="x64" />
HoursBetweenUpdateChecks="0" />

2 Replies
In case you are not aware, Microsoft disabled using an external appinstaller xml file due to security concerns. They added the capability for it to be inside the package instead, and later also created a group policy that you can use to re-enable the external file capability. What was disabled is technically the protocol handler used. See this for how to enable:



Thank you Timothy for your swift reply. I was not aware of this (and will certainly look into the matter and see if it relates). It does not seem to be the problem, but you never know. :) 


On that same note - when and if Microsoft decides to do such (rather fundamental) changes - how does one retain this knowledge/insight in a structured way? I’m an applications developer first and foremost and does not have a lot of experience with application packing and application deployment techniques. I usually use whatever is “current” and usually this has worked out fine (for the past 20 years).


Now – however – it’s gotten extensively complicated (mainly for efforts in making the process more secure, I presume/understand) but still – one needs to do this and one needs to understand the underlying concepts and “visions” of Microsoft. Is there a place (wiki, blog, release notes, anything) where changes, new features, guidelines etc. are publicly available – in relation to (Desktop) AppInstaller? So one can catch news such as the one you are informing me about now?


And more importantly – when you run into some trouble like this with “code 0x80072F76 – Unknown error” situations and absolutely no logging (anywhere I’ve been able to find) – where is the support or – even better – the documentation? 


Perhaps you (who seems well versed in this area) or anyone else in the community knows or can share useful resources for beginners like myself?