Cannot Sign in Power BI Account in DA-100 Lab Units

New Contributor

In the DA-100 course, lab unit (, it's required to login to Power BI account but I had problem in login, it reports error as below. Sign in 1.pngSign in 2.png




25 Replies

@Sunny000I myself was able to use Power BI inside the labs environment (without logging in). Please note that the lab mentions to close the initial pop-up asking for login credentials.


@mdeconinck, yes, you are right that the lab mentions to close the initial pop-up asking for login credentials. During the lab, we are tasked with getting Power BI data sets or publishing the dashboard, which requiring login. On this circumstance, I failed to login with my account.Publish Step.png


I have the same problem.


I have tried to reach out to LODS Help Desk Team, but the only response I'm getting is this:

"The only other thing we can suggest is that whatever other Microsoft service you are logged into I would log off that then try again."


Did you manage to find another solution?

please i am having the same issue now

were you able to sign in?  @Sunny000 

Power BI Desktop can't connect to the internet in the lab so you need to use the Edge browser. Save your file in Power BI Desktop and open Edge. Click on Power BI service in the toolbar and log in. Once logged in, click on My Workspace | Add Content | Files | Local File | Browse to the file you saved earlier and you'll have your Dashboard and Reports
I am unable to sign-in as well. It lab notes says something about signing in with the account details provided. Unfortunately, no such details were provided anywhere.

It is a disappointing that Microsoft is directing a lot of people to these modules as part of their ignite cloud challenge, but the labs do not work.
Initially I was not able to connect to the internet, when I re-opened the lab, the internet seemed to work. However, there were no credentials anywhere in sight that I could use.
I am also a bit reluctant to use my work account to do these labs due to security concerns.

This is a way that I did.

I learned after taking Lynda course on Power BI Desktop.

During this course, it mentioned about this way around.

I signed up for "Office 365 E3 Trial".
You will set up email address like "".
You could use that email address going forward.

It works for me now.

It's an ssl issue because you are not in Microsoft's timezone.

Go to the adjust date time, set timezone and time manually.

You can then sign in as normal.
I have tried it and changed the time zone to my one. But how shall this work together with the login issue? I mean, I have no credentials and changing the timezone didn't fix this issue.
it depends on what your issue is. The ssl issue resolves the fact that you don't get a login prompt but just a timeout error. If you get a prompt but you don't have any credentials, then you need to make an account.
It does feel strange that MS would not provide temp lab-specific user accounts. Signing in with our regular organization accounts is hit or miss for these labs. I also struggled with this.
Now I got a vaid information here: from Julian Sharp: You need to ask to your training provider ...
Thanks for the extra context. Microsoft should definitely reconsider their stance because the DA-100 self-paced training+labs are really well organized and I would think that the majority of participants would choose self-paced over instructor led. I hope that the lack of DA-100 user accounts is just an oversight that will be remediated soon! Fingers crossed.

Having the same issue. such a shame, i got all the way to the 8th lab before being unable to continue due to this. These labs are a phenomenal learning tool and have been a huge help.




as I explained.  change your timezone..on the lab virtual machine, open the clock, find the timezone setting, change it to manually set it, and set it to your timezone.

@Sunny000 Struggled with this for a bit... but clicked the lightning bolt at the top left in the black bar across the top... there was an option to 'Type Password', when it is clicked it typed a password and resumed my session! 


I tried this and the UserName it put in was "student" - but then there was an error that the username was turned off for sign in.  I put and it went to the password screen, but the password in the lightning bolt menu didn't work

So I still can't get in - but thank you for pointing the menu option out!

Now the DA-100 team just needs to update the text they will populate so we can use it

Hi @Christine37, I am also stuck at this level, have you found a way around it?