SOLVED

Uninstalled Apps keeps showing in Discovered Apps

Occasional Contributor

Hi, does anyone encountered a scenario that after uninstalling an application on user device, the application is still showing up on the Device Discovered apps?

 

We have a situation where we are manually uninstalling old versions of Python. The app is totally remove and can't be search on the machine but still getting detected by the Intune.

 

I found the registry where the discovered apps seems to be registered at

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\IntuneManagementExtension\Inventories\

 

However, even after manually deleting the registry key it keeps on coming back.

 

12 Replies
Hey @crsmr05, let me dive deeper into this topic to understand how the IME collecte the discovered apps.
Can you check programs and features if the app is also not listed here.
best response confirmed by crsmr05 (Occasional Contributor)
Solution

@crsmr05:
Can you check if the last FullSync was after the unistallation of the app: Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\IntuneManagementExtension\InventorySetting

 

Jannik_Reinhard_0-1657312398480.png

 

@Jannik_Reinhard thanks for your response. Yes it is also not showing up in the programs and features. I also removed the left overs in the program files as well. 

@Jannik_Reinhard, I've checked today and yes it was up to date.

@crsmr05 If you check the IME code you see how the inventory is captured.

Jannik_Reinhard_0-1657551128064.png

 

Can you try to run a PowerShell as admin and execute the following command:  

 

GWMI Win32_InstalledWin32Program

 

Check if you can find here the application.

 

 

 

@Jannik_Reinhard, I checked and confirmed that the app is not listed on the InstalledWin32Program list after running the command. I was able to reproduce the scenario by following the steps below.

 

I also check the left overs of the app on the following registry path but it's all clean.

 

HKLM:\SOFTWARE\
HKLM:\SOFTWARE\Wow6432Node\
HKCU:\SOFTWARE\
HKCU:\SOFTWARE\Wow6432Node\

 

Do you know which registry is responsible for sending Win32 app details from user machine to Endpoint discovered apps? is it HKLM\SOFTWARE\Microsoft\IntuneManagementExtension\Inventories?

What happens when clearing this content of this value LastFullSyncTimeUtc in that reg key
Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\IntuneManagementExtension\InventorySetting

@Rudy_Ooms_MVP I tried deleting the InventorySetting reg key, and it recreated after full sync. However, it doesn't help. I can still see the app showing in Endpoint discovered apps.

@crsmr05 : This is the registry path where the Inventory is written:

 

Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\IntuneManagementExtension\Inventories\

 

Jannik_Reinhard_0-1657636415119.png

You were already right

@Jannik_Reinhard I tried again today and finally it worked by doing the steps below which completely removes the win32 app. After another full sync and confirming that the win32 app is no longer showing in IntuneManagementExtension\Inventories\ registry, the app stops showing in the endpoint discovered apps as well.

 

1. Delete InventorySetting reg key

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\IntuneManagementExtension\InventorySetting

 

2. Search and delete the the win32 app reg key in

Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\IntuneManagementExtension\Inventories\

 

3. Do a full sync of the device

@crsmr05 : Very good I am glad if it works now. I hope my help has been useful to you.

Of course! Thanks a lot again :)