SOLVED

MDM Session: OMA-DM session ended with status: (Unknown Win32 Error code: 0x80072f0c)

%3CLINGO-SUB%20id%3D%22lingo-sub-1816163%22%20slang%3D%22en-US%22%3EMDM%20Session%3A%20OMA-DM%20session%20ended%20with%20status%3A%20(Unknown%20Win32%20Error%20code%3A%200x80072f0c)%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1816163%22%20slang%3D%22en-US%22%3E%3CP%3EHi%2C%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EAn%20increasing%20number%20of%20devices%20are%20getting%20a%20non%20compatible%20status.%20Is%20active%20is%20non-compatible.%20When%20inspecting%20the%20event%20logs%20with%20event%20viewer%20I%20see%20the%20following%20error%20message.%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EMDM%20Session%3A%20OMA-DM%20session%20ended%20with%20status%3A%20(Unknown%20Win32%20Error%20code%3A%200x80072f0c)%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThis%20error%20code%20did%20not%20lead%20to%20any%20results%20after%20a%20search%20on%20the%20internet%2C%20so%20I%20thought%20let's%20try%20it%20here.%20Does%20anybody%20have%20any%20ideas%20how%20I%20can%20resolve%20this%3F%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThanks%20a%20lot%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EBest%20wishes%3C%2FP%3E%3CP%3EMartin%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-1816163%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EIntune%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EMobile%20Device%20Management%20(MDM)%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1936227%22%20slang%3D%22en-US%22%3ERe%3A%20MDM%20Session%3A%20OMA-DM%20session%20ended%20with%20status%3A%20(Unknown%20Win32%20Error%20code%3A%200x80072f0c)%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1936227%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F845139%22%20target%3D%22_blank%22%3E%40martingroen%3C%2FA%3E%26nbsp%3BDid%20you%20ever%20get%20any%20help%20for%20this%3F%20I%20am%20having%20the%20exact%20same%20problem%2C%20thanks%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1937247%22%20slang%3D%22en-US%22%3ERe%3A%20MDM%20Session%3A%20OMA-DM%20session%20ended%20with%20status%3A%20(Unknown%20Win32%20Error%20code%3A%200x80072f0c)%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1937247%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F845139%22%20target%3D%22_blank%22%3E%40martingroen%3C%2FA%3E%26nbsp%3BYes!%20That%20is%20exactly%20what%20happened%20with%20ours%20as%20well!%20We%20upgraded%20to%20edition%2019041%20(2004)%20and%20these%20workstations%20immediately%20stopped%20checking%20in%20to%20Intune%20and%20now%20we%20cannot%20re-enroll%20them.%20What%20do%20you%20mean%20by%20%22resetting%20the%20Windows%20installation%22%3F%20Do%20you%20mean%20you%20rolled%20back%20the%20upgrade%3F%20Unfortunately%20I%20am%20not%20in%20the%20position%20to%20do%20that%20because%20we%20require%202004%20for%20full%20Windows%20Defender%20Application%20Control%20functionality%20with%20custom%20OMA-URIs%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1938340%22%20slang%3D%22en-US%22%3ERe%3A%20MDM%20Session%3A%20OMA-DM%20session%20ended%20with%20status%3A%20(Unknown%20Win32%20Error%20code%3A%200x80072f0c)%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1938340%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F845139%22%20target%3D%22_blank%22%3E%40martingroen%3C%2FA%3EHey%2C%20I%20worked%20on%20this%20today%20and%20was%20able%20to%20resolve%20it%20on%20several%20computers%20without%20resorting%20to%20reinstalling%20Windows%2C%20if%20you%20are%20interested.%20First%2C%20I%20removed%20the%20computers%20from%20the%20AAD%20Connect%20sync%20and%20GPO%20scope%20and%20completely%20purged%20them%20from%20Intune%20and%20AAD.%20I%20then%20ran%20dsregcmd%20%2Fleave%20from%20an%20elevated%20command%20prompt%20on%20each%20workstation%20console.%20Next%2C%20navigate%20to%20the%20following%20registry%20hive%20on%20each%20impacted%20workstation%3A%26nbsp%3BHKLM%5CSOFTWARE%5CMicrosoft%5CEnrollments.%20Delete%20as%20many%20GUID-named%20keys%20as%20possible%20from%20this%20directory%20(example%20attached).%20Ignore%20any%20keys%20that%20cannot%20be%20deleted.%20Now%20restart%20the%20workstation%20and%20add%20it%20back%20to%20the%20AAD%20Connect%20sync%20and%20GPO%20containers%2Fgroups.%20Once%20I%20logged%20back%20in%20with%20a%20MEM-licensed%20AAD%20user%20(user%20auto%20enrollment)%2C%20my%20devices%20were%20once%20again%20managed%20by%20Intune%20within%20the%20next%20~15%20minutes.%20Good%20luck%20and%20thanks%20for%20your%20collaboration%20on%20this!%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E
Occasional Contributor

Hi,

 

An increasing number of devices are getting a non compatible status. Is active is non-compatible. When inspecting the event logs with event viewer I see the following error message. 

 

MDM Session: OMA-DM session ended with status: (Unknown Win32 Error code: 0x80072f0c)

 

This error code did not lead to any results after a search on the internet, so I thought let's try it here. Does anybody have any ideas how I can resolve this?

 

Thanks a lot

 

Best wishes

Martin

 

11 Replies

@martingroen Did you ever get any help for this? I am having the exact same problem, thanks

@NFederico No one offered any help. It is a weird error message. I couldnt find any mention of it on the internet.

What version of Windows 10 are you on? This happened with a couple of laptops that had upgraded themselves to Windows 10 20H2. I resolved the matter by resetting the Windows installation from the cloud. Now they are happily syncing again with Intune.

 

Best wishes

Martin

@martingroen Yes! That is exactly what happened with ours as well! We upgraded to edition 19041 (2004) and these workstations immediately stopped checking in to Intune and now we cannot re-enroll them. What do you mean by "resetting the Windows installation"? Do you mean you rolled back the upgrade? Unfortunately I am not in the position to do that because we require 2004 for full Windows Defender Application Control functionality with custom OMA-URIs

@NFederico Annoying isn't it. Seems to be some bug that MS have forgotten to address. ;)

 

Anyway, I didn't downgrade, I just downloaded a fresh install from the cloud. This is a new option in Win10 2004 that is extremely useful. I followed these steps

 

Optimize Windows 10 PC reset using the cloud

 

, making sure I clicked on the 'Keep my files' option. Unfortunately, I had to repeat this procedure with every laptop; it's very time consuming.  But the colleagues get to keep their files and Intune syncing resumed so I could enforce my policies again and indeed enforce Advanced Threat Protection again and firewall policies. @microsoftsupport could you correct this before you release version 2101? 

best response confirmed by martingroen (Occasional Contributor)
Solution

@martingroenHey, I worked on this today and was able to resolve it on several computers without resorting to reinstalling Windows, if you are interested. First, I removed the computers from the AAD Connect sync and GPO scope and completely purged them from Intune and AAD. I then ran dsregcmd /leave from an elevated command prompt on each workstation console. Next, navigate to the following registry hive on each impacted workstation: HKLM\SOFTWARE\Microsoft\Enrollments. Delete as many GUID-named keys as possible from this directory (example attached). Ignore any keys that cannot be deleted. Now restart the workstation and add it back to the AAD Connect sync and GPO containers/groups. Once I logged back in with a MEM-licensed AAD user (user auto enrollment), my devices were once again managed by Intune within the next ~15 minutes. Good luck and thanks for your collaboration on this! 

@NFederico Thanks! Very interested. A much more elegant solution than mine :)

 

Cheers, Martin

@martingroen 

We are seeing this on our intune devices - brand new out of the box from the Department of Education.  Autopilot configured.  I've done a reset windows autopilot and still have this issue.

 

Do I need to log it with MS Support?

 

I came across it because I was hunting to find out why my devices weren't compliant and Chrome ADMX ingest wasn't working.

@John Dooley IT Yes, I am afraid so. This is an error that has not been addressed by MS Support yet, as far as I am aware.

My solution to reinstall windows 10 20H2 from the cloud was rather crude and Federico's solution was more elegant. 

 

But this should not occur in the first place, of course.

 

Good luck!

 

Martin

Thanks - when you say reinstall from cloud, are you referring to the new feature in 20H2? I’ve not used this feature yet but I believe it was go live for this feature release?

Autopilot reset therefore won’t fix this issue?

Thanks
John

@John Dooley IT Hi John, I am indeed referring to the new 20H2 feature. This works perfectly, with a good internet connection. 

 

The problem I had was that MDM sync wasn't happening. Everything worked fine on the laptop itself, only the MDM sync didn't work with that mysterious error code as a result. I did a extensive search on the internet for more info on this error but to no avail. So, I decided to try this new cloud reinstall feature. And that helped. Apparently, during the previous update to 20H2 something went wrong which was corrected this time around. 

 

I'm not using autopilot yet, but am planning to start using it. Hopefully that will make it easier to locate the source of these issues?

 

Thanks

Martin

@NFederico Great work. We had the same issue on a company device and we could fix it with these steps. Hopefully Microsoft will fix this in a future update soon, because this problem is blocking our deployment of 20H2.