Intune - Company Portal Issues with MDM Android tablets

Brass Contributor

We have noticed that some of our Samsung tablets that use Android 7.1 started having issues with our managed apps, such as outlook, word, excel and more. We were not able to open any apps and when we attempt to, the app just crashes.


No changes have been made to our policies and all apps are up to date.


We tried to fix the issue by removing company portal and the work profile on the affected device, then we tried to enrol the device again. This seems to start off fine, as we were able to login and get past MFA, but every time the device tries to register, company portal crashes!


As an extreme workaround, we have to wipe the affected device and then we can enrol it back into intune.(This is far from ideal)


We have lots of tablets that have been affected and each day we see much more tablets having the same issue.


Has anyone had a similar issue?

26 Replies
I have seen this issue when there were issues with app protection policies?

Do you have those in place or are you requiring some conditions through conditional access?

@Thijs Lecomte 

Hey Thijs, yes we have app protection policies applied for all of our managed apps.


We also have conditional access in place too.


But wiping a tablet back to factory reset, removing all instances of that device from intune and enrolling it back via company portal, seems to have fixed the issue.


Is there way I can do this without wiping the tablet and keeping it enrolled?




could you check the sign-in logs in AzureAD and check where exactly it's failing.

I had an Android phone fail because I used the 'require app protection policy' and switched to 'require approved app'



Exactly the same problem here, we have 70 Android smartphones (Android version is 7.1.2) which begin to fail one after the other, Outlook, Word, Excel crash at the autentification process.



We ask Microsoft with no answer at this time, some help will be much appreciated !!



We've got the same issue on our Samsung A5 phones.
Thanks, I will try that with one of the troubled users in a moment and get back to you with an update

Most appreciated.

I have logged a ticket with Microsoft and their Dev team is looking into it..

Still no solid explanation from them, I will keep you posted on any news.

not good.. I've noticed there has been updates to Intune company portal and outlook in the last 2 days for Android.

I will keep you posted on any new revelations.

We tried to install Office manually from the playstore, exact same version as the one insalled with Intune and it works

We have no conditional strategy applied,


Will keep you inform too



Yammer works, it seems to be a problem with the authentification system of Word, Excel and outlook
Yes we had exactly the same results too.. It seems to be an issue with Intune..

@Thijs Lecomte 


Upon trying to re-enroll an affected user and tablet back into Intune, I can see that Microsoft Intune Company Portal signs in successfully from the Android tablet, then the Microsoft Authentication Broker, both are successful.


..then company portal crashes on the tablet and nothing..


So just to clarify, if the tablet was enrolled, we just access access any managed apps and if we attempt to re-enrol it, this happens


Any ideas?

After reading the Logs, it seems the problem appears after this update :


Initiated by :

Device Registration Service
Microsoft ADO.NET Data Services
Property name : 
Included Updated Properties
OLD value : nothing
New value : ""

@obisch2440 I will look into this and let you know what I find, thanks for the update.


Also check: Intune ->Device enrollment -> Incomplete user enrollments: then Export the list


I've seen lots of failed enrollments with the result of abandonment, it does not give a clear indication on what is happening but it's something to go on.


Also have you tried to factory wipe your device and enrol it again?

Thank you, i will take a look

No i haven't try the factory reset. I have still no news from Microsoft
Keep me updated, as that will change the the device id in Azure and you should be able to enrol the device again.

Let me know how that goes?
Yes i will let you know

Thank you
Good morning, just a quick update.

Microsoft are definitely looking into this and aware it's affecting multiple clients, so I hope they will have a fix soon.

I will update you when I have some more news.



Hi Chris, yes i revived Microsoft this morning. Will keep you inform too.


Thank you

1 best response

Accepted Solutions
best response confirmed by ChrisWork (Brass Contributor)


After many days spent troubleshooting with Microsoft, the issue seemed to be with the Android OS.
Which I can confirm has been fixed by Google, to fix the bug you have to install Google Chrome on your Android devices.

I have made it a required app and pushed it out via Intune.

Please give that a try and let me know how it goes?

View solution in original post