Edge - app protection policy

Copper Contributor

I have a App protection policy (also created in conditional access), where issues appear when adding Edge.

Without adding Edge to app protection policies, I can open edge - and there is a message that edge is not part of any protection policy, which is correct

When I add edge to app protection policy, it start up with "checking app" and then edge just close. If I try and open edge one more time, it just closes right away (without even "checking app" appear)

I have tried on several devices, and it is the same issue. So what must be done to to get edge working with app protection policy. I tried for test just create an default app configuration policy with edge - but still same

6 Replies

Hi @rossonero,

Based on the information you have provided, you can try this:

  1. Verify that the app protection policy is configured correctly. Make sure that the policy is targeting the correct users and devices, and that the settings are configured as expected.
  2. Try disabling the conditional access policy temporarily and see if the app protection policy works. If it does, then the issue is likely with the conditional access policy.

Please click Mark as Best Response & Like if my post helped you to solve your issue.
This will help others to find the correct solution easily. It also closes the item.

If the post was useful in other ways, please consider giving it Like.

Kindest regards,

Leon Pavesic

@LeonPavesic I have the same issue, it started with version 118 which was released the other day for iOS. No issues with version 117. Once you update to 118 and sign in with an account that uses app protection with conditional access, Edge will close. It doesn't appear to be affecting Android devices. 

OK interesting, that I just hit issue. Thought it was me that was missing something - but I really have set nothing up in the app protection policy, besides just adding edge, so cannot see why something should be done wrong

Do you have a conditional access policy that requires an app protection policy for grant access?
Looks like they fixed it in today build, version 118.2088.60
yes seems the new version is working