Cannot delete device

Copper Contributor

Hi I have problem with deleting old device from Intune.

The device was manualy factory reseted by user and now I cannot delete it from Intune. The DELETE "button" is freezed.

Can anyone give me solution, how to solve this issue?


4 Replies

Hi Tomas,


Try to click the "Remove Company Data" button first.  That should then enable the Delete button.


Let me know if that works for you.





best response confirmed by Ronni Pedersen (MVP)

Hi, yes that´s the way. But after click "Remove Company data" you have to wait few days, maybe one week and after that you are able to "delete" this device.

Thank you.

Are you sure?  I was able to click delete immediately after wiping...


I tried it again and you are right. Now it works. But before in my case I was unabble to delete device immediately after wiping.

Maybe it was only on devices wich were uncorrectly unenrolled from Intune, or hard resetted by end user. Intune was triyng to contact these devices for some days and after that enabled the DELETE button.

I guess...