Autopilot Error (0x81036502) - Endpoint Manager

Brass Contributor

Dear community members,


I am facing an issue with my Endpoint Manager's autopilot feature. It suddenly stopped working and I am receiving error code 0x81036502. I would greatly appreciate any help or advice on how to resolve this issue. 


According to my research, this error is related to either a timeout issue or with the Windows 10 version 22h2. I am running Windows 10 version 22h2 on my endpoint.  I have tried several troubleshooting steps but to no avail.



If anyone has any information or suggestions, please share them with me.


Thank you for your time and assistance.


Best regards,

Rashad Bakirov


24 Replies
best response confirmed by rashadbakirov (Brass Contributor)
Solution :p

just use my blog as your own personal google search....
Lets start by looking at which apps you configured as required apps during the esp
If you know the apps... use mn his get-autopilotdiagnostics tool to determine which app has a wrong install status ... or by looking at the registry

I guess with a little bit of searching you will find the culprit
Solved. Hi, thank you very much for your answer.
We have many apps configured as required apps on ESP, and a few days before one of these apps was updated by software teams, and the new version has an installation error, which we missed.

Hi - i am having the same issue, please advise me which apps were updated thanks@rashadbakirov 

@rashadbakirov The solution and suggestion described herein is a fallacy, respectfully to the previous posters this issue is much bigger than what it appears and has nothing to do with a "smoking gun" bad app error which was the case in this specific instance and that further diluted the true problem identification. 


This error is 22H2 error and was introduced into 22H2, same exact profiles and Auto Pilot setup does NOT trigger the same error, as long as Windows 10 version is less than 22H2 - for example 20H2 works just fine.


So, does anyone know what's going on with 22H2





That error the op mentioned it a time out error… that could occur because alot of reasons.. but when the esp is failing it apps, its because of an app failing…
@Rudy Respectfully if it was time out why does it NOT occur with 20H2 but only with 22H2?
Without knowing the esp required apps and without having any logs it could be anything. Maybe the app has some prereqs that need to be installed and maybe windows 22h2 has some other ideas for it…

I just had the same problem, never have an issue with Autopilot usually but today had the error on the device stage when using Win 10 22H2 (I usually use 21H2). I removed Dell Command Update 4.7.1, Edge and M365 apps from my ESP required apps and it worked. My remaining required apps were ESET agent and Teamviewer. Might be a fluke but thought I would post in case related.


Did have a strange issue on this job though, brand new Dell out of the box and it would not start autopilot process even though the device hash was uploaded and profile assigned. It did start when I clean installed 22H2 but had the error, I clean installed 21H2 and autopilot did not start so altered ESP apps and reinstalled 22H2.

I'm honestly new to the Intune game but have started experiencing these errors as well. I'm leaning toward some type of update issue. If the device gets the error, then I let it sit, you can hear the laptop fans spin up and down, and eventually you can get past the error after a few reboots. The system seems to time out on an app that's supposed to be there, but is part of an update not yet deployed.

Hello world


I may have worked out how to find and resolve this.


When the device throws up the error, press Shift + F10 to open a cmd prompt. Open regedit.




Here you'll see all win32 apps being deployed. We only deploy win32 apps but you may have some other registry locations with apps in. You'll find them in this general area anyway.


Look for a registry value of 4. This app has failed installation is likely what caused the issue. Make a note of the app ID string.


Use the app ID string to go to the app in Intune


I had to actually go in to the app, and visually find the app id, pasting it didn't work. I might have had an incorrect URL.


Anyway, that's how you find the app causing issues. Exclude it and you'll find ESP works fine.






Good spot, will try that if I encounter the issue again. Thanks for sharing

Shift-F10 does not work for me at this point.

Additionally, when I click "Collect Logs", it opens a dialog to choose a destination for the log files and then... nothing.
This is using the bog standard Windows 10 ISO available from Microsoft.

@IlsaL the Dell laptops we received require the FN lock to be set before you can just use Shift+F10.  Or... you can use Shift+Fn+F10.  Works for me.


I tried it today when I encountered the error and it was Dell Command Update, this time I was installing using a winget script whereas before I packaged the universal app installer. Great find so thanks for sharing, to other Dell users, it looks like we need to install after ESP.


In MEM the error is "The application was not detected after installation completed successfully (0x87D1041C)" so I am going to check my detection script.


@rashadbakirov We are experiencing this issue with a single machine. We are noticing all required and non-required apps fail to install during ESP with error code 0x800711C7, which according to some posts online like this one the error code means "HRESULT_FROM_WIN32(ERROR_SYSTEM_INTEGRITY_POLICY_VIOLATION), "Your organization used Device Guard to block this app. Contact your support person for more info."", which apparently presents itself when running Windows in S-Mode, but this is not the case here, the machine is freshly installed from Microsoft with the latest version of Windows 10 22H2.


We are now going to try with older versions of Windows 10 like 21H2, I'll update this post if it works.





This helped me alot and saved me tons of time, thank you!


As of today 5/24/2023 the internal Intune "Microsoft 365 Apps for Windows 10 and later" install only sporadically, 4 out of 5 deployments fail, and 1 succeeds with 100% identical hardware and configuration. I had to remove the apps from the group in order to permit ESP to complete successfully. If this is not some royal Intune MEM screw up I don't know what is: 




Did you find the root cause of your failure? Did older version of Windows 10 work? Thanks
I've been fighting with this myself for 2 days.......I thought it was me.