Channel MonthlyEnterprise

Brass Contributor

The MonthlyEnterprise channel is not working with the latest ODT that is available as of today.


ODT: 16.0.14326.20404

23 Replies
Hi Kevin, can you clarify what behavior you're seeing that you don't expect? Can you explain your scenario and share the config.xml file you're using?
Error code 0-2015 (2250)
<Add OfficeClientEdition="64" Channel="MonthlyEnterprise" MigrateArch="TRUE">
<Product ID="O365ProPlusRetail">
<Language ID="MatchOS" />
<ExcludeApp ID="Groove" />
<ExcludeApp ID="Lync" />
<ExcludeApp ID="Bing" />
<Property Name="SharedComputerLicensing" Value="0" />
<Property Name="SCLCacheOverride" Value="0" />
<Property Name="AUTOACTIVATE" Value="0" />
<Property Name="FORCEAPPSHUTDOWN" Value="TRUE" />
<Property Name="DeviceBasedLicensing" Value="0" />
<Updates Enabled="TRUE" />
<RemoveMSI />
<Setup Name="Company" Value="Removed Company Name" />
<Display Level="None" AcceptEULA="TRUE" />
I was connected to a working Wi-Fi connection, yet it immediately threw the message:

Couldn't install We're sorry, we had a problem installing your Office program(s). Is your internet connection working? Do you have enough free space on your main hard drive? Please try installing again after you've checked the above. Go online for additional help. Error Code: 0-2015 (2250)
Hi Kevin, it looks like this error code is indicating a connectivity problem on your device. I'm able to successfully run the ODT to download and install with MEC so it doesn't appear to be a bug. I would suggest verifying your connection, trying on a wired connection, or using a different PC.
is caused by a bug of lastest setup.exe, seems it does not know "MonthlyEnterprise"
older setup.exe works
Agree. I was trying from a working network connection and switching the channel allowed the ODT to function... I forgot to put that tidbit in my original post. I also, tried another PC with a wired connection... same outcome with that build of ODT.
Hello, thank you for this information. Can you please clarify which build of ODT you are using that does work?

i tested with

April 13, 2021 Version
Version 16.0.13901.20336 (setup.exe version 16.0.13901.20328)

as i had no newer (beside latest but affected) available


I just found the 
July 12, 2021
Version 16.0.14131.20278 (setup.exe version 16.0.14131.20278)
and it seems to work normally 

so just the latest
Sept 16, 2021
Version 16.0.14326.20404 (setup.exe version 16.0.14326.20384)
seems to be affected

new Version 16.0.14527.20178 (setup.exe version 16.0.14527.20144)
have same error

I can confirm this behavior. I can download every single channel in 32-bit and 64-bit. Only MonthlyEnterprise fails with an absurd error message.




We identified a bug in ODT which prevents the use of /download for the Monthly Enterprise Channel when the command is launched without admin permissions. This is not the intended behavior and we are working on a fix. Current workarounds are: a) use an ODT release prior to the September update or b) run the /download command from an elevated prompt.

@Kevin Taber 

January 13, 2022

Version 16.0.14729.20228 (setup.exe version 16.0.14729.20228)

  • Fixed issue where downloads or installations would fail under certain network proxy configurations
  • Fixed issue where downloads from the Monthly Enterprise Channel would fail from unelevated contexts
Hello there, I'm trying to download MonthlyEnterprise now with setup.exe (16.0.15629.20196 and 16.0.16026.20162). Both refuses to download MonthlyEnterprise channel. However Monthly works fine.
I get the same error as above (0-2015 (2250))
Just tested in on my box > works fine.

Can you share the XML and command line you are using?

@Martin Nothnagel 



  <Add SourcePath="C:\Users\username\Desktop\SETUP" OfficeClientEdition="64" Channel="MonthlyEnterprise">
        <Product ID="O365BusinessRetail">
            <Language ID="en-us"/>
         <ExcludeApp ID="Access" />
         <ExcludeApp ID="Groove" />
         <ExcludeApp ID="Lync" />
         <ExcludeApp ID="OneDrive" />
         <ExcludeApp ID="Teams" />
         <ExcludeApp ID="Publisher" />



This is my XML file.

And I use


.\setup.exe /download .\office-365-pull.xml




The XML gave me an error initially, as it can't write data to C:\users\username\... When changing the SourcePath to C:\Temp it worked fine for me. Can you check if changing the sourcepath resolves your issue?

With C:\temp it worked fine for both updatechannel = MonthlyEnterprise and Current
Thanks, Martin. This is weird. We are behind a proxy. If I do the same on a VM without proxy, direct access to internet, it just works fine. But the error code still confuses me why it was showing me 0-2015 (2250), which is apparently related to wrong channel... Or because my network point is blocked, and it doesn't understand that there is a "MonthlyEnterprise" channel ?
You mentioned that the same download works for Current Channel. Might it be that the network team only unblocked the "subdirectory" path for Current Channel? So, accessing* is allowed while everything else (including Monthly Enterprise's*) is blocked?