Two-node Exchange 2019 DAG with many 4999 event ID errors

Copper Contributor



We are running a two-node Exchange 2019 DAG behind a Kemp LB.  Since the Feb CU and SU updates, I've seen continuous 4999 errors in the Event Viewer.  

Error 1:

Watson report about to be sent for process id: 18868, with parameters: E12, c-RTL-AMD64, 15.02.1118.026, w3wp#MSExchangeSyncAppPool, MSExchange ActiveSync, Microsoft.Exchange.AirSync.Common.SchemaConverter.Entity.EntityContentProperty.get_MIMEData, UnexpectedCondition:NotImplementedException, 76de, 15.02.1118.026.

ErrorReportingEnabled: True 

exData=|exHResult=|exStacktrace=at Microsoft.Exchange.AirSync.Common.SchemaConverter.Entity.EntityContentProperty.get_MIMEData()

   at Microsoft.Exchange.AirSync.Common.SchemaConverter.AirSync.AirSyncContentProperty.InternalCopyFrom(IProperty sourceProperty)

   at Microsoft.Exchange.AirSync.Common.SchemaConverter.AirSync.AirSyncContent14Property.InternalCopyFrom(IProperty sourceProperty)

   at Microsoft.Exchange.AirSync.Common.SchemaConverter.AirSync.FlexibleSchemaStrategy.ExecuteCopyProperty(IProperty srcProperty, AirSyncProperty dstAirSyncProperty)

   at Microsoft.Exchange.AirSync.Common.SchemaConverter.AirSync.AirSyncDataObject.CopyFrom(IProperty srcRootProperty)

   at Microsoft.Exchange.AirSync.MailboxItemFetchProvider.BuildResponse(XmlNode responseNode)|exTargetSite=MSExchange ActiveSync Microsoft.Exchange.AirSync.Common.SchemaConverter.Entity.EntityContentProperty.get_MIMEData|exSource=|exMessage=|exComplete=


Error 2:

Watson report about to be sent for process id: 19480, with parameters: E12IIS, c-RTL-AMD64, 15.02.1118.026, w3wp#MSExchangeOWAAppPool, M.E.C.Owa2.Server, M.E.C.O.S.C.OwaMapiNotificationManager.SubscribeToSuiteNotification, System.NotSupportedException, 80d2-dumptidset, 15.02.1118.026.

ErrorReportingEnabled: True 


Error 3:

Watson report about to be sent for process id: 27204, with parameters: E12IIS, c-RTL-AMD64, 15.02.1118.026, w3wp#MSExchangeServicesAppPool, M.Exchange.Services, M.E.S.C.T.ServiceResult`1.ProcessServiceResults, System.ArgumentNullException, feb4-dumptidset, 15.02.1118.026.

ErrorReportingEnabled: True 


I've tried the following to resolve the issue:  

1. run a .NET repair.

2. Recycle AppPools

3. Checked that OAuth is valid
4. Make sure that all certificates are valid

5. confirm virtual directories have the correct FQDN

6. multiple reboots


I haven't received any connection issues besides a few of Outlook autodiscover redirect popups.  


Open to any suggestions.


4 Replies



this error is related to Exchange mailbox transport delivery service. install latest CU to address this issue.



If I have answered your question, please mark your post as Solved

If you like my response, please give it a Like :smile:


Appreciate your Kudos! Proud to contribute! :)




Fail. This answer could not be more wrong ...

@floridaitI have the same issue in a 3-node Exchange 2019 DAG running behind Kemp LB. I have updated to CU14 and continue to have event id 4999 errors. My healthchecker.ps1 runs without errors.


I believe that even though it is an error you can ignore the error. It has been reported for a while:



I still have this error occurring approx. 400 (!) times a day for the activesync app pool and another 100 (!) times a day for the owa app pool. On a server cluster/DAG with about 500 users....
And i should consider this as "normal" ?? I can't imagine this.

Why the hell MS is just ignoring this since more than 4 years ?

Please take-over your responsibility.