Remove Classic EAC Organization Add-ins?

Brass Contributor

Hello,

 

Does anyone know how to remove the organization add-ins that were deployed with the Classic Exchange Admin Center? Now that the "classic view" is no longer accessible, our tenant shows a 400 Bad Request error when trying to go to "https://outlook.office.com/ecp/".

 

This org add-in is pushed to all mailboxes by "organization administrators", and as far as I can tell, there isn't a way to remove the add-in. This legacy add-ins are not visible in the new "Integrated Apps" in O365. I contacted Microsoft Support but the support agent got to the point where he was having me run PowerShell commands to check the registry to see if it was "installed as a program on my computer", and that's when I knew he had exhausted his support resources. :sad:

 

I can see the app if I execute: Connect-ExchangeOnline as a Global Admin & Tenant Admin (Exchange Online Role) and then run the Get-App | select DisplayName, AppID cmdlet.

 

If I try to remove it Remove-App -Identity <AppID>, then I see a:
Write-ErrorMessage : |Microsoft.Exchange.Data.ApplicationLogic.Extension.OwaExtensionOperationException|The app "Alert" is managed by organization administrators and can't be uninstalled by end users.

 

If I check the Exchange Online roles, I am in the TenantAdmins_3744d role, which states that "it will be a member of the Organization Management role group and will inherit the capabilities of that role group".

 

rmoat_0-1720188902747.png

 

So far I have no way to remove this old add-in which normally was installed/uninstalled through Organization > Add-Ins in the Classic (Legacy) Exchange Admin Center.

 

4 Replies
Simply add the -OrganizationApp switch.

@VasilMichev 

Hey Vasil,

I should have updated my post, but it doesn't think it is an OrganizationApp either. It cannot find it if I add that switch, unfortunately.

 

remove-app -Identity 641b89c0-a4f1-4289-881f-c1f2f48f31d9 -OrganizationApp
Write-ErrorMessage : Ex43C0AC|Microsoft.Exchange.Configuration.Tasks.ManagementObjectNotFoundException|The operation
couldn't be performed because '641b89c0-a4f1-4289-881f-c1f2f48f31d9' couldn't be found.

 

And if I run: get-app -OrganizationApp it doesn't show up. It seems like it's an app deployed in EAC that installed on every mailbox, but isn't listed as an "Org App".

Erm, you'll have to endure some more interaction with support them, I'm afraid :)

Oddly enough, I checked this morning and do not see the add-in deployed to my mailbox anymore. I ran a foreach loop of every mailbox and am not seeing it on the other mailboxes as well. My ticket was closed last week, and no further updates; however, Microsoft must have been able to remove the add-in after my ticket was closed.