Outlook 365 keeps asking for password with Exchange 2019

%3CLINGO-SUB%20id%3D%22lingo-sub-1007023%22%20slang%3D%22en-US%22%3EOutlook%20365%20keeps%20asking%20for%20password%20with%20Exchange%202019%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1007023%22%20slang%3D%22en-US%22%3EHi%20guys%2C%3CBR%20%2F%3E%3CBR%20%2F%3EI%20would%20like%20to%20ask%20if%20you%20didn't%20face%20the%20similar%20problem%20last%20few%20weeks%20when%20using%20Outlook%20365%20connecting%20to%20on-premise%20Exchange%202019.%20Office%20365%20does%20not%20have%20exchange%20online%20setup%20and%20there%20is%20not%20authorized%20domain%2C%20so%20there%20couldn't%20be%20any%20colision%20with%20on-premise%20exchange%20autodiscovery.%20Few%20users%20using%20Outlook%20365%20started%20reporting%20that%20their%20Outlook%20keeps%20asking%20for%20password%20and%20when%20I%20was%20remotely%20connected%20to%20those%20users%2C%20they%20used%20correct%20username%20and%20password%20in%20the%20prompt%20(so%20there%20is%20not%20any%20problem%20with%20DOMAIN%5C%20or%20%40domain.com%20username%20format).%20Their%20login%20to%20OWA%20works%20correctly%20so%20password%20is%20correct%20too.%20The%20worst%20is%20I%20cannot%20find%20any%20reason%20why%20it's%20still%20asking%20for%20password%20and%20in%20very%20random%20intervals.%3CBR%20%2F%3E%3CBR%20%2F%3EIt%E2%80%99s%20also%20good%20to%20say%20that%20Outlook%202019%20does%20not%20have%20such%20issue%20and%20all%20users%20with%20Outlook%202019%20works%20correctly%20and%20problem%20is%20observed%20only%20on%20Outlook%20365.%3CBR%20%2F%3E%3CBR%20%2F%3ECouldn't%20be%20there%20some%20incomaptible%20update%20in%20Outlook%20365%20inside%2C%20as%20our%20team%20didn't%20do%20any%20update%20to%20Exchange%202019%20for%20more%20than%203%20months%20including%20update%2C%20configuration%20change%20(except%20new%20users)%20and%20I'm%20100%25%20sure%20that%20exchange%20is%20not%20changed%20anyhow.%3CBR%20%2F%3E%3CBR%20%2F%3EThanks%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-1007023%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EExchange%202019%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EOutlook%20365%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1007595%22%20slang%3D%22en-US%22%3ERe%3A%20Outlook%20365%20keeps%20asking%20for%20password%20with%20Exchange%202019%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1007595%22%20slang%3D%22en-US%22%3E%3CP%3EOutlook%20will%20try%20to%20connect%20to%20Exchange%20Online%20%22as%20priority%22%2C%20even%20if%20you%20are%20not%20actually%20using%20the%20service%2C%20which%20is%20most%20likely%20what's%20causing%20the%20issue%20for%20you.%20Use%20the%20reg%20keys%20in%20this%20article%20to%20disable%20this%20%22helpful%22%20feature%3A%26nbsp%3B%3CFONT%20style%3D%22background-color%3A%20%23ffffff%3B%22%3E%3CA%20href%3D%22https%3A%2F%2Fsupport.microsoft.com%2Fen-us%2Fhelp%2F3211279%2Foutlook-2016-implementation-of-autodiscover%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%22%3Ehttps%3A%2F%2Fsupport.microsoft.com%2Fen-us%2Fhelp%2F3211279%2Foutlook-2016-implementation-of-autodiscover%3C%2FA%3E%3C%2FFONT%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1012583%22%20slang%3D%22en-US%22%3ERe%3A%20Outlook%20365%20keeps%20asking%20for%20password%20with%20Exchange%202019%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1012583%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F457155%22%20target%3D%22_blank%22%3E%40TiborM%3C%2FA%3E%26nbsp%3BWe%20started%20to%20see%20the%20same%20thing.%20we%20tested%20and%20deployed%20the%20regkey%20mentioned%20in%20the%20article%26nbsp%3B%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F58%22%20target%3D%22_blank%22%3E%40Vasil%20Michev%3C%2FA%3E%26nbsp%3Bmentention%20and%20that%20fixed%20our%20issue.%26nbsp%3B%3C%2FP%3E%3CDIV%3EHKEY_CURRENT_USER%5CSoftware%5CMicrosoft%5COffice%5C16.0%5COutlook%5CAutoDiscover%20DWORD%3AExcludeExplicitO365Endpoint%3C%2FDIV%3E%3CDIV%3EValue%3A1%3C%2FDIV%3E%3C%2FLINGO-BODY%3E
Highlighted
Occasional Visitor
Hi guys,

I would like to ask if you didn't face the similar problem last few weeks when using Outlook 365 connecting to on-premise Exchange 2019. Office 365 does not have exchange online setup and there is not authorized domain, so there couldn't be any colision with on-premise exchange autodiscovery. Few users using Outlook 365 started reporting that their Outlook keeps asking for password and when I was remotely connected to those users, they used correct username and password in the prompt (so there is not any problem with DOMAIN\ or @domain.com username format). Their login to OWA works correctly so password is correct too. The worst is I cannot find any reason why it's still asking for password and in very random intervals.

It’s also good to say that Outlook 2019 does not have such issue and all users with Outlook 2019 works correctly and problem is observed only on Outlook 365.

Couldn't be there some incomaptible update in Outlook 365 inside, as our team didn't do any update to Exchange 2019 for more than 3 months including update, configuration change (except new users) and I'm 100% sure that exchange is not changed anyhow.

Thanks
2 Replies
Highlighted

Outlook will try to connect to Exchange Online "as priority", even if you are not actually using the service, which is most likely what's causing the issue for you. Use the reg keys in this article to disable this "helpful" feature: https://support.microsoft.com/en-us/help/3211279/outlook-2016-implementation-of-autodiscover

Highlighted

@TiborM We started to see the same thing. we tested and deployed the regkey mentioned in the article @Vasil Michev mentention and that fixed our issue. 

HKEY_CURRENT_USER\Software\Microsoft\Office\16.0\Outlook\AutoDiscover DWORD:ExcludeExplicitO365Endpoint
Value:1