Exchange Hybrid Configuration Wizard - Error 1603 - Connector registration failed

Copper Contributor

Did any of you encounter this error while installing hcw on an exchange server? 




Here is the event viewer error details: 


Connector registration failed: Make sure you are a Global Administrator of your Active Directory to register the Connector. Error: '"The registration request was denied. "'

26 Replies
Hello, I'm facing the same issue, my customer has an Exchange 2016 and we have : Connector registration failed: Make sure you are a Global Administrator of your Active Directory to register the Connector. Error: '"The registration request was denied. "'
Exchange is up to CU 22.
Thanks for the help.
Could you please do a DNS check and a GUID check.
DNS is good. How do you suggest checking the GUID?

@Eric Fuentes I have the exact same problem at the moment. "The registration request was denied".
If using an Azure AD user which do not have Global Administrator access the error is: "The registration request was denied. Details: User is unauthorized".
It seems as if the issue is with Azure AD services denying to register the connector, as it can see if the users is a Global Administrator or not...



Michael, i tested this with a non GA account and you were right, USER is Unauthorized came up.

Now the next question is what service or how the service can be allowed for registration??
Yes, it must be some Azure AD services denying access - but which?
Do you know where to find the msi log files from the installer - perhaps they have more detailed information, other than just the generic error 1603?
I have the same problem at a customer for 2 days. I use the GA user.
Would it be possible that there is currently a problem in Azure?

I have the same problem:
Invoking powershell script from path 'C:\Program Files\Microsoft Hybrid Service\RegisterConnector.ps1'
Error while invoking powershell script: 'System.Management.Automation.CmdletInvocationException: The registration request failed. Make sure you are an administrator of the AD directory you are trying to register the Connector with.
best response confirmed by Eric Fuentes (Copper Contributor)
Folks, I never got a clear answer but the solution we did was to install HCW on a member server running on Windows Server 2019.

@Eric Fuentes 


I have a 2016 member server, I can try again on another member server.



I have deployed a Windows Server 2019 as member server with Exchange HCW with success. Thanks for suggestions

@griffom7 I agree, my setup on a member server on 2019 was also successfull :)

I recently had chance to support on the same issue and i found that windows 2016 OS file was broken due to Patch . Here it has mentioned that Supported OS as windows server 2019 and We ignored it as the patch is for Exchange server 2019 . Post upgradation of windows server 2016 to Windows server 2019 it fixed the broken OS files and then Hybrid Agent worked . Additionally I verified on windows server 2016 where I have not installed this Patch and it works perfectly.

@Eric Fuentes My Exchange 2016 patched to CU 23 and security update KB5014261 this server would not install hybrid agent error 1603. I ran HCW on non-Exchange 2016 server ( I don't have any 2019 servers yet) and hybrid agent installed ok, HCW ran to successful conclusion. Thank you, this post allowed me to fix my hybrid setup.


I have just come across this same issue. Customer has a newly installed Exchange 2016 box, with Exchange 2016 newly installed for hybrid purposes (they have an exchange 2013 that will be migrated through)
There isn't the option right now to upgrade the server to server 2019, anyone got an actual fix that isn't a work around?
Ben, see if you can install to a non-Exchange server with 2016 or 2019. See Mark Canning's reply above for your reference.