IE to Edge 87+ redirection issues

%3CLINGO-SUB%20id%3D%22lingo-sub-1941961%22%20slang%3D%22en-US%22%3EIE%20to%20Edge%2087%2B%20redirection%20issues%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1941961%22%20slang%3D%22en-US%22%3E%3CP%3EWe've%20set%20both%20the%20RedirectSitesFromInternetExplorerRedirectMode%20and%20the%20RedirectSitesFromInternetExplorerPreventBHOInstall%20policies%20to%20prepare%20for%20the%20release%20of%20Edge%2087%2C%20as%20we%20still%20have%20a%20large%20population%20of%20folks%20who%20require%20IE%20as%20their%20default.%20Now%20that%2087%20stable%20is%20here%2C%20we're%20finding%20that%20the%20settings%20don't%20work.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EFirst%20RedirectSitesFromInternetExplorerPreventBHOInstall%20only%20appears%20to%20work%20if%20it's%20done%20on%20the%20Computer%20Configuration%20in%20the%20ADMX%2C%20not%20the%20User%20Configuration.%20I've%20double-checked%20and%20I%20don't%20see%20this%20listed%20in%20the%20documentation%20anywhere.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ESecond%2C%20the%20RedirectSitesFromInternetExplorerRedirectMode%20policy%20doesn't%20work%20at%20all%2C%20either%20in%20the%20User%20or%20the%20Computer%20ADMX%20configuration.%20The%20setting%20shows%20%22Never%22%20correctly%20in%20the%20Edge%20%26gt%3B%20Settings%20%26gt%3B%20Default%20Browser%20UI.%20But%20the%20value%20of%20the%20setting%20is%20ignored%20and%20IE%20redirects%20anyway.%20If%20it's%20not%20set%20by%20policy%20and%20I%20manually%20toggle%20it%20to%20Never%2C%20IE%20correctly%20follows%20the%20setting%20and%20does%20not%20redirect.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1942437%22%20slang%3D%22en-US%22%3ERe%3A%20IE%20to%20Edge%2087%2B%20redirection%20issues%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1942437%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F567005%22%20target%3D%22_blank%22%3E%40db1080%3C%2FA%3E%26nbsp%3BHi!%26nbsp%3B%20Sorry%20to%20hear%20you%20are%20having%20issues%20with%20those%20policies.%26nbsp%3B%26nbsp%3B%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3ETo%20double%20check%2C%20when%20setting%20up%20the%20policies%20did%20you%20follow%20these%20instructions%3F%26nbsp%3B%26nbsp%3B%3C%2FP%3E%0A%3CP%3E%3CA%20href%3D%22https%3A%2F%2Fdocs.microsoft.com%2Fen-us%2Fdeployedge%2Fedge-learnmore-neededge%23disable-redirection-to-microsoft-edge%22%20target%3D%22_self%22%20rel%3D%22noopener%20noreferrer%22%3Ehttps%3A%2F%2Fdocs.microsoft.com%2Fen-us%2Fdeployedge%2Fedge-learnmore-neededge%23disable-redirection-to-microsoft-edge%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3EJust%20want%20to%20make%20sure%20that%20part%20is%20correct!%26nbsp%3B%20If%20you%20are%20still%20having%20problems%2C%20please%20let%20us%20know!%26nbsp%3B%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3E%3CEM%3E-Kelly%3C%2FEM%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1943309%22%20slang%3D%22en-US%22%3ERe%3A%20IE%20to%20Edge%2087%2B%20redirection%20issues%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1943309%22%20slang%3D%22en-US%22%3EHi%3CBR%20%2F%3E%3CBR%20%2F%3EI%20guess%20these%20folks%20that%20require%20IE%20as%20default%20uses%20several%20websites%20(finite%20number)%20that%20works%20in%20IE%20only.%20I%20suggest%20you%20to%20explore%20IE%20mode%20feature%20of%20new%20edge.%20You%20will%20be%20able%20to%20add%20these%20websites%20to%20site%20list%20and%20you%20will%20no%20longer%20need%20to%20cope%20with%20these%20RedirectFromInternetExplorer%20policies%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1946372%22%20slang%3D%22en-US%22%3ERe%3A%20IE%20to%20Edge%2087%2B%20redirection%20issues%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1946372%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F757644%22%20target%3D%22_blank%22%3E%40Kelly_Y%3C%2FA%3E%3C%2FP%3E%3CP%3EYes%2C%20we%20followed%20those%20directions.%20We%20implemented%20both%20policies%20prior%20to%20the%20Edge%2087%20release.%20We%20generally%20prefer%20to%20add%20settings%20to%20the%20ADMX%20User%20Configuration%2C%20since%20it%20makes%20exceptions%20easier%20to%20manage.%20While%20the%20%3CSTRONG%3ERedirectSitesFromInternetExplorerPreventBHOInstall%26nbsp%3B%3C%2FSTRONG%3Epolicy%20appears%20in%20the%20User%20Config%2C%20it%20looks%20like%20it%20fails%20because%20the%20setup%20doesn't%20detect%20the%20setting%20unless%20it's%20set%20in%20the%20Computer%20Config.%20This%20isn't%20documented%20in%20the%20release%20notes%20or%20the%20ADMX%20itself%2C%20but%20it's%20logical%20since%20the%20installer%2Fupdater%20typically%20runs%20as%20system.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EWe%20also%20added%20the%20%3CSTRONG%3ERedirectSitesFromInternetExplorerRedirectMode%26nbsp%3B%3C%2FSTRONG%3Epolicy%2C%20again%20before%20the%2087%20release%2C%20just%20to%20cover%20our%20bases.%20Remember%2C%20we%20had%20no%20way%20to%20fully%20test%20this%20prior%20to%20the%2087%20release%20since%20we're%20domain-joined.%20While%20%22Never%22%20is%20displayed%20correctly%20in%20Edge%20settings%2C%20it%20doesn't%20work.%20Further%20digging%20shows%20that%20the%20HKEY_CURRENT_USER%5CSoftware%5CMicrosoft%5CEdge%5CIEToEdge%20%7C%20RedirectionMode%20key%2C%20which%20is%20what%20the%20BHO%20itself%20uses%2C%20is%20not%20being%20created%20nor%20set%20to%200%20when%20the%20policy%20is%20read%20by%20Edge.%20If%20the%20BHO%20doesn't%20find%20the%20key%2C%20the%20default%20is%20to%20redirect.%20If%20I%20manually%20create%20the%20RedirectionMode%20key%20and%20then%20re-launch%20Edge%2C%20it%20correctly%20follows%20the%20policy%20and%20sets%26nbsp%3BRedirectionMode%20to%200.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E
Occasional Contributor

We've set both the RedirectSitesFromInternetExplorerRedirectMode and the RedirectSitesFromInternetExplorerPreventBHOInstall policies to prepare for the release of Edge 87, as we still have a large population of folks who require IE as their default. Now that 87 stable is here, we're finding that the settings don't work.

 

First RedirectSitesFromInternetExplorerPreventBHOInstall only appears to work if it's done on the Computer Configuration in the ADMX, not the User Configuration. I've double-checked and I don't see this listed in the documentation anywhere.

 

Second, the RedirectSitesFromInternetExplorerRedirectMode policy doesn't work at all, either in the User or the Computer ADMX configuration. The setting shows "Never" correctly in the Edge > Settings > Default Browser UI. But the value of the setting is ignored and IE redirects anyway. If it's not set by policy and I manually toggle it to Never, IE correctly follows the setting and does not redirect.

8 Replies

@db1080 Hi!  Sorry to hear you are having issues with those policies.  

 

To double check, when setting up the policies did you follow these instructions?  

https://docs.microsoft.com/en-us/deployedge/edge-learnmore-neededge#disable-redirection-to-microsoft... 

 

Just want to make sure that part is correct!  If you are still having problems, please let us know! 

 

-Kelly

Hi

I guess these folks that require IE as default uses several websites (finite number) that works in IE only. I suggest you to explore IE mode feature of new edge. You will be able to add these websites to site list and you will no longer need to cope with these RedirectFromInternetExplorer policies

@Kelly_Y

Yes, we followed those directions. We implemented both policies prior to the Edge 87 release. We generally prefer to add settings to the ADMX User Configuration, since it makes exceptions easier to manage. While the RedirectSitesFromInternetExplorerPreventBHOInstall policy appears in the User Config, it looks like it fails because the setup doesn't detect the setting unless it's set in the Computer Config. This isn't documented in the release notes or the ADMX itself, but it's logical since the installer/updater typically runs as system.

 

We also added the RedirectSitesFromInternetExplorerRedirectMode policy, again before the 87 release, just to cover our bases. Remember, we had no way to fully test this prior to the 87 release since we're domain-joined. While "Never" is displayed correctly in Edge settings, it doesn't work. Further digging shows that the HKEY_CURRENT_USER\Software\Microsoft\Edge\IEToEdge | RedirectionMode key, which is what the BHO itself uses, is not being created nor set to 0 when the policy is read by Edge. If the BHO doesn't find the key, the default is to redirect. If I manually create the RedirectionMode key and then re-launch Edge, it correctly follows the policy and sets RedirectionMode to 0.

 

@db1080 Thanks for the additional information!  I've reached out to our team and we will follow up with updates or additional questions.  

 

-Kelly

@db1080  Thanks for reaching out.

For the RedirectSitesFromInternetExplorerPreventBHOInstall policy, you're right that computer config is the only one that is affected. We'll make sure to clarify that through documentation. If set to Enable, this policy will uninstall the BHO the next time you update Edge Stable.

 

To ensure I understand the issue with the second policy, can you please confirm that the policy does not disable redirection after being set as shown below? 

 

IEtoEdgeDisable.png

@Shilpa_Subramanian 

Correct, that is how we have it set. I found that the HKCU\Software\Microsoft\Edge\IEToEdge | RedirectionMode key, which the BHO itself uses, is not being created by Edge when the

RedirectSitesFromInternetExplorerRedirectMode policy is set BEFORE Edge 87 is installed.

If I manually create the RedirectionMode key and then re-launch Edge, it correctly reads the policy and sets RedirectionMode to 0.

 

So, if the RedirectionMode key doesn't exist AND the policy is set to disabled, Edge won't create it. The BHO defaults to redirecting sites from IE and ignores the policy. We're getting around the issue by creating that missing registry key.

@db1080 If setting a policy to disable BEFORE installing 87, all you need to do is set RedirectSitesFromInternetExplorerPreventBHOInstall to Enabled. In this case, the BHO will not get installed with the Edge update and redirection shouldn't occur. Are you able to try if this helps?

 

We will take a look at the RedirectSitesFromInternetExplorerRedirectMode policy and get back on what's going on.

 

@Shilpa_Subramanian 

Thanks. We did that, but it was in HKCU so it didn't work. We're moving the BHO policy to HKLM now so it should be resolved soon.