IE Site list mode not working

Occasional Contributor



I'm trying to use the Enterprise Site List in Edge chromium. I read and followed the instructions and set the GP settings as mentioned in the MS instructions page.

The site list xml file was created using "Enterprise Mode Site List Manager v2" and worked fine on the pre-chromium Edge versions. I loads fine when trying to open in the browser.


I see the set policies in the 'edge://policy/' page (exported json file attached), it shows correctly with the correct URL addresses in the 'edge://compat/enterprise' page, but when I try to actually open one of the URLs, it loads up via Edge chromium and not IE, as I would expect.


I'm Running Windows 10 Enterprise OS Version 1803 (Build 17134.1304)

and Edge Version 80.0.361.54 (Official build) (64-bit)


Would appreciate any help on this, as I'm sure I followed all requirements, but fail to see the results.


28 Replies

@eladz6  It looks like you have the policies set correctly. Does the site you expect to open in IE mode  have the <open-in> tag set to IE11? 


<site url="">






Thanks for the reply.

I tried it both with "open-in" set to IE11 and to MS-Edge, but nothing really occurred on either. I also tried to place the site list Xml file both locally and remotely, but again - it had no effect.

@eladz6 I misread your initial post. 

Sites configured to open in IE mode through the site list will load in Microsoft Edge (Chromium-based) on the same tab. The only indicator that the site is in IE mode is the IE11 icon on the top left next to the Refresh button.

It looks like you are expecting the site to open in the IE11 standalone app and not in Edge. If this is correct, you will need to add an additional attribute to the <open-in> tag.

<open-in app="true">IE11</open-in>



@Shilpa_Subramanian Thank you, but no, that's not the issue - I want the site to open in MSEdge using the IE engine. Since that didn't work, I tried the open in IE option, but that didn't work either.

The sites in the site list still open only in Edge with the Chromium engine, despite all settings set to open them using the IE engine.


Any ideas on how to resolve this, or check why it's not working as expected?

best response

@eladz6  That is odd. We can take a look. Can you please send us the following - 

1. A screenshot of edge://compat/iediagnostic

2.  Start Edge with the command line "msedge.exe --enable-logging --v=1 --vmodule=*/dual_engine/*"       

This will create a log in "%localappdata%\microsoft\Edge<Canary/Dev/Beta>\user data\chrome_debug.log"

 This log is human readable and will contain URLs. Please proof read to ensure there is no PII information included before you share back with us.

Feel free to share the log via Private Message if you prefer.





Did you choose "Internet Explorer Mode" in "Configure Internet Explorer Integration" setting in the Group Policy editor?


Edit: 3rd picture in this URL ->

@Shilpa_Subramanian Attached. Thank you.


I see in the log the following, after I placed in the SiteList file:


"Site found on sitelist. engine == Edge, allow-redirect == 0, for_redirect == 0, IsHostingInternetExplorer == 0, IsRemoteDebugging == 0 for:"


So it seems it does recognize the site list, but uses the wrong engine (Edge instead of IE).


I got the same results when setting the SiteList XML file to open the site with IE11, as well.




@DeadCanDance  I did, thank you. Just re-checked it after your message and it seems to be set correctly.

@eladz6  Thanks for sharing the logs. Can you resend the log file when you change the XML entry to be IE11 for Here's guidance:

1. Update the site list XML entry as follows:

<site url="">



2. Once you make this change, go to edge://compat/enterprise and click on Force Update next to the XML location.

The list should update and you'll see the column for Engine read IE11 for the entry.

3. Once this is complete, try navigating to from Edge using the command line to retrieve the log again.




@Shilpa_Subramanian  Sure, I'm attaching the log.

To my surprise - this time it did open using an IE engine. The surprise stems from the fact that when I tried the same thing - changing the sitelist value to open with IE instead of Edge, then forcing update and opening the site - it still used the Edge engine.





I am having this same issue.  I have created the xml list and applied all policies but the sites do not open in IE mode.








I see the same issue at our company, I have set the GPO to point to a Enterprise Site list, but sites don't open in IE. 

2020-04-20 11_42_18-Microsoft Edge Compatibility and 4 more pages - Work - Microsoft​ Edge.jpg


If I go to the link, I can read the xml file. But when I go to 


And try to click on Force Update I get this error :

2020-04-20 11_48_15-Microsoft Edge Compatibility and 4 more pages - Work - Microsoft​ Edge.jpg

I have also updated the Enterprise mode site list manager to the latest version and made a new file with this version.



This issue exists in Microsoft Edge version 85.0.564.51 too


Make sure you download the updated admx files for edge. Also, not sure if it made a difference, but I configured the same settings under computer and user policy.


@eladz6 When "Configure Internet Explorer intergration" policy is set to Internet Explorer mode you need to set Open in IE11 and check Standalone IE .


The Engine will be set to IE11APP if you check it in




@ Shilpa




I read all the topic and didn't found the answer of my issue. 


You say : "2. Once you make this change, go to edge://compat/enterprise and click on Force Update next to the XML location"


Is it possible to automate the action "Force Update" button ? 

We can't tell at our 10 000 users to do this action! :)


Thank you. 


I see the same problem in Edge Version 100.0.1185.36 (April 2022)
I have created a sitelist and included it in Edge using Group Policy Editor.

1. When I open Edge and go to the IE11 compatability site, The site will NOT be opened in Internet Explorer compatibility mode.

if I instead
1. Open edge, go to edge://compat/enterprise and press "Force Update"
2. Opening the IE11 compatability site will open the site in Compatability mode

If I close Edge and open it again, I need to do the "Force Update" in edge://compat/enterprise again to make the site work in compatibility mode.

Is there any new information about this behaviour?

@rauhe Would you be able to confirm if you have enabled the group policy for IE mode, “Configure Internet Explorer integration” (Configure IE mode Policies | Microsoft Docs)? Thanks! 




Hi Kelly, Thanks for the reply...

Yes, yesterday I tried setting setting the “Configure Internet Explorer integration” option and this seems to have done the trick.

I was, however, hoping for an easier solution. I have to instruct non-PC-super-users to setup a pc for IE compatibility, and the solution I have (as described in your link), requires downloading and installing "Microsoft Edge Policy Template" to the Group Policy Editor (this is required for the option “Configure Internet Explorer integration” to be available). Even for me as a professional, this is not an every day task, so for a non-PC-super-user I think this is more or less impossible.


Do you know if it possible to set the “Configure Internet Explorer integration” setting trought the registry?

Best regards