IE Mode not working

Copper Contributor

I keep getting the following error message when opening a site that is set to redirect to Edge:


Can't open this page in Internet Explorer mode. Try reinstalling Microsoft Edge with administrator privileges.


My 1809 machine is at this build (17763.615) and my 1903 machine is at this build (18362.239) so they are higher than the minimum build referenced in the support doc. I have tried everything that is in that doc as a possible fix and tried anything I have read in this forum.


In our environment we have Edge redirecting to IE using the Enterprise Mode Site Manager (v.2 scheme). It opens the link in IE 11 after I get this error but I am wondering if there is something else I am missing that would give me this error and not let this open up in IE mode within the Edge browser.


Has anyone else run into this issue and resolved it?


7 Replies

@lutedai If you type edge://version in the Edge address bar, the Executable path should show a path starting with C:\Program Files... to indicate a system install. If the Executable path begins with C:\Users.. then you will need to uninstall and reinstall Edge with administrator privileges.


Additionally, IE mode is not supported on the Canary channel. Please use the Dev channel to try out IE mode.



Thanks for the reply. Here is what I show for the Executable path and also under command line.


Executable pathC:\Program Files (x86)\Microsoft\Edge Dev\Application\msedge.exe


Command-line"C:\Program Files (x86)\Microsoft\Edge Dev\Application\msedge.exe" --flag-switches-begin --internet-explorer-integration=iemode --enable-features=msInternetExplorerIntegrationEnhancedHangResistance,msInternetExplorerModeDevelopment,msInternetExplorerModeFrameHangResistance,msSignInWithAADAccount --flag-switches-end

@lutedai ,@Shilpa_Subramanian


Same issue, with Dev 223, IE Mode only works with send all intranet sites to IE EdgeC policy.  Does not work when I use the IE 11 use EMIE list policy.


best response confirmed by lutedai (Copper Contributor)

@lutedai It looks like you have a few additional flags turned on for IE mode. Can you try going to edge://flags, search Internet Explorer, and match the configuration you see below? 






FYI, I followed the steps in this post,, and it is now working as expected.


Having to use machine-based policies is a challenge, but I am hopeful that before EdgeC goes GA we will be able to use both user-based and machine-based GPO to apply the required GPOs to enable IE Mode with EMIE List support.




Yes, that did the trick!  :)


Once I turned off those other IE flags it worked with no problem at all. Thank you for the help!!



i still can't see the ie mode in the menu?

Version 80.0.320.5 (Official build) dev (64-bit)