SOLVED

GPO RestoreOnStartup not working - shows edge://apps/

Contributor

We are preparing to roll out the brand new Edge Chromium. 

Therefore we have created a GPO that works pretty well except of one thing - we are not able to set the URL for the site to load on startup. 

 

The policy for RestoreOnStartup and RestoreOnStartupURLs is loading correctly from GPO to edge://policy/.

EDGE_Policies.png

But if you hit edge://settings/onStartup the page URL to start with Edge is set to "edge://apps". 

EDGE_Settings.png

This is annoying. Has anyone experienced this behavior and has a solution?

 

Version 80.0.361.32 (Official build) beta (64-bit)

Version 81.0.389.2 (Offizielles Build) dev (64-Bit)

Version 79.0.309.65 (Offizielles Build) (64-Bit)

 

 

5 Replies

@Philipp Hammer We also use NewTabPageLocation for setting the homepage URL in addition to HomepageLocation and RestoreOnStartupURLs

@PeteLanglois 

EDGE_Policies2.png

Thank you for your reply. 

I added the NewTabPageLocation to the group policy and checked it hits the Policies page in Edge. 

It shows up as expected - BUT Edge still loads edge://apps/ on startup so this sadly did not solve the issue. 

How is this PC managed? AD-joined or MDM?

 

@Gunnar Haslinger 

This issue occures on all PCs with Edge since creation of the GPO Policy. 

Before the users could use Edge with their custom start page. 

 

All machines are Win 10 1809 and Active Directory members. No MDM is used for them. 

It occures on all Versions of Edge - DEV, BETA and the brand new Stable build (from https://www.microsoft.com/en-us/edge/business/download). 

 

As seen in the screenshot of edge://policy there aren't many policies set. 
I thought someone else should have this issue as well, as it occures on any machine/user in our environment. 

Is there anything you would think I could test to get the cause of this issue?

best response confirmed by Philipp Hammer (Contributor)
Solution

@Philipp Hammer 

 

Problem seems to be solved. 

 

Deleted whole GPO object, created a new one and set setting after setting - following "gpupdate /force" and reloading policies in Edge. 

In the end I had the same settings as on the screenshot above - but this time startup page worked.