Enterprise Mode in Edge Chromium leaving empty tab

Occasional Contributor

Hi,

 

I've configured the Enterprise Mode in Edge Chromium (Version 83.0.478.56 (Official build) (64-bit)) so that I have, for instance, this value in the XML:

 

<site url="www.google.com">
<compat-mode>IE8Enterprise</compat-mode>
<open-in>IE11</open-in>
</site>
 
and when I reach the URL it indeed opens the site using a new IE11 window. 
 
But the problem is that it leaves the original Edge tab that tried to access the URL open, so I get a new IE11 window and an empty Edge tab.
 
Is there a way to avoid this behavior and also close the open tab once it launches the IE11 window, so I won't have any 'leftovers'?
 
Thank you.
 
9 Replies

@eladz6 Thanks for reaching out and reporting this behavior. I'll loop in our IE Mode team and let you know if they have any insights.

 

Fawkes (they/them)
Program Manager & Community Manager - Microsoft Edge

@eladz6 To make sure I understand the problem, are you expecting google.com to open in Internet Explorer mode and instead ending up in IE11 standalone app with Edge as is? 

If so, can you check if you have enabled the policy for IE mode integration? - https://docs.microsoft.com/en-us/deployedge/edge-ie-mode-policies#configure-internet-explorer-integr...

If you already have the policy set and this is still an issue, can you please send over a screenshot of edge://compat/iediagnostic?

 

 

@Shilpa_Subramanian Thanks for the reply.

 

I have the IE mode integration set to 'Internet Explorer 11'. I expect the website to open in a separate IE window, which it does, but it also leaves an empty Edge tab open as well.

 

Attaching the output you requested. Thank you !

Can anyone assist with this issue? Thank you.

Did you manage to resolve this? I am having the same issue @eladz6 

No, hadn't found a solution or gotten any assistance, sorry.

@eladz6 @Vincent Sok Hi - I was just discussing your question with our IE Mode team.  They have seen your feedback and are currently investigating.  It is on their radar :smile:

 

The team had a couple of questions and they are hoping to understand your specific scenarios.  Would either of you be able to share if you've tried using IE mode instead of opening standalone IE11?  Did you have any issues with IE mode or is there a reason why it is necessary to use standalone IE11?  Generally, launching standalone IE is intended as a fallback for cases where IE mode can’t be used. Thanks! 

 

-Kelly

@eladz6 @Vincent Sok - Good news!  We have released an update included with MS Edge Canary build 88.0.698.0 that should resolve this issue.  Please let us know if you have any further issues.  Thanks! 

 

-Kelly

Group policy - Computer Configuration - Administrative Templates - Microsoft Edge - enable 'Configure Internet Explorer Integration' select Internet Explorer mode in the drop down menu.