Bug: Edge Beta 101 on Start: This policy is blocked - its value will be ignored.

Steel Contributor

This Bug affects only Edge Beta 101.0.1210.10 as well as current Edge Dev and Canary.

Current Stable Edge 100.0.1185.36 ist NOT affected and works fine!


All Policies which are documented as "This policy is available only on Windows instances that are joined to a Microsoft Active Directory domain, Windows 10 Pro, or Enterprise instances enrolled for device management." do not work on Edge Beta 101 and above. All other Policies still work as expected, but Policies like HomepageLocationDefaultSearchProviderRestoreOnStartUpURLs etc... which need an MDM-Enrolled or AD-Joined Device don't work. 


Edge Beta 101 shows on Browser-Start: ErrorThis policy is blocked - its value will be ignored.




When Pressing the "Reload Policies" Button after some seconds AFTER Browser-Start the MDM-Management seems to get detected correct, and after pressing "Reload Policies" those show up correct and work:



But: This problem comes again every Edge Browser start!

The "sensitive" Policies which need MDM-Management show up with Error. After manually reloading them by pressing the button they start working until the next Edge Browser restart.


This Bug is new in Edge Beta 101, on the same devices everything works fine with current stable Edge 100. It is not OS-Related, I tried it on different Windows 10 v21H2 Professional as well as Windows 10 v1909 Education Machines - they behave the same. It is just Edge v101 related.


So may I ask you @Kelly_Y , @mkruger ... to please forward this to the right team so that it can get fixed before Edge 101 becomes stable!


14 Replies
Hello @mkruger

i have the same problems as @Gunnar-Haslinger.

After new start of EdgeBeta a whole bunch of policies are marked as error, ignored

According to edge://policy/ its following values:


After releoad policie is looks fine again. This bug needs to be fixed before rollout.

To note this started in 101.0.1198.0. I believe we have a fix that I hope to get out in an upcoming canary channel release. If the fix proves to be stable we will work to get this corrected in beta and dev. I'll try to update here as I see it make it through the channels.

@Joachim_T and @Gunnar-Haslinger


If you are feeling adventurous, a fix to this issue is out in in April 14's canary channel build 102.0.1226.0 at Download Microsoft Edge Insider Channels.


I'd love any feedback you may have on this to be sure it fixes your issue or if there are any other problems this change causes. I'll will continue to work to get this into the beta channel.

Thank you @mkruger ... just checked, new Canary Version looks good - is fixed for me! Hope to see this in Dev and Beta soon.


Edge Stabe 100.0.1185.39 ... OK - not affected
Edge Beta 101.0.1210.14 ... ERROR (unchanged, not fixed)
Edge Dev 102.0.1220.1 ... ERROR (unchanged, not fixed)
Edge Canary 102.0.1226.0 ... OK - FIXED!

@Gunnar-Haslinger, and @mkruger.

On first look it seems to be fixed in Edge Beta 101.0.1210.19

@Joachim_T @mkruger 


I can confirm Edge Beta 101.0.1210.19 works now.
So right now only Edge Dev 102.0.1220.1 is still affected.

Since Canary is currently fixed, this week's Dev update should also get that fix. Once you update to a newer version of Dev, can you make sure it also has the fix?
Edge Dev just updated and should have the fix.
Edge Dev 102.0.1227.0 should be working for you.
Thanks @mkruger , @josh_bodner

I can confirm Edge Dev 102.0.1227.0 works as expected.

Thanks @Gunnar-Haslinger  and @Joachim_T for the reports of the issue and help validating the fix. I really appreciate it!


If either of you are supporting other Chromium based browsers (non-Chrome ones), you will want to check on those browsers as well. I found this issue was a Chromium code base one, but one that did not affect Google Chrome. I have reported the issue in Chromium's bug tracking and will follow up with helping get things fixed there as well, but other Chromium browsers using the policy system may be affected.

Edge v101.0.1210.32 is now offered as Stable-Release and I can confirm Policies work like expected.


Side-Note: Google Chrome v101 seems to be affected, seems Google didn't fix this in time like Microsoft did.


Link to Google-Chrome Issue: https://bugs.chromium.org/p/chromium/issues/detail?id=1320281

Thanks again for the further testing!

Ouch, I did test try testing out on Chrome at first and did not find a similar issue and thought it may be an Edge specific problem. On testing for Chromium, I found the problem did exist there. I reported the issue Chromium and it looks like they are merging the fix from that in the issue you linked.

My theory at the time was that some of the Cloud Based management code for Google Workplace was performing some initialization that was missed when it was disabled. If that is disabled in some manner in your environment, that may be what is causing this to be seen in Chrome too. Just a guess though, looks like Google will have a fix out soon for you.

For reference, here is the issue I filed: