Automate the force start in enterprise mode

%3CLINGO-SUB%20id%3D%22lingo-sub-3052642%22%20slang%3D%22en-US%22%3EAutomate%20the%20force%20start%20in%20enterprise%20mode%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-3052642%22%20slang%3D%22en-US%22%3E%3CP%3EHi%2C%3C%2FP%3E%3CP%3ECan%20anyone%20please%20let%20me%20know%20all%20the%20setting%20we%20need%20to%20do%20so%20that%20we%20can%20automate%20the%20websites%20to%20open%20in%20IE%20in%20Microsoft%20edge.%3C%2FP%3E%3CP%3ECurrently%20we%20have%20created%20the%20XML%20profile%20and%20and%20tagged%20it%20to%20Microsoft%20edge%20but%20every%20time%20we%20need%20to%20go%20to%26nbsp%3Bedge%3A%2F%2Fcompat%2Fenterprise%20and%20force%20start%20it%20so%20that%20the%20XML%20file%20is%20updated%20in%20the%20location.%3C%2FP%3E%3CP%3EIt's%20difficult%20to%20operate%20in%20such%20way%20so%20can%20anyone%20please%20help%20me%20out.%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22%22%3EWe%20are%20using%20Microsoft%20Edge%20version%3C%2FSPAN%3E%3CSPAN%20class%3D%22%22%3E%3CSPAN%20class%3D%22%22%3E96.0.1054.62%20(Official%20build)%20(64-bit)%3C%2FSPAN%3E%3C%2FSPAN%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E
New Contributor

Hi,

Can anyone please let me know all the setting we need to do so that we can automate the websites to open in IE in Microsoft edge.

Currently we have created the XML profile and and tagged it to Microsoft edge but every time we need to go to edge://compat/enterprise and force start it so that the XML file is updated in the location.

It's difficult to operate in such way so can anyone please help me out.

We are using Microsoft Edge version96.0.1054.62 (Official build) (64-bit)

6 Replies

@Himank14 Hi!  Would you be able to confirm if you have enabled the group policy for IE mode, “Configure Internet Explorer integration” (Configure IE mode Policies | Microsoft Docs)?  I don't think it should be necessary to force update for the location to be updated.  

 

Also, I wanted to mention the AppAssure team is offering webinars to help with transitioning to Microsoft Edge and using IE mode.  It might be helpful!  Here is a link to sign up: How to get started with Internet Explorer mode in Microsoft Edge  Thanks! 

 

-Kelly

本件について、私も何か方法がないか知りたいです。
(コマンドとか、Edgeの起動オプションなど)

今、実施している方法は、初回に以下を実行してます。(インストール時など)
・IEモードをOFFにする(InternetExplorerIntegrationLevel=0)
・Edgeを起動
・C:\Users\xxx\AppData\Local\Microsoft\Edge\User Data\Default
 に「SiteList.xml」がないことを確認
・Edgeを終了
・IEモードをONにする(InternetExplorerIntegrationLevel=1)
・Edgeを起動
・C:\Users\xxx\AppData\Local\Microsoft\Edge\User Data\Default
 に「SiteList.xml」があることを確認
・Edgeを終了

インストール時などは上記が可能ですが、それ以外でのsiteList.xmlの更新時は
Edge起動してから65秒での更新タイミングで更新されることを期待している状態です。
他に何かいい方法があるのであれば、教えてほしいです。

よろしくお願いいたします。

@Kelly_Y  I had done most of the settings but was unable to do 1 step.

Himank14_0-1641449505813.png

"Configure Internet explorer Integration " button is missing from the group policy editor.

 

Himank14_1-1641449600531.png

I had sorted the tabs alphabetically and as you can see there is no tab for "Configure Internet explorer Integration ".

Can you please advice on it. Also i had added the latest group policy to as instructed.

Himank14_0-1641458075998.png

 

@ikuno i am sorry, can you please post your response again in English.

@Himank14 Hi!  I'm not a policy expert :smile: but did you follow these instructions?  Configure Microsoft Edge for Windows | Microsoft Docs  It looks like your screenshots are a little different from the article.  

 

Thanks! 

 

-Kelly

I think you are using policy for old Edge browser, not new one. Thats why you can't find it there. New "Microsoft Edge" policies are right under "Administrative templates", not under "Windows components". If you will setup everything correctly in group policy, that site list xml will be read automatically by the browser. However update version number field after each change to that file, or browser may not read changes