AutoImportAtFirstRun policy no longer imports favorites

Iron Contributor

Has anyone else noticed that the "Automatically import another browser's data and settings at first run" policy has stopped working in Edge Dev Version 80.0.361.9? I tried it in Canary 81.0.375.0 and got the same result. However, it works fine in the Beta build 79.0.309.56. 


I have my policy set to automatically import settings from Internet Explorer. On first run, the favorites import dialog is skipped but the browser doesn't import favorites. I tried configuring this in the registry and with group policy and got the same result on two different machines. 


Favorites location has not been redirected on either machine. 






34 Replies

I also tested this on a personal machine of mine (Win10 1909 Home) that is not joined to our domain and I get the same result. 


On all machines, IE favorites will import fine if I import them manually through the menu. 


We are probably going to hold off deploying until we are sure this is going to work in the release build.



@AndrewSAIF, is this issue only with IE favorites?



Hi there, 


Previously I had only tried importing IE favorites, but after I saw your reply I set the policy to import Chrome favorites in the Dev build and it did the same thing. It did allow me to manually import Chrome favorites through the menu after startup. 


To test this I am deleting the User Data folder from %localappdata%\Microsoft\[Edge Version] so the first run experience is triggered. 


I tested the Beta build (79.0.309.58) with the policy set to import Chrome favorites and that worked just like it does with IE. It looks like something broke between this version and the current Dev version. 







Thanks for the heads up. I have taken a bug on this.



Awesome! Thanks for your help.



@AndrewSAIF I have the exact same experience with the Stable build. Favorites are only imported if I do so manually. This should be fixed soon, since a stable roll-out can't occur without this.

best response
Quick update. This has been fixed and the fix should be out in canary.
The same will land in stable in E81.
Thank you, good news indeed.

An ETA for Stable E81? I’m not familiar how the releases are provided.

@Miha Pecnik 

You can generally follow the Chromium release calendar and add a few days to get a good idea of Edge releases.



@Miha Pecnik I'm also curious about the release schedule. But it seems they handle this



does that mean that the current stable version (80) will not have this patch? this functionality was operational in the 79, but we were missing the removal of the wizard on first launch.

We are therefore again blocked in this version 80 for a massive deployment because of this new bug.

Is there a workaround ?

thank you


I quite agree. We need the correction already for Version 80.


Update 2020-02-21: Same Situation with Version 80.0.361.57



and its still not fixed in beta 81.0.416.16

Changelog for Build 81.0.410.1 says "Fixed an issue where the autoImportAtFirstRun management policy stopped working" but in none of the current releases in all four channels it's working (Stable, Beta, Dev, Canary).


Indeed that's a problem for us.



Now that others also confirm that the Option is still broken, when can we expect an fix?


This Bug is an real dealbreaker for our company rollout plans



Hey Joachim and @dkirchberger

Will you be willing to get on a quick Teams call with me to help repro the issue at our end?
I will share the details in a message.



Always open to help. You got mail

@AndrewSAIF @Joachim_T @rishavsharan 


"Funny" story... Today I was discussing deployment plans with my CTO and Director, and the Director asked if we'll be able to transfer our favorites from IE to Edge.  I said "we're way past importing favorites, easy button"... oh am I eating those words now.  I was excited to see that First Run can now be disabled, but it seems at the cost of auto-importing Favorites... super disappointing (and scary to be honest).  I have sold the new Edge to my executives, please Microsoft development team, let's make this a successful venture!  In any case, I am delaying the deployment to our enterprise now, which is disheartening. I digress.


We are on stable release Version 80.0.361.62 (Official build) (64-bit).  Automatically import another browser's data etc is Enabled and Import Favorites is Not Configured (tried Enabled as well).


I just don't understand how this gets past 3 development versions into a stable version. 


#Following #Concerned #Anxious 

1 best response

Accepted Solutions
best response
Quick update. This has been fixed and the fix should be out in canary.
The same will land in stable in E81.

View solution in original post