SOLVED

Why is Edge so slow to open?

Frequent Contributor

I have been using chromium-based Edge for a long time now, and believe it is a vast improvement on classic Edge, but as more and more features are added, I am very concerned at how "clunky" it is getting to use - even on a modern Intel i5 based machine with 8GB RAM.

 

I use Edge on a daily base on Windows 11 on my main Lenovo IdeaCentre 3 and Surface Laptop Go (4GB) and on two slightly older Windows 10 machines.  I run both Edge Dev and Edge Stable.

 

I am experimenting with Efficiency Mode and Startup Boost on different machines, but I am continuously appalled at the speed at which Edge takes to show anything on screen when I first open it, and often when loading pages there are pauses.

 

On the older Windows 10 machine I have been comparing Edge with the latest version of Firefox and Lion Browser.  Lion browser is chromium based and extremely fast by comparison.

 

I have five extensions running and my content is sync'd across my Microsoft Account.

 

I work with older clients, many of whom are using older Pentium and i3 devices, and more and more are complaining to me about Edge, which is a shame because 90% of them switched from Chrome to Edge and really loved it at first.  I have tested the latest version of Chrome on two devices recently (I hate it, but it is quicker to load.)  I am not aware of anything on my systems that may prevent Edge from opening correctly. 

 

Whether I have my home page (Edge Start) set to focussed, inspiratinal or informational the problem is the same.  Changing my startup page to a different page makes no difference either.

 

Thankfully Edge on Android continues to work really nicely.

4 Replies

I'm in the same boat.. since last week, Edge takes about 20 sec to load my first page. After that it works like it seposed to do. FF works just fine.
Version 95.0.1020.40 (Officiële build) (64-bits)
Windows build 22000.282
Desktop AMD Ryzen 5600X 32GB RAM

 

Reset Edge settings didn't work

best response confirmed by Graham-STMC (Frequent Contributor)
Solution
Okay, I think I've found the solution. Go to settings in Edge, System and Performance, open your computers proxy settings, automatic detect switch it to off. After this, Edge works how it should be.
Thanks that helped a little with a system already running, but when opening Edge immediately after starting Windows 10 or Windows 11, the delay for any content to show on the home page (Microsoft Start) or have any response from Edge (buttons do not work) is anything between 10 and 30 seconds, which I do not consider to be acceptable for normal every day use.

Hello,

 

@Graham-STMC  I' am also experiencing the same issue. I have done several tests and when I switch off sync, the performance of the UI increase 200% but obviously this is not the solution we expect.

 

With sync enable, when I open edge and go straight to elipses menu it takes 10/15 seconds to open and new tab also have a big lag.

 

Already repair edge but the problem persist. 

 

Please fix that Microsoft!

 

I' am using an Desktop AMD ryzen 5.

 

Best regards,

Daniel