View In File Explorer function in Sharepoint Site Does Not Work In IEMode

%3CLINGO-SUB%20id%3D%22lingo-sub-2382898%22%20slang%3D%22en-US%22%3EView%20In%20File%20Explorer%20function%20in%20Sharepoint%20Site%20Does%20Not%20Work%20In%20IEMode%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2382898%22%20slang%3D%22en-US%22%3E%3CP%3EHello%20-%20for%20local%20testing%20purposes%2C%20I%20setup%20IEMode%20to%20work%20on%20my%20PC%20by%20modifying%20the%203%20registry%20keys%20below%3A%3C%2FP%3E%3CP%3EHKEY_LOCAL_MACHINE%5CSOFTWARE%5CPolicies%5CMicrosoft%5CEdge%20%26gt%3B%3CBR%20%2F%3EInternetExplorerIntegrationLevel%20(REG_DWORD)%20with%20value%201%20(or%20decimal%3A%200x00000001)%3CBR%20%2F%3Eii.%20HKEY_LOCAL_MACHINE%5CSOFTWARE%5CPolicies%5CMicrosoft%5CInternet%20Explorer%5CMain%5CEnterpriseMode%20%26gt%3B%3CBR%20%2F%3ESiteList%20(REG_SZ)%20with%20path%20to%20your%20XML-sitelist%26nbsp%3B%3CBR%20%2F%3Eiii.%20HKEY_LOCAL_MACHINE%5CSOFTWARE%5CPolicies%5CMicrosoft%5CMicrosoftEdge%5CMain%5CEnterpriseMode%20%26gt%3B%3CBR%20%2F%3ESiteList%20(REG_SZ)%20with%20path%20to%20your%20XML-sitelist%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20then%20created%20an%20XML%20in%20accordance%20with%20the%20Enterprise%20Mode%20Sites%20List%20v2%20Schema%20and%20added%20sharepoint%20domain%20with%20open-in%20tag%20%22IE11%22%20and%20compat-mode%20%22IE11%22.%20This%20XML%20is%20pointed%20to%20by%20the%202nd%20and%203rd%20registry%20keys%20listed%20above.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EWhen%20I%20try%20to%20open%20the%20sharepoint%20side%20in%20Edge%2C%20I%20can%20see%20the%20tiny%20IE%20logo%20to%20the%20left%20of%20the%20address%20bar%20(which%20I%20understand%20is%20confirmation%20that%20IEMode%20is%20being%20used)%20and%20the%20main%20sharepoint%20page%20loads%20up%20fine.%20However%2C%20when%20I%20choose%20the%20%22View%20In%20File%20Explorer%22%20function%20to%20view%20a%20document%20library%20in%20the%20sharepoint%20site%2C%20a%20blank%20popup%20window%20appears%20with%20only%20a%20URL%20of%20the%20sharepoint%20site%20on%20top%20ending%20with%20%22%2Fopeninexplorer.aspx%22%20and%20nothing%20else%20happens.%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EHas%20anyone%20encountered%20this%20and%20knows%20how%20to%20go%20about%20correcting%20this%20behaviour%3F%20According%20to%20Microsoft%2C%20%3CSTRONG%3EView%20In%20File%20Explorer%3C%2FSTRONG%3E%20will%20work%20in%20IEMode%20in%20Edge.%20See%26nbsp%3B%3CA%20href%3D%22https%3A%2F%2Fdocs.microsoft.com%2Fen-us%2Fdeployedge%2Fedge-ie-mode-faq%23%3A~%3Atext%3DRun%2520Microsoft%2520Edge%2520with%2520the%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noreferrer%22%3Ehttps%3A%2F%2Fdocs.microsoft.com%2Fen-us%2Fdeployedge%2Fedge-ie-mode-faq%23%3A~%3Atext%3DRun%2520Microsoft%2520Edge%2520with%2520the%3C%2FA%3E.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThanks!%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-2393314%22%20slang%3D%22en-US%22%3ERe%3A%20View%20In%20File%20Explorer%20function%20in%20Sharepoint%20Site%20Does%20Not%20Work%20In%20IEMode%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2393314%22%20slang%3D%22en-US%22%3EThanks%20for%20reporting%20this%2C%20%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F351605%22%20target%3D%22_blank%22%3E%40Cellulose%3C%2FA%3E.%20When%20you%20perform%20those%20steps%20in%20IE%20itself%2C%20you%20should%20get%20a%20permissions%20prompt%20to%20allow%20access%20to%20the%20filesystem.%20While%20that%20permissions%20prompt%20is%20up%2C%20you%20also%20can%20see%20a%20browser%20window%20like%20what%20you%20describe.%20Is%20it%20possible%20the%20permissions%20prompt%20came%20up%20on%20a%20different%20monitor%20or%20behind%20the%20Edge%20window%20or%20anything%20like%20that%3F%3CBR%20%2F%3E%3CBR%20%2F%3E-John%3C%2FLINGO-BODY%3E
Regular Visitor

Hello - for local testing purposes, I setup IEMode to work on my PC by modifying the 3 registry keys below:

HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Edge >
InternetExplorerIntegrationLevel (REG_DWORD) with value 1 (or decimal: 0x00000001)
ii. HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Internet Explorer\Main\EnterpriseMode >
SiteList (REG_SZ) with path to your XML-sitelist 
iii. HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\MicrosoftEdge\Main\EnterpriseMode >
SiteList (REG_SZ) with path to your XML-sitelist 

 

I then created an XML in accordance with the Enterprise Mode Sites List v2 Schema and added sharepoint domain with open-in tag "IE11" and compat-mode "IE11". This XML is pointed to by the 2nd and 3rd registry keys listed above.

 

When I try to open the sharepoint side in Edge, I can see the tiny IE logo to the left of the address bar (which I understand is confirmation that IEMode is being used) and the main sharepoint page loads up fine. However, when I choose the "View In File Explorer" function to view a document library in the sharepoint site, a blank popup window appears with only a URL of the sharepoint site on top ending with "/openinexplorer.aspx" and nothing else happens. 

 

Has anyone encountered this and knows how to go about correcting this behaviour? According to Microsoft, View In File Explorer will work in IEMode in Edge. See https://docs.microsoft.com/en-us/deployedge/edge-ie-mode-faq#:~:text=Run%20Microsoft%20Edge%20with%2....

 

Thanks!

 

 

 

1 Reply
Thanks for reporting this, @Cellulose. When you perform those steps in IE itself, you should get a permissions prompt to allow access to the filesystem. While that permissions prompt is up, you also can see a browser window like what you describe. Is it possible the permissions prompt came up on a different monitor or behind the Edge window or anything like that?

-John