unsafely-treat-insecure-origin-as-secure does not seem to work in Edge 81.0.416.34

%3CLINGO-SUB%20id%3D%22lingo-sub-1259050%22%20slang%3D%22en-US%22%3Eunsafely-treat-insecure-origin-as-secure%20does%20not%20seem%20to%20work%20in%20Edge%2081.0.416.34%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1259050%22%20slang%3D%22en-US%22%3E%3CP%3EI%20am%20really%20having%20difficulties%20making%20this%20flag%20to%20work.%20It%20is%20essential%20for%20web%20development.%20I%20am%20having%20a%20local%20app%20running%20on%20http%3A%2F%2Flocalhost%3A3000%20trying%20to%20access%20a%20https%20resource%20on%20localhost%3A9001%20but%20to%20no%20avail.%3C%2FP%3E%3CP%3EI%20always%20get%20an%20error%20message%20in%20the%20console%20%22Access%20to%20XMLHttpRequest%20at%20'https%3A%2F%2Flocalhost%3A9001%2Fapi%2Fauth%2Flogin'%20from%20origin%20'http%3A%2F%2Flocalhost%3A3000'%20has%20been%20blocked%20by%20CORS%20policy%3A%20Response%20to%20preflight%20request%20doesn't%20pass%20access%20control%20check%3A%20No%20'Access-Control-Allow-Origin'%20header%20is%20present%20on%20the%20requested%20resource.%22%3C%2FP%3E%3CP%3EI%20have%20configured%20the%20%23unsafely-treat-insecure-origin-as-secure%20flag%20and%20also%20tried%20a%20--unsafely-treat-insecure-origin-as-secure%20startup%20parameter%20to%20msedge.exe.%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20image-alt%3D%22Slavius_0-1585313919718.png%22%20style%3D%22width%3A%20400px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Fgxcuf89792.i.lithium.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F179962i2DE539F1DEADAAE3%2Fimage-size%2Fmedium%3Fv%3D1.0%26amp%3Bpx%3D400%22%20title%3D%22Slavius_0-1585313919718.png%22%20alt%3D%22Slavius_0-1585313919718.png%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3EPlease%20I%20need%20help%20with%20this.%20It's%20making%20me%20crazy.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1259386%22%20slang%3D%22en-US%22%3ERe%3A%20unsafely-treat-insecure-origin-as-secure%20does%20not%20seem%20to%20work%20in%20Edge%2081.0.416.34%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1259386%22%20slang%3D%22en-US%22%3E%3CP%3EIt%20seems%20to%20have%20something%20to%20do%20with%20app%20middleware.%20Please%20disregard.%20TY%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1259461%22%20slang%3D%22en-US%22%3ERe%3A%20unsafely-treat-insecure-origin-as-secure%20does%20not%20seem%20to%20work%20in%20Edge%2081.0.416.34%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1259461%22%20slang%3D%22en-US%22%3EGood%20to%20know%20you%20figured%20it%20out%20%3A)%3C%2Fimg%3E%3C%2FLINGO-BODY%3E
Highlighted
New Contributor

I am really having difficulties making this flag to work. It is essential for web development. I am having a local app running on http://localhost:3000 trying to access a https resource on localhost:9001 but to no avail.

I always get an error message in the console "Access to XMLHttpRequest at 'https://localhost:9001/api/auth/login' from origin 'http://localhost:3000' has been blocked by CORS policy: Response to preflight request doesn't pass access control check: No 'Access-Control-Allow-Origin' header is present on the requested resource."

I have configured the #unsafely-treat-insecure-origin-as-secure flag and also tried a --unsafely-treat-insecure-origin-as-secure startup parameter to msedge.exe.

Slavius_0-1585313919718.png

Please I need help with this. It's making me crazy.

 

2 Replies
Highlighted

It seems to have something to do with app middleware. Please disregard. TY

Highlighted