Some text become zero width in recently canary version of Edge

Copper Contributor

Edge:  115.0.1895.0(Canary)

Win11(canary channel, 23H2, 25381.1)

I try stable version of Edge(114.0.1823.37) on the same PC, and it works well

For example:

1. autocomplete in console of developer window


2. some web site like



5 Replies
To clarify , you observe this behavior in the Canary version of Microsoft Edge and the stable version is working?
If that is the case, make sure report this issue using the Feedback option in the Microsoft Edge and share steps to reproduce the problem.


For someone hit the same problem, an workaround is edit the font settings of Edge, set mono font to an really mono font, not empty, simfang or simsum.

对于和我一样遇到了同样问题的用户, 一个临时解决方案是修改Edge的自定义字体设置, 随便设置一个真正的等宽字体(不要默认的空白, 也不要设置为宋体和仿宋)


Seems it only happen when all the below matches

1. Win11 Cannary channel(tested on win10 and works well, but I don't have a win11 on stable channel)

2. Edge cannary channel(tested on stable channel of Edge and works well)

3. all text with css


font-weight: bold;

font-family: monospace;


4. mono font in Edge is empty(the default value) or 仿宋(simfang) or 宋体(simsun)

5. Maybe system language must be Chinese(zh_CN), both 仿宋(simfang) and 宋体(simsun) is an chinese font(They are not really mono).


@Reza_Ameri I will feedback it in Edge latter but maybe difficult to reproduce



I try to remove `User Data` folder to do a clean report(mono font can not be reset to default value), but it also works well now.

Dev channel: 115.0.1880.3(BAD)

Beta channel: 114.0.1823.37(GOOD)

Verify display language of Edge must be set to Chinese because different font is setting.


And enable `efficiency mode`, exit Edge, kill all background process of edge, and restart Edge.

But it's stange,  after you enable `efficiency mode` and see the issue, disable `efficiency mode` and restart makes no difference.



Great, make sure file feedback report and also share all these information.