SOLVED

Smart Copy missing

Occasional Contributor

Hello all, 

 

I'm on Edge Beta (93.0.961.11) and for the past few months Smart Copy has been missing. It was there at some point in time.  In fact, on the What's New! page that comes up after Edge update it states that it is a feature since v 90. 

 

I've checked in two more PCs, one on release (v 92) and another on beta and it is missing. 

 

The only similar thing is Web Capture but that only gets me an image. 

 

Thanks,

21 Replies

@Andrés S Me too! Did you manage to get it back?

Still missing in action. I noticed on some release notes or somewhere that it was merged with Web Capture and when the selection rectangle shows a "smart copy" button appears but not to me, so, no dice yet.
best response confirmed by Andrés S (Occasional Contributor)
Solution

Smart Copy seems to be on field trial stage, at least for me on beta/dev/canary channels.
In any channels(stable..canary), command-line option "--enable-features=msEdgeAreaSelect" should enable the feature.

 

@atlanto, worked like a charm.

***Thank you!***

@atlanto 

 

Help how do I insert command-line ?????? Please provide me steps:  option "--enable-features=msEdgeAreaSelect" should enable the feature.

I would also like to know the status of this. The CMD line arg suggestion did not work for me., and I don't see Smart Copy listed under experimental features to enable either...

 

Currently running Edge 94.0.992.19 (Official build) beta (64-bit) on Win 10.

 

Thanks!

@ratu2007 @ncazer  So, basically it means launch Edge from a command line, just once. 

 

Steps:

 

Windows key+R 

On the window that opens type cmd.exe (enter)

 

... opens a command prompt window...

 

Type the two commands below

 

 

 

cd C:\Program Files (x86)\Microsoft\Edge Beta\Application
msedge --enable-features=msEdgeAreaSelect

 

 

 

This launches Edge and then the feature will be enabled.  You can close that Edge window now, the feature will remain enabled. 

 

I am on version 94.0.992.19 (Official build) beta and it is there, just above Web Capture.

 

For a few days, I saw Web Capture and Smart Copy merged on a single menu/submenu group. Now they are separate again.

 

@ncazer 

See 3dots menu->Help and feedback->Send feedback->Send diagnostic data(link)->Experiments and Field Trials(link).
There are
  "disabled_experiments": [ ... ]
  "enabled_experiments": [ ... ]
and
  {"feature_name": "msEdgeAreaSelect","trial_name": "SmartCopy"}
under enabled_experiments in my case.(beta 94.0.992.19, canary 95.0.1017.0, ...)

 

Note that this configuration is not same for all users and not configurable on user side.
Only command-line option can make change.

 

BTW, there is no such trial on stable 93.0.961.47 in my case but I can enable SmartCopy with just launching
"C:\Program Files (x86)\Microsoft\Edge\Application\msedge.exe" --enable-features=msEdgeAreaSelect.
I don't know whether "msEdgeAreaSelect" has some dependency or some blocker though.

 

@atlanto 

I am using Version 95.0.1011.1 (Official build) dev (64-bit)

 

C:\Program Files (x86)\Microsoft\Edge Dev \Application\msedge.exe --enable-features=msEdgeAreaSelect

 

Still, Smart Copy is missing.

@ratu2007 

 

I also am still not seeing smart copy after trying these cmd commands, and I don't see it under the developer options (clicking on the gear), or by going through the feedback / diagnostic data link.

 

Can someone please advice?

@Andrés S For the Beta channel, please make sure you have 'Optional Diagnostic Data' toggled on in Edge Settings. Wait 5 minutes and then restart your browser twice. You should now automatically be placed in the Smart Copy experimental group. Thank you!

Hi there, I checked I already have Optional Diagnostic Data toggled on. Still no Smart Copy / same issue as described.

Please advise.

@ncazer Please use Alt+Shift+I to send us feedback and check the box that says "Send diagnostic data" so we can evaluate your specific case. If you include the word "Smart Copy" it should be directly routed to our team. Thank you!

@johannal feedback sent.

 

It was there, last week I used it last. It was enabled using the command prompt method I posted above.  

 

My send diagnostic data was set so I disabled, logged off, restarted Edge twice waiting more than 5 minutes each time and still not there. 

 

Smart Copy is very useful, more useful than Web Capture (which duplicates Snip & Sketch functionality). It is even more useful on a business context because it does capture tables very accurately. 

feedback also sent. I still do not see it after trying cmd again.

@Andrés S Thanks for sending feedback! It seems like your ExperimentationAndConfigurationServiceControl policy is set to 1. In order to receive experiments it needs to be set to 2, or FullMode. This policy is set by your employer, or whoever manages your device, and cannot be changed if it is set to Mandatory. 

 

@ncazer Sorry, I'm unable to find your feedback. Did you use the words "Smart Copy" in your description? You can also check if your issue is policy related by going to edge://policy and searching for ExperimentationAndConfigurationServiceControl.

 

Apologies that you are unable to access the feature at this time. We hope to have Smart Copy in all channels soon, and I'll update this thread when it is available. 

Hi @johannal,

Thanks for your reply. I did include "Smart Copy" in the description when using Alt+Shift+I to send feedback as you described previously. I just sent it again this morning, please let me know if you get it.

In terms of checking edge://policy and searching for ExperimentationAndConfigurationServiceControl:
On my instance of Edge there is no value set. This seems like it could the the culprit based on your answer above, which also sounds like it is not mandatory by my employer / device manager if it's not set, correct?

If this is the case, can you provide direction to change its value appropriately to "2" or "full"? Thanks again for your assistance.
Here's an update: I was able to use cmd to edit group policy as described here: https://docs.microsoft.com/en-gb/DeployEdge/microsoft-edge-policies#experimentationandconfigurations.... I confirm that ExperimentationAndConfigurationServiceControl which was not set is now set to "2". I ran cmd again to enable Smart Copy, but I still am not getting the option when using CTRL-SHFT-X.

I have re-sent you my diagnostic data.
Hi all,

Thanks for the reply. I am the admin of this whole setup MS365 business, and as part of the setup we have Defender Level 2 (the additional feature). That one brings Intune on tow, so my first suspicion was that all the "hardening" features somehow created a policy restricting the Experimentation level.

I spent a couple of hours looking all over the place and confirmed that no policy is being set by MS365, furthermore, my laptop is not registered with Azure AD, so it did not come from there.

---

Next, in order to confirm @johannal 's diagnostic I followed the same article and installed the Policy Template for Edge.

I checked the registry as well as the the flag set by the Policy using the Policy Editor and the flag *is not there*. I wonder if the diagnostic log is reporting the wrong information by some reason.

I made the change using the Policy Editor then and restarted Edge (by making some restarting-requiring change on edge://flags back and forth) and yes, Smart Copy has appeared on the Context Menu. And in fact, I was able to use it for work, it is really helpful.

So, I was in the exact same situation as @ncazer: the policy was not set. The flag on the Registry was not present at all.

One incidental annoying thing: Now on Edge's settings page a huge ugly banner shows stating that my Edge configuration is managed by my administrator. I have traced it to the Policy setting. It is unsightly but, well, can't be helped.

-----------

UPDATE: Because I didn't like that banner I decided to rename the Registry flag to something, and now the banner is gone - as well as Smart Copy. But, on Policy Editor it *still shows as enabled* so there is an disconnect between Policy Editor and the Registry (that's totally out of the scope of this thread).

If I rename that registry flag back once again to the correct name, Smart Copy comes back.

So, my advice, check the Registry in addition to the Policy Editor.

Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Edge