Site Permissions - Not working

Iron Contributor

@BEN_FAWKES @Rohit_M @MicrosoftX  There are some site permissions which never work.



When I tried Ads permission blocked on a NDTV  it with tracking prevention off and lots of ads, it wasn't blocking any of the ads. Plus the video also started playing. 

But when I tried to highlight ads using "Highlight ad frames" in rendering tab, it highlighted all visible ads with red color. This means it was successfully able to detect all ads.



And when I tried to block ads using "Force block in developer preferences", it really blocked all ads. But this permission resets after we close the developer tool.


I highly doubt when you people have the built-in ad blocker and a site settings toggle button as in the first screenshot, why doesn't it work? And we won't be needing any more ad-blockers which consume a lot of CPU and memory.


I know this is going to hurt monetization but this can be disabled by default and enabled as people select to block ads in site settings. This would be the best approach.

3 Replies
ublock origin doesn't consume a lot of CPU or memory.
But the point is when the functionality is there. It should work.
I think it's basically coming from Chromium, don't seem like Edge developers even worked on it.
but even if they do, I still don't think will be as good as ublock origin and all of its filters that are made by community members.
unless Edge will allow us to use custom filters too, which will be awesome!