Salesforce behaviour with Edge Canary 86.0.611.0

Occasional Contributor

I have recently been experiencing issues with Edge Canary in the latest releases that aren't occurring in Edge itself with Salesforce. Some pages within Salesforce where we use a custom tab on an opportunity is opening as a separate window instead of appearing in the nested tab. 

If I click on the Pandadoc tab, it should open a nested view into the Pandadoc system, but is instead opening a new tab. The link when you highlight over the link is javascript:void(0)

It should look like the 2020-08-18 21_13_02-Window.png , but instead looks like 2020-08-18 21_13_52-Window.png.


Unfortunately the buttons on the new window do not work as I think they depend on references on the actual Salesforce opportunities page, so I'm having to work in Edge itself at the moment.


9 Replies


Hi there, you are welcome to the Microsoft Edge Insider Community Hub!

Thanks for reporting the issue here. I would recommend you to send feedback about this bug through the in-app feedback tool in Microsoft Edge (Alt+Shift+I) with the diagnostics attached in order to help the Microsoft Edge dev team to resolve your issue as soon as possible.



I also started seeing issues in Salesforce from 86.0.611.0 and all builds since. I have provided the feedback via the Edge Send Feedback option as well.


We use the Support console and when I try an open a support case I can seeing looping "Waiting for.." URL handoffs in the bottom left corner of the page and then I get an error and broken page symbol:


<redactedcomanyname> redirected you too many times



On other pages I will get the following error message as it tries to load page elements:


Your browser privacy settings have prevented this page from showing some Visualforce content. To display this content you need to change your browser privacy settings to allow "Third Party" cookies from the domain <redacted>.<redacted> Alternatively, if your browser is Internet Explorer, you can add <redacted>.<redacted> to your trusted sites list in the security options page.


Hi theshaunshaw,

I did send through the diagnostics details as per your recommendation back in August. The issue is continuing to occur on the latest release, so the issue hasn't been resolved as of yet.

@rob_farnell Latest version of Edge Stable is breaking the Salesforce site for us as well, particularly parts of the site coming from All versions of Google Chrome (stable, beta, canary) are working fine. Sent a few reports to Edge feedback.

Additional discussion here:
Problems with Salesforce and Microsoft Edge : salesforce (

Hopefully this gets addressed soon, this will hurt adoption of Edge within our company.

@andrewtchilds I had a look at the release notes here: Microsoft Edge release notes for Stable Channel | Microsoft Docs


I don't think the security updates that you mention on Reddit are the issue, as the issue pre-dates that release number. 

Could it be a cookie issue? Microsoft Edge Browser Policy Documentation | Microsoft Docs

best response confirmed by rob_farnell (Occasional Contributor)

@rob_farnell Nice find! Was there some changelog that you got that from?

I was able to add [*.] and [*.] to the list of sites that use the legacy SameSite behavior for cookies and things seem to be working now.

Used this policy, specifically:


@andrewtchilds Great news!

The release notes mentioned the cookie change on the features list. It was the only thing that I believed was within the vicinity of affecting the iframes on the list.

Thanks for testing my suggestion.


I've attached an export of the registry key that worked for me too.

@rob_farnell & @andrewtchilds - thanks guys, that has fixed it for me based on 1 day of testing today!


I am sorry I could not reply to the question you asked because I was offline for a month.



Thanks for giving the answer to the conversation :smile: