SOLVED

"2-Hop" Authentication stopped working in Canary (86.0.619.0)

%3CLINGO-SUB%20id%3D%22lingo-sub-1614230%22%20slang%3D%22en-US%22%3E%222-Hop%22%20Authentication%20stopped%20working%20in%20Canary%20(86.0.619.0)%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1614230%22%20slang%3D%22en-US%22%3E%3CP%3EAs%20I%20described%20here%2C%20we%20use%202-hop%20authentication%20(delegation)%20to%20access%20files%20on%20additional%20servers%3A%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fdiscussions%2Fintegrated-authorization-for-intranet-sites%2Fm-p%2F672095%2Fhighlight%2Ftrue%23M4555%22%20target%3D%22_blank%22%3Ehttps%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fdiscussions%2Fintegrated-authorization-for-intranet-sites%2Fm-p%2F672095%2Fhighlight%2Ftrue%23M4555%3C%2FA%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EUntil%20the%20update%20to%20Canary%20last%20night%2C%20this%20worked%20perfectly%2C%20but%20as%20of%20today%2C%20it%20is%20failing.%20This%20is%20a%20big%20deal%20for%20us%20and%20I%20sure%20hope%20it's%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1614296%22%20slang%3D%22en-US%22%3ERe%3A%20%222-Hop%22%20Authentication%20stopped%20working%20in%20Canary%20(86.0.619.0)%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1614296%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F50052%22%20target%3D%22_blank%22%3E%40Keith%20Davis%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EJust%20updated%20to%26nbsp%3B86.0.620.0%20and%20issue%20still%20exists.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1627521%22%20slang%3D%22en-US%22%3ERe%3A%20%222-Hop%22%20Authentication%20stopped%20working%20in%20Canary%20(86.0.619.0)%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1627521%22%20slang%3D%22en-US%22%3E%3CP%3EStill%20broken%20in%26nbsp%3B87.0.627.0.%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F484598%22%20target%3D%22_blank%22%3E%40fawkes%3C%2FA%3E%26nbsp%3B%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F470968%22%20target%3D%22_blank%22%3E%40MissyQ%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EIf%20this%20makes%20it%20to%20production%2C%20we%20might%20have%20to%20do%20something%20as%20drastic%20as%20switch%20all%20users%20to%20Chrome%2C%20as%20this%20will%20break%20production%20resources.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EFYI%2C%20I've%20verified%20that%20this%20issue%20does%20not%20exist%20in%20Dev%2C%20Beta%2C%20Stable%2C%20and%20also%20does%20not%20exist%20in%20Chrome%20Canary%20(87.0.4252.0).%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1631319%22%20slang%3D%22en-US%22%3ERe%3A%20%222-Hop%22%20Authentication%20stopped%20working%20in%20Canary%20(86.0.619.0)%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1631319%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F50052%22%20target%3D%22_blank%22%3E%40Keith%20Davis%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EWow!%20This%20problem%20has%20made%20it%20to%20Dev%20now%20(86.0.622.3)!!%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EPlease%2C%20please%2C%20please%2C%20somebody%20pay%20attention%20to%20this%20issue.%20We%20are%20going%20to%20have%20serious%20problems%20if%20this%20makes%20it%20to%20stable!!!!%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1637043%22%20slang%3D%22en-US%22%3ERe%3A%20%222-Hop%22%20Authentication%20stopped%20working%20in%20Canary%20(86.0.619.0)%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1637043%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F50052%22%20target%3D%22_blank%22%3E%40Keith%20Davis%3C%2FA%3E%26nbsp%3BThanks%20for%20looping%20us%20in%20on%20this.%20I'll%20see%20if%20I%20can%20get%20any%20insights%20from%20the%20team.%20In%20the%20meantime%2C%20can%20you%20please%20submit%20detailed%20feedback%20and%20diagnostics%20through%20the%20browser%2C%20if%20you%20haven't%20yet%3F%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3E%3CI%3EFawkes%20(they%2Fthem)%3CBR%20%2F%3EProgram%20Manager%20%26amp%3B%20Community%20Manager%20-%20Microsoft%20Edge%3CI%3E%3C%2FI%3E%3C%2FI%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1637048%22%20slang%3D%22en-US%22%3ERe%3A%20%222-Hop%22%20Authentication%20stopped%20working%20in%20Canary%20(86.0.619.0)%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1637048%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F484598%22%20target%3D%22_blank%22%3E%40fawkes%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThanks.%20Yes%2C%20I've%20sent%20that%20in%20multiple%20times%2C%20from%20both%20Canary%20and%20Dev.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1637064%22%20slang%3D%22en-US%22%3ERe%3A%20%222-Hop%22%20Authentication%20stopped%20working%20in%20Canary%20(86.0.619.0)%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1637064%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F50052%22%20target%3D%22_blank%22%3E%40Keith%20Davis%3C%2FA%3E%26nbsp%3BPerfect%2C%20I'll%20reach%20out%20to%20our%20Feedback%20team%20and%20ensure%20that%20it%20got%20to%20the%20right%20feature%20owner.%20I'll%20let%20you%20know%20if%20they%20end%20up%20needing%20any%20additional%20info.%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3E%3CI%3EFawkes%20(they%2Fthem)%3CBR%20%2F%3EProgram%20Manager%20%26amp%3B%20Community%20Manager%20-%20Microsoft%20Edge%3CI%3E%3C%2FI%3E%3C%2FI%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1637559%22%20slang%3D%22en-US%22%3ERe%3A%20%222-Hop%22%20Authentication%20stopped%20working%20in%20Canary%20(86.0.619.0)%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1637559%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F50052%22%20target%3D%22_blank%22%3E%40Keith%20Davis%3C%2FA%3E%26nbsp%3BI'm%20happy%20to%20confirm%20that%20your%20feedback%20made%20it%20to%20the%20right%20people%2C%20who%20have%20made%20it%20into%20a%20bug%20and%20are%20actively%20investigating%20it!%20Thanks%20for%20letting%20us%20know%20so%20we%20could%20follow-up%20for%20you.%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3E%3CI%3EFawkes%20(they%2Fthem)%3CBR%20%2F%3EProgram%20Manager%20%26amp%3B%20Community%20Manager%20-%20Microsoft%20Edge%3CI%3E%3C%2FI%3E%3C%2FI%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1637621%22%20slang%3D%22en-US%22%3ERe%3A%20%222-Hop%22%20Authentication%20stopped%20working%20in%20Canary%20(86.0.619.0)%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1637621%22%20slang%3D%22en-US%22%3E%3CP%3EThank%20you!!%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1655502%22%20slang%3D%22en-US%22%3ERe%3A%20%222-Hop%22%20Authentication%20stopped%20working%20in%20Canary%20(86.0.619.0)%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1655502%22%20slang%3D%22en-US%22%3E%3CP%3EHello%26nbsp%3B%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F50052%22%20target%3D%22_blank%22%3E%40Keith%20Davis%3C%2FA%3E%2C%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3EThanks%20for%20reporting%20and%20sorry%20for%20this%20experience.%3C%2FP%3E%0A%3CP%3EThe%20Edge%20team%20has%20introduced%20a%20fix%20yesterday%20that%20I%20believe%20should%20address%20the%20incident%20you%20are%20hitting.%20The%20fix%20has%20deployed%20in%20today's%20Canary%20build%26nbsp%3B%3CSPAN%3E87.0.636.0%20.%3C%2FSPAN%3E%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3E%3CSPAN%3ECould%20you%20update%20Canary%20and%20confirm%20if%20the%20issue%20has%20been%20resolved%3F%3C%2FSPAN%3E%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3E%3CSPAN%3EThank%20you%2C%3C%2FSPAN%3E%3C%2FP%3E%0A%3CP%3E%3CSPAN%3EDavid%20Delgadillo%3C%2FSPAN%3E%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1656778%22%20slang%3D%22en-US%22%3ERe%3A%20%222-Hop%22%20Authentication%20stopped%20working%20in%20Canary%20(86.0.619.0)%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1656778%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F404881%22%20target%3D%22_blank%22%3E%40DavidD95%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EYes!!%20I%20can%20confirm%20that%20the%20issue%20is%20resolved%20in%26nbsp%3B%3CSPAN%3E87.0.636.0!%3C%2FSPAN%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1658342%22%20slang%3D%22en-US%22%3ERe%3A%20%222-Hop%22%20Authentication%20stopped%20working%20in%20Canary%20(86.0.619.0)%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1658342%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F50052%22%20target%3D%22_blank%22%3E%40Keith%20Davis%3C%2FA%3E%26nbsp%3BThanks%20for%20confirmation.%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3EWe're%20patching%20this%20fix%20into%2086%20build%20as%20well%20which%20Beta%20is%20currently%20on.%20Next%20update%20should%20include%20the%20fix.%20Issue%20won't%20hit%20production.%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3EThanks%20again%20for%20your%20help.%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3E-David%20Delgadillo%3C%2FP%3E%3C%2FLINGO-BODY%3E
Frequent Contributor

As I described here, we use 2-hop authentication (delegation) to access files on additional servers:

 

https://techcommunity.microsoft.com/t5/discussions/integrated-authorization-for-intranet-sites/m-p/6...

 

Until the update to Canary last night, this worked perfectly, but as of today, it is failing. This is a big deal for us and I sure hope it's 

11 Replies

@Keith Davis 

 

Just updated to 86.0.620.0 and issue still exists.

Still broken in 87.0.627.0. 

 

@Deleted @MissyQ 

 

If this makes it to production, we might have to do something as drastic as switch all users to Chrome, as this will break production resources.

 

FYI, I've verified that this issue does not exist in Dev, Beta, Stable, and also does not exist in Chrome Canary (87.0.4252.0).

@Keith Davis 

 

Wow! This problem has made it to Dev now (86.0.622.3)!!

 

Please, please, please, somebody pay attention to this issue. We are going to have serious problems if this makes it to stable!!!!

@Keith Davis Thanks for looping us in on this. I'll see if I can get any insights from the team. In the meantime, can you please submit detailed feedback and diagnostics through the browser, if you haven't yet?

 

Fawkes (they/them)
Program Manager & Community Manager - Microsoft Edge

@Deleted 

 

Thanks. Yes, I've sent that in multiple times, from both Canary and Dev.

@Keith Davis Perfect, I'll reach out to our Feedback team and ensure that it got to the right feature owner. I'll let you know if they end up needing any additional info.

 

Fawkes (they/them)
Program Manager & Community Manager - Microsoft Edge

@Keith Davis I'm happy to confirm that your feedback made it to the right people, who have made it into a bug and are actively investigating it! Thanks for letting us know so we could follow-up for you.

 

Fawkes (they/them)
Program Manager & Community Manager - Microsoft Edge

Hello @Keith Davis,

 

Thanks for reporting and sorry for this experience.

The Edge team has introduced a fix yesterday that I believe should address the incident you are hitting. The fix has deployed in today's Canary build 87.0.636.0 .

 

Could you update Canary and confirm if the issue has been resolved?

 

Thank you,

David Delgadillo

 

@DavidD95 

 

Yes!! I can confirm that the issue is resolved in 87.0.636.0!

Best Response
Solution

@Keith Davis Thanks for confirmation.

 

We're patching this fix into 86 build as well which Beta is currently on. Next update should include the fix. Issue won't hit production.

 

Thanks again for your help.

 

-David Delgadillo