Home

Proxy Authentication not working with profile

%3CLINGO-SUB%20id%3D%22lingo-sub-982875%22%20slang%3D%22en-US%22%3EProxy%20Authentication%20not%20working%20with%20profile%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-982875%22%20slang%3D%22en-US%22%3E%3CP%3EHello%2C%3C%2FP%3E%3CP%3Ewe%20use%20a%20proxy%20server%20which%20requires%20authentication.%20I%20have%20two%20profiles%20in%20my%20Edge%20Dev%20%3CSPAN%3E79.0.309.11%20(one%20for%20business%20and%20one%20private).%20If%20I%20now%20want%20to%20use%20the%20private%20profile%20I%20have%20no%20access%20to%20the%20Internet%20because%20the%20browser%20uses%20my%20private%20account%20as%20proxy%20authentication%20and%20not%20my%20windows%20account.%20When%20I%20disable%20this%20function%20%3CA%20href%3D%22edge%3A%2F%2Fflags%2F%23edge-sign-in-with-aad%22%20target%3D%22_blank%22%20rel%3D%22nofollow%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%22%3Eedge%3A%2F%2Fflags%2F%23edge-sign-in-with-aad%3C%2FA%3E%26nbsp%3Bthe%20proxy%20authentication%20works%20as%20expected%20but%20then%20I%20cannot%20use%20SSO%20for%20other%20websites.%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%3EIs%20there%20a%20setting%20for%20this%20or%20is%20this%20the%20expected%20behavior%3F%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%3EBest%20regards%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%3CSPAN%3EKai%3C%2FSPAN%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-982927%22%20slang%3D%22en-US%22%3ERe%3A%20Proxy%20Authentication%20not%20working%20with%20profile%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-982927%22%20slang%3D%22en-US%22%3EHi%2C%3CBR%20%2F%3EWhat%20type%20of%20proxy%20server%20is%20it%20and%20how%20do%20you%20use%20it%20on%20Edge%20insider%3F%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-983080%22%20slang%3D%22en-US%22%3ERe%3A%20Proxy%20Authentication%20not%20working%20with%20profile%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-983080%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F310193%22%20target%3D%22_blank%22%3E%40HotCakeX%3C%2FA%3E%26nbsp%3BIt's%20a%20McAfee%20Web%20Gateway%20and%20we%20did%20not%20configured%20something%20in%20the%20Edge%20we%20just%20configured%20the%20Windows%20proxy%20settings.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-983442%22%20slang%3D%22en-US%22%3ERe%3A%20Proxy%20Authentication%20not%20working%20with%20profile%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-983442%22%20slang%3D%22en-US%22%3EWhen%20you%20configure%20it%20system%20wide%20on%20Windows%2C%20it%20won't%20matter%20which%20profile%20is%20selected%20in%20Edge%20insider%20browser%20because%20they%20all%20use%20the%20same%20Windows%20proxy%20settings.%3CBR%20%2F%3E%3CBR%20%2F%3Ebut%20of%20course%20there%20seems%20to%20be%20a%20conflict%20in%20your%20case%20when%20it's%20combined%20with%20SSO..unfortunately%20lots%20of%20other%20users%20have%20reported%20issues%20with%20SSO%20too%3CBR%20%2F%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1001424%22%20slang%3D%22en-US%22%3ERe%3A%20Proxy%20Authentication%20not%20working%20with%20profile%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1001424%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F310193%22%20target%3D%22_blank%22%3E%40HotCakeX%3C%2FA%3E%26nbsp%3BYes%2C%20i%20know%20that%20they%20use%20the%20Windows%20proxy%20settings%2C%20but%20the%20Browser%20is%20using%20the%20connected%20account%20of%20the%20current%20profile%20to%20authenticate%20at%20the%20proxy%20and%20I%20think%20that%20should%20not%20happen.%20It%20should%20use%20the%20Windows%20user%20instead%20to%20authenticate%20at%20the%20proxy.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1001458%22%20slang%3D%22en-US%22%3ERe%3A%20Proxy%20Authentication%20not%20working%20with%20profile%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1001458%22%20slang%3D%22en-US%22%3EYes%20I%20think%20you're%20right%2C%20I'm%20not%20familiar%20with%20McAfee%20Web%20Gateway%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1001756%22%20slang%3D%22en-US%22%3ERe%3A%20Proxy%20Authentication%20not%20working%20with%20profile%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1001756%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F310193%22%20target%3D%22_blank%22%3E%40HotCakeX%3C%2FA%3EI%20don't%20think%20the%20problem%20is%20McAfee%20specific%2C%20it's%20a%20general%20problem.%20The%20Edge%20uses%20the%20credentials%20of%20the%20current%20profile%20for%20proxy%20authentication%20instead%20of%20the%20Windows%20credentials.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1001763%22%20slang%3D%22en-US%22%3ERe%3A%20Proxy%20Authentication%20not%20working%20with%20profile%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1001763%22%20slang%3D%22en-US%22%3EWindows%20credentials%3F%20you%20mean%20the%20same%20username%20and%20password%20that%20is%20used%20to%20log%20into%20Windows%3F%3CBR%20%2F%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1001839%22%20slang%3D%22en-US%22%3ERe%3A%20Proxy%20Authentication%20not%20working%20with%20profile%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1001839%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F310193%22%20target%3D%22_blank%22%3E%40HotCakeX%3C%2FA%3E%26nbsp%3Byes%2C%20like%20in%20every%20other%20browser.%20When%20I%20use%20Firefox%2C%20IE%20or%20the%20old%20Edge%20the%20browser%20uses%20my%20Windows%20credentials%20to%20authenticate%20at%20the%20Proxy.%20Only%20the%20new%20Edge%20uses%20the%20credentials%20of%20the%20current%20profile%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1002517%22%20slang%3D%22en-US%22%3ERe%3A%20Proxy%20Authentication%20not%20working%20with%20profile%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1002517%22%20slang%3D%22en-US%22%3EThat's%20weird.%3CBR%20%2F%3Ecredential%20of%20the%20current%20profile%20means%20the%20saved%20passwords%20in%20your%20profile%20or%20your%20Microsoft%20account%20email%20and%20pass%3F%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1043970%22%20slang%3D%22en-US%22%3ERe%3A%20Proxy%20Authentication%20not%20working%20with%20profile%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1043970%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F310193%22%20target%3D%22_blank%22%3E%40HotCakeX%3C%2FA%3E%26nbsp%3BIt%20uses%20my%20authentication%20of%20the%20Microsoft%20account%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1044755%22%20slang%3D%22en-US%22%3ERe%3A%20Proxy%20Authentication%20not%20working%20with%20profile%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1044755%22%20slang%3D%22en-US%22%3EYou%20mentioned%20earlier%20that%20you%20don't%20think%20the%20problem%20is%20McAfee%20specific%2C%20would%20you%20mind%20saying%20what%20other%20proxies%20have%20problem%3F%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1049191%22%20slang%3D%22en-US%22%3ERe%3A%20Proxy%20Authentication%20not%20working%20with%20profile%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1049191%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F310193%22%20target%3D%22_blank%22%3E%40HotCakeX%3C%2FA%3E%26nbsp%3BI%20just%20guess%20that%20all%20those%20proxies%20who%20are%20using%20that%20kind%20of%20authentication%20got%20the%20same%20problem%2C%20but%20maybe%20I'm%20wrong%3C%2FP%3E%3C%2FLINGO-BODY%3E
K_Holzer
Occasional Contributor

Hello,

we use a proxy server which requires authentication. I have two profiles in my Edge Dev 79.0.309.11 (one for business and one private). If I now want to use the private profile I have no access to the Internet because the browser uses my private account as proxy authentication and not my windows account. When I disable this function edge://flags/#edge-sign-in-with-aad the proxy authentication works as expected but then I cannot use SSO for other websites.

 

Is there a setting for this or is this the expected behavior?

 

Best regards

Kai

12 Replies
Hi,
What type of proxy server is it and how do you use it on Edge insider?

@HotCakeX It's a McAfee Web Gateway and we did not configured something in the Edge we just configured the Windows proxy settings.

 

 

When you configure it system wide on Windows, it won't matter which profile is selected in Edge insider browser because they all use the same Windows proxy settings.

but of course there seems to be a conflict in your case when it's combined with SSO..unfortunately lots of other users have reported issues with SSO too

@HotCakeX Yes, i know that they use the Windows proxy settings, but the Browser is using the connected account of the current profile to authenticate at the proxy and I think that should not happen. It should use the Windows user instead to authenticate at the proxy.

Yes I think you're right, I'm not familiar with McAfee Web Gateway

@HotCakeXI don't think the problem is McAfee specific, it's a general problem. The Edge uses the credentials of the current profile for proxy authentication instead of the Windows credentials.

Windows credentials? you mean the same username and password that is used to log into Windows?

@HotCakeX yes, like in every other browser. When I use Firefox, IE or the old Edge the browser uses my Windows credentials to authenticate at the Proxy. Only the new Edge uses the credentials of the current profile

That's weird.
credential of the current profile means the saved passwords in your profile or your Microsoft account email and pass?

@HotCakeX It uses my authentication of the Microsoft account 

You mentioned earlier that you don't think the problem is McAfee specific, would you mind saying what other proxies have problem?

@HotCakeX I just guess that all those proxies who are using that kind of authentication got the same problem, but maybe I'm wrong