Problem with Bing set as default search engine

%3CLINGO-SUB%20id%3D%22lingo-sub-2142303%22%20slang%3D%22en-US%22%3EProblem%20with%20Bing%20set%20as%20default%20search%20engine%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2142303%22%20slang%3D%22en-US%22%3E%3CP%3EToday%20we%20are%20experiencing%20Edge%20(Beta)%20crashes%20for%20instances%20where%20the%20default%20search%20provider%20is%20set%20to%20Bing.%20It%20crashes%20after%20trying%20to%20enter%20any%20address%20to%20the%20address%20bar.%20After%20changing%20the%20default%20search%20provider%20to%20any%20other%2C%20Edge%20starts%20to%20work%20and%20stops%20crashing.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-2142338%22%20slang%3D%22en-US%22%3ERe%3A%20Problem%20with%20Bing%20set%20as%20default%20search%20engine%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2142338%22%20slang%3D%22en-US%22%3E%3CP%3E%3CBR%20%2F%3EI%20can%20confirm%20we%20have%20this%20problem%20aswell%20only%20with%20the%20stable%20version%20%3A%2088.0.705.68%3CBR%20%2F%3E%3CBR%20%2F%3EChanging%20the%20browser%20default%20search%20engine%20solves%20it.%3CBR%20%2F%3E%3CBR%20%2F%3E%3C%2FP%3E%3CP%3ESeems%20like%20its%20the%20same%20as%20this%20bug%20from%20a%20while%20ago%2C%20but%20now%20it%20occurs%20with%20Bing.%3CBR%20%2F%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fdiscussions%2Fbug-in-edge-suggestions%2Fm-p%2F1557424%22%20target%3D%22_blank%22%3Ehttps%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fdiscussions%2Fbug-in-edge-suggestions%2Fm-p%2F1557424%3C%2FA%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-2142427%22%20slang%3D%22en-US%22%3ERe%3A%20Problem%20with%20Bing%20set%20as%20default%20search%20engine%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2142427%22%20slang%3D%22en-US%22%3EI%20can%20confirm%20this%20as%20well%2C%20we're%20having%20multiple%20clients%20with%20Edge%20Version%2088.0.705.68%20having%20this%20problem.%20Deleting%20cache%20%2B%20removing%20Bing%20as%20the%20default%20search%20engine%20%22solves%22%20the%20issue%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-2142436%22%20slang%3D%22en-US%22%3ERE%3A%20Problem%20with%20Bing%20set%20as%20default%20search%20engine%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2142436%22%20slang%3D%22en-US%22%3EHave%20same%20problem.%20disable%20Show%20me%20search%20and%20site%20suggestions%20using%20my%20typed%20characters%20solve%20problem%20%3B(%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-2142487%22%20slang%3D%22en-US%22%3ERe%3A%20Problem%20with%20Bing%20set%20as%20default%20search%20engine%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2142487%22%20slang%3D%22en-US%22%3EI%20can%20confirm%20that%20any%20of%20the%20following%20changes%20can%20be%20a%20workaround%3A%3CBR%20%2F%3E-%20disable%20%22Show%20me%20search%20and%20site%20suggestions%20using%20my%20typed%20characters%22%3CBR%20%2F%3Eor%3CBR%20%2F%3E-%20set%20another%20default%20search%20engine%20other%20than%20Bing%3CBR%20%2F%3E%3CBR%20%2F%3EWhen%20a%20solution%20will%20be%20provided%20by%20Microsoft%3F%3CBR%20%2F%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-2142536%22%20slang%3D%22en-US%22%3ERe%3A%20Problem%20with%20Bing%20set%20as%20default%20search%20engine%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2142536%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F796846%22%20target%3D%22_blank%22%3E%40JB128%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CP%3EWhich%20OS%20and%20OS%20version%20are%20you%20guys%20using%20exactly%3F%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI'm%20on%20Windows%2010%2020H2%20latest%20update%20and%20Edge%20stable%26nbsp%3B%3CSPAN%3EVersion%2088.0.705.68%20(Official%20build)%20(64-bit)%3C%2FSPAN%3E%3C%2FP%3E%3CP%3EBing%20default%20search%20engine%2C%20no%20crashes%20whatsoever.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3Emake%20sure%20to%20go%20here%3A%20edge%3A%2F%2Fcrashes%2F%3C%2FP%3E%3CP%3Eclick%20on%20submit%20feedback%20button%20next%20to%20the%20crash%2C%20then%20in%20the%20new%20window%20that%20opens%2C%20briefly%20explain%20what%20happens%20and%20what%20you%20were%20doing%20when%20the%20crash%20happened%2C%20and%20then%20send%20it.%3C%2FP%3E%3C%2FLINGO-BODY%3E
New Contributor

Today we are experiencing Edge (Beta) crashes for instances where the default search provider is set to Bing. It crashes after trying to enter any address to the address bar. After changing the default search provider to any other, Edge starts to work and stops crashing.

11 Replies


I can confirm we have this problem aswell only with the stable version : 88.0.705.68

Changing the browser default search engine solves it.

Seems like its the same as this bug from a while ago, but now it occurs with Bing.
https://techcommunity.microsoft.com/t5/discussions/bug-in-edge-suggestions/m-p/1557424

I can confirm this as well, we're having multiple clients with Edge Version 88.0.705.68 having this problem. Deleting cache + removing Bing as the default search engine "solves" the issue
Have same problem. disable Show me search and site suggestions using my typed characters solve problem ;(
I can confirm that any of the following changes can be a workaround:
- disable "Show me search and site suggestions using my typed characters"
or
- set another default search engine other than Bing

When a solution will be provided by Microsoft?

@JB128 

Which OS and OS version are you guys using exactly?

 

I'm on Windows 10 20H2 latest update and Edge stable Version 88.0.705.68 (Official build) (64-bit)

Bing default search engine, no crashes whatsoever.

 

make sure to go here: edge://crashes/

click on submit feedback button next to the crash, then in the new window that opens, briefly explain what happens and what you were doing when the crash happened, and then send it.

It seems that issue can be fixed also by disabling Bing thru GPO, 

 

Set "Enable Microsoft Search in Bing suggestions in the address bar" to Disabled.

This Disables AAD Account Internal searches from Address Bar.

 

It seems that problem is somehow mixed with "background service for Microsoft Search in Bing", because this fix is not needed if computer dont have O365 Installed, even with Bing as Default Search engine.

 

@HotCakeX 

We use win 10 1909 but it's also a problem on RDS 2012 R2.

 

 

The problems occurs also on RDS 2012 R2, we dont have O365 installed or enabled.

 

Will try the GPO tip.
Thanks

Retested this with that 2016 Server and still Bing search works and addressbar search dont crash Edge. I wonder is there some differences how Edge works in different OS versions ?

Tested also my 20H2/2004 W10 and Edge crashes, but when i remove Bing service then Edge won't crash anymore even that GPO fix isn't on. O365 build is 13628.30380

Both server and W10 are hybrids and browsers profile sync were enabled.

I can see that the problem has been solved by Microsoft. Our Edge browser stopped crashing and I can use Bing as a default search provider and use address bar suggestions.

@Marius Motiekaitis 

 

It seems that they also rolled out .74 today.

 

Maybe it would be nice to add some failover functions to address bar. 

 

I think that users won't event notice if bingforbusiness part is missing when background service has problems if outcome is something else than full browser crash.