Power Platform Microsoft Community Login Loop

Occasional Contributor



OK, so I'll start at the very beginning as I'm reliably informed that it's a very good place to start.

The Problem

I'm trying to login to the following community:







I'm using my business microsoft account with its own domain. So, when I try to click 'Sign-In' on the community it seems to go through the OAUTH sign-in process.




However, then it forwards me to powerusers .microsoft .com (no extended /'s), where it says:

Welcome to the Power Platform Community

Here it offers all the available community links.


OK, that's cool, so I click on the Power Automate Community link for the exact same URL as the first, above ... the forum loads ... ... aaaaaand ... I'm not logged in.


The same (or variations on this) happen with the other Power Platform communities.

Further Details

Possible Repeat Incident


Company DNS Verification

One of the common things recommended is ensuring that the corporate domain, etc, is all approved properly in Azure DNS.


This is all fine. The way that I can tell is that if I try to log in using FireFox Private Browsing in Windows 10, I have zero issues.

Browser Console Stuff

I've looked as heavily as I can at browser console stuff and things, and it's looking to my untrained eye to be an issue with:

  1. chromium Cross-Origin Read Blocking (CORB)
  2. An MS OAUTH issue.
  3. Both.

The actual error that I get from CORB blocked cross-origin response, happens upon clicking any link to the forum or sign-in:




I've obfuscated some of that data.


Logged Elsewhere

  1. At Edge Support
  2. Over on the Power Platform community "I Found a Bug" forum
  3. Rightly closed via Office Admin as not relevant


EDGE - Latest Edge DEV (no add-ons)
Windows - Latest Win 10 (w/ updates)

Ancillary information

Cookies - All relevant Microsoft domains (see end) allowed
Tracking - All relevant Microsoft domains (see end) allowed --- * this shouldn't be required, though.
ISP - Tried on my normal ISP, and an additional one.
DNS - Tried with multiple DNS providers, private and public.
VPN - Tried with two different IPs.

0 Replies