Home

PiP window blank when taskbar is set to auto-hide on Windows 10

%3CLINGO-SUB%20id%3D%22lingo-sub-1056194%22%20slang%3D%22en-US%22%3EPiP%20window%20blank%20when%20taskbar%20is%20set%20to%20auto-hide%20on%20Windows%2010%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1056194%22%20slang%3D%22en-US%22%3E%3CP%3EIf%20the%20Windows%2010%20taskbar%20is%20set%20to%20automatically%20hide%20then%20the%20Picture%20in%20Picture%20window%20will%20be%20blank%20and%20unresponsive.%20This%20bug%20only%20occurs%20with%20the%20Windows%2010%20auto-hide%20taskbar%20setting%20on.%20After%20doing%20some%20research%20on%20the%20issue%20I%20read%20people%20have%20this%20issue%20in%20other%20Chromium%20browsers%20too%20e.g.%20Google%20Chrome%20and%20on%20Linux%20too%20if%20auto-hide%20panel%20is%20on.%20In%20Opera%20and%20Mozilla%20Firefox%20this%20bug%20doesn't%20occur%20when%20using%20their%20respective%20PiP%20features%20with%20the%20taskbar%20auto-hide%20setting%20on.%20It%20may%20be%20a%20GeForce%20related%20bug%20or%20maybe%20a%20bug%20related%20to%20my%20series%20of%20graphics%20card%20as%20the%20bug%20doesn't%20occur%20while%20using%20my%20older%20laptop%20which%20uses%20Intel%20HD%20Graphics%2C%20but%20it%20occurs%20on%20my%20Desktop%20PC%20using%20my%20GeForce%20GTX%20750%20Ti.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EScreenshot%20of%20PiP%20mode%20with%20taskbar%20auto-hide%20on%3A%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20style%3D%22width%3A%20999px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Fgxcuf89792.i.lithium.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F160752i7340F525C2949F5F%2Fimage-size%2Flarge%3Fv%3D1.0%26amp%3Bpx%3D999%22%20alt%3D%22pip%20mode%20taskbar%20auto-hide%20on.jpg%22%20title%3D%22pip%20mode%20taskbar%20auto-hide%20on.jpg%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3Eand%20with%20taskbar%20auto-hide%20off%3A%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20style%3D%22width%3A%20999px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Fgxcuf89792.i.lithium.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F160753iD93BCCE04A41E27A%2Fimage-size%2Flarge%3Fv%3D1.0%26amp%3Bpx%3D999%22%20alt%3D%22pip%20mode%20taskbar%20auto-hide%20off.jpg%22%20title%3D%22pip%20mode%20taskbar%20auto-hide%20off.jpg%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20would%20like%20this%20bug%20to%20get%20resolved%2C%20also%20I'm%20curious%20how%20many%20users%20are%20affected%20by%20it.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1056227%22%20slang%3D%22en-US%22%3ERe%3A%20PiP%20window%20blank%20when%20taskbar%20is%20set%20to%20auto-hide%20on%20Windows%2010%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1056227%22%20slang%3D%22en-US%22%3E%3CP%3EHi%26nbsp%3B%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F437541%22%20target%3D%22_blank%22%3E%40yoruzo%3C%2FA%3E%26nbsp%3B%2C%20welcome%20to%20the%20community!%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3Eyou're%20right%20about%20Intel%20graphics%2C%20I%20have%207700K%20with%20Intel%20630%20IGPU%20running%20Windows%2010%20insider%20fast%20ring%20build%2019037%2C%20I%20tried%20YouTube's%20built%20in%20PIP%20mode%20with%3A%3C%2FP%3E%3CP%3EEdge%20insider%20canary%26nbsp%3B%3CSPAN%3EVersion%2080.0.355.0%20(Official%20build)%20canary%20(64-bit)%3C%2FSPAN%3E%3C%2FP%3E%3CP%3EGoogle%20chrome%20dev%26nbsp%3B%3CSPAN%3EVersion%2080.0.3983.2%20(Official%20Build)%20dev%20(64-bit)%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%3CSPAN%3Eboth%20were%20working%20fine%20when%20taskbar%20auto-hide%20was%20on.%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%3Eso%20like%20you%20said%20it%20might%20be%20only%20related%20to%207-series%20GTX%20cards%20or%20Nvidia%20cards%20in%20general.%20it%20could%20be%20Nvidia's%20job%2Fmistake%20not%20releasing%20a%20proper%20driver%20to%20work%20properly%20on%20Chromium%20based%20browsers.%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%3CSPAN%3Ehopefully%20someone%20else%20with%20more%20recent%20GTX%20cards%20will%20provide%20more%20insights.%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%3Emeanwhile%20you%20can%20try%20turning%20off%20hardware%20acceleration%20to%20get%20your%20GPU%20off%20the%20hook%20from%20Edge%20process%20or%20use%20this%20extension%20(official)%20to%20have%20a%20PIP%20view%20that%20will%20stay%20on%20the%20top%2C%20works%20on%20YouTube%20and%20any%20other%20site%20that%20has%20HTML5%20video%20playing.%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%3E%3CA%20href%3D%22https%3A%2F%2Fchrome.google.com%2Fwebstore%2Fdetail%2Fhkgfoiooedgoejojocmhlaklaeopbecg%22%20target%3D%22_blank%22%20rel%3D%22nofollow%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%22%3Ehttps%3A%2F%2Fchrome.google.com%2Fwebstore%2Fdetail%2Fhkgfoiooedgoejojocmhlaklaeopbecg%3C%2FA%3E%3C%2FSPAN%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1056243%22%20slang%3D%22en-US%22%3ERe%3A%20PiP%20window%20blank%20when%20taskbar%20is%20set%20to%20auto-hide%20on%20Windows%2010%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1056243%22%20slang%3D%22en-US%22%3E%3CP%3EHi%2C%26nbsp%3B%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F310193%22%20target%3D%22_blank%22%3E%40HotCakeX%3C%2FA%3E%26nbsp%3B%2C%20thank%20you%20for%20your%20quick%20reply!%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI've%20tried%20both%20potential%20fixes%2Fworkarounds%20before%20and%20sadly%20none%20of%20them%20resolve%20the%20issue.%20Just%20to%20be%20sure%20I%20tried%20both%20of%20your%20suggestions%20again%20and%20oddly%20enough%20the%20bug%20occurs%20even%20with%20hardware%20acceleration%20off%20or%20while%20using%20the%20extension%20you%20linked%20(I%20think%20it%20just%20adds%20a%20button%20for%20easier%20PiP%20mode%20access%20and%20doesn't%20add%20a%20different%20PiP%20mode).%20Thank%20you%20for%20your%20suggestions%20though.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1056249%22%20slang%3D%22en-US%22%3ERe%3A%20PiP%20window%20blank%20when%20taskbar%20is%20set%20to%20auto-hide%20on%20Windows%2010%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1056249%22%20slang%3D%22en-US%22%3E%3CP%3EYou're%20welcome%2C%3C%2FP%3E%3CP%3Ewell%20what%20the%20extension%20does%20is%20it%20creates%20a%20new%20popup%20video%20that%20can%20be%20dragged%20and%20put%20over%20other%20programs'%20windows%20or%20even%20over%20a%20full-screen%20game%20you%20play%2C%20but%20the%20one%20in%20the%20YouTube%20is%20only%20restricted%20to%20the%20YouTube.com%20website%20and%20tab%2C%20so%20i%20think%20that's%20the%20main%20difference%3C%2FP%3E%3C%2FLINGO-BODY%3E
yoruzo
New Contributor

If the Windows 10 taskbar is set to automatically hide then the Picture in Picture window will be blank and unresponsive. This bug only occurs with the Windows 10 auto-hide taskbar setting on. After doing some research on the issue I read people have this issue in other Chromium browsers too e.g. Google Chrome and on Linux too if auto-hide panel is on. In Opera and Mozilla Firefox this bug doesn't occur when using their respective PiP features with the taskbar auto-hide setting on. It may be a GeForce related bug or maybe a bug related to my series of graphics card as the bug doesn't occur while using my older laptop which uses Intel HD Graphics, but it occurs on my Desktop PC using my GeForce GTX 750 Ti.

 

Screenshot of PiP mode with taskbar auto-hide on:

 

pip mode taskbar auto-hide on.jpg

 

and with taskbar auto-hide off:

 

pip mode taskbar auto-hide off.jpg

 

I would like this bug to get resolved, also I'm curious how many users are affected by it.

3 Replies

Hi @yoruzo , welcome to the community!

 

you're right about Intel graphics, I have 7700K with Intel 630 IGPU running Windows 10 insider fast ring build 19037, I tried YouTube's built in PIP mode with:

Edge insider canary Version 80.0.355.0 (Official build) canary (64-bit)

Google chrome dev Version 80.0.3983.2 (Official Build) dev (64-bit)

both were working fine when taskbar auto-hide was on.

 

so like you said it might be only related to 7-series GTX cards or Nvidia cards in general. it could be Nvidia's job/mistake not releasing a proper driver to work properly on Chromium based browsers.

hopefully someone else with more recent GTX cards will provide more insights.

 

meanwhile you can try turning off hardware acceleration to get your GPU off the hook from Edge process or use this extension (official) to have a PIP view that will stay on the top, works on YouTube and any other site that has HTML5 video playing.

 

https://chrome.google.com/webstore/detail/hkgfoiooedgoejojocmhlaklaeopbecg

Hi, @HotCakeX , thank you for your quick reply!

 

I've tried both potential fixes/workarounds before and sadly none of them resolve the issue. Just to be sure I tried both of your suggestions again and oddly enough the bug occurs even with hardware acceleration off or while using the extension you linked (I think it just adds a button for easier PiP mode access and doesn't add a different PiP mode). Thank you for your suggestions though.

You're welcome,

well what the extension does is it creates a new popup video that can be dragged and put over other programs' windows or even over a full-screen game you play, but the one in the YouTube is only restricted to the YouTube.com website and tab, so i think that's the main difference

Related Conversations
Tabs and Dark Mode
cjc2112 in Discussions on
50 Replies
Extentions Synchronization
Deleted in Discussions on
3 Replies
Stable version of Edge insider browser
HotCakeX in Discussions on
35 Replies
How to Prevent Teams from Auto-Launch
chenrylee in Microsoft Teams on
32 Replies
Security Community Webinars
Valon_Kolica in Security, Privacy & Compliance on
15 Replies
Dev channel update to 80.0.355.1 is live
josh_bodner in Discussions on
67 Replies