Netflix - Playing any video results in error code D7356

Occasional Contributor

Using Edge Dev 80.0.320.5, with Windows 10 Pro Build 1909


While I can browse Netflix site and view trailers, attempting to play any title results in the Netflix black screen "Unexpected error" with error code D7356.  Have disabled all extensions just in case, but still no luck.


However using official Edge or Chrome browsers on same laptop and have no problem (and also Netflix windows app works fine)  ... anyone else seeing this?  I don't know how long it has been like this (I'm sure it used to work).  Also  Youtube still plays videos fine in Edge Dev.


19 Replies

@WRD2000AU I too am experiencing this problem. I'm on latest Canary build on a Surface Pro X, so using the new ARM64 build.


Thank you for helping to bring this to our attention. We are looking into the cause of the issue, but are receiving conflicting information.  If you try logging into Microsoft Edge Insider Build Beta Channel, does that work, or is it also receiving the error?



@v-gapart I'm getting the error on Beta channel too.  I just tried with the latest beta.



Installed Beta - Version 79.0.309.18 (Official build) beta (64-bit) - same error code.


Also update Dev to Version 80.0.328.4 (Official build) dev (64-bit) - same error code.

I'm having the same problem... :(
Same problem on Version 80.0.340.0 (Official build) canary (64-bit). It just started sometime today.

Ditto.  V79.0.309.25.  Surface Pro X arm64

Same Issue, has been going for over a week now.. Always used to work, but then suddenly nothing... I have reported this to Netflix who don't seem to care.

Version 80.0.334.3 (Official build) dev (64-bit) - Error Code: D7356

@Lopalos Netflix works for me again in Build Canary Build 341 on my Surface Pro X.

Having Same Issue..

with  these parameters;

Win and 10 Home insider preview Ver. 10.0.19536 Build and 19536 

Microsoft Edge Beta Ver. 79.0.309.54 (Official Build) Beta-64bit



Same error on  80.0.361.9 version of Edge Dev(Beta channel) build.

@WRD2000AU Same error on Version 80.0.361.9 (Official build) dev (64-bit), on win 10 pro 64bit build 1909.

Had the same error appear a couple of dev builds before the one mentioned, but it fixed itself in a couple of days. This time it has persisted for a while.

Playback was working fine when 80.0.361.9 was released and it stopped after a day or two.

Other protected and unprotected content streams fine (youtube, Amazon prime video for example).

Same or very similar error here, it occurs after I pause the video for like a minute it always happens. Doesn't happen on chrome or regular edge. But it always does on edge beta, dev and canary they all get the same exact error after pausing.


Also no problem with other websites on edge beta like youtube or amazon video. This is the error code I always get. 

Error Code: D7361-1253

Edit: Minutes after I posted this I kept testing stuff and I figured out a fix.  Try unchecking the box for  

"Use hardware acceleration when available" on the settings in the browser. Worked for me.
Thank you for coming back and adding your fix to your comment! It worked for me too.

I also get the same error when trying to watch Netflix. Error Code: D7356
@DanielMP fix worked for me..

I'm having the same problem today's date 2/22/2020
Microsoft Edge is up to date. Version 80.0.361.57 (Official build) (64-bit)
last insider update, Windows 10 Insider Preview Build 19569
Pardon the interruption
Sorry, we're having trouble with your request.
Netflix Home
Error Code D7356

Thanks @DanielMP . That worked !!

@DanielMP   Daniel,  You are "The Man".  Your recommendation fixed the problem.  Contacted Microsoft, Netflix, Xfinity and they had no solution and were supposed to get back to me.  Thanks