Microsoft Edge Dev Sync Issues on Linux/Debian/Ubuntu

Copper Contributor

When will Microsoft get the sync issues fixed on Linux/Debian/Ubuntu?


I don't know about anyone else on the planet, but I switched to Edge Dev as my default browser once Microsoft decided to go with Chromium. In other words, Chrome went out the window on ALL devices.


Ubuntu's default browser is Firefox which I use on Linux/Debian/Ubuntu. If this is not resolved soon, I'll be switching to Firefox, permanently no matter when the issue is fixed...


Yes to those that will ask if I have tried this and that, of course I have. Friggin Edge will not sync. No work arounds, just fix the damned thing.


When Microsoft, WHEN???


JP Johnston ME CSWP

Rogue Exploration Technologies | JP Parametrics

12 Replies

First, I think that it would be helpful if you (1) let us know the Dev version you are using, and (2) explain the nature of the issues you are encountering with sync. That might help us to replicate/test the issues you are encountering.

Second, if you can, it might be helpful to submit Feedback to Microsoft so that Microsoft's technical staff can evaluate the issue.

I do not sync extensively (syncing favorites, passwords, settings, personal information, and extensions, but not history, open tabs or collections), but I've not encountered syncing issues involving my two Linux computers, which are synced with two Windows computers, an iPhone 2020SE and an Android tablet**. I don't know if that is typical or not at this point.


**I am running Version 91.0.845.2 on a Solus Budgie laptop and desktop, Version 89.0.774.68 on a Windows 10 laptop and desktop, Version on a Lenovo Android tablet, and Version 46.2.0 on an iPhone.

Sync was just recently added to the Linux version, it's in the Dev channel, not even in Beta nor stable.
these problems are normal and expected. it took them months to make it solid on Mac and Windows. took Google even longer than that when they first started it.

What problems have you been having with sync on your Linux build(s)? As I noted, I've been having none on mine, and I haven't run across reports of issues on this forum, either, which is odd.  That's not to say that problems don't exist, but I'm not seeing reports yet.  Perhaps this thread will prompt some reports.



I am on Edge Version 91.0.845.2 (Official build) dev (64-bit). See the attached screenshot...

I personally don't have any problems, that was in reference to the OP's post.
I know it was just added. I get it took forever to make it to Linux. I understand computers. So, if she is syncing for y'all then I am not doing something correctly...

@jpparametrics91.0.845.2 is the current Dev version, and I can see that you are signed into your MSA, so sync should be working by default (that is, without the flag, which was required by an earlier version). It clearly isn't.


At this point, my only suggestion is that you submit Feedback or contact Microsoft Edge Insider Support. I've had good luck with the latter on several occasions when I encountered something not working for me that seemed to be working for others.


I suppose that you could try brute force, uninstalling Edge from your Ubuntu build and then reinstalling.   That might help if something in your current Edge setup is blocking.

I will contact them. I have already uninstalled and reinstalled a couple of times...

Appreciate y'alls assistance...

I'm sorry you've been having issues with syncing on Linux. When you file feedback if you select 'include diagnostics logs' we'll get information about the state of sync, which will help us troubleshoot the issue. Also, if you are willing, you can share the contents edge://sync-internals/ and I can create a bug and route it directly to our sync team. Also, we really appreciate you reporting this problem. It will help us deliver a solid experience as we move to the Beta and Stable releases of Edge on Linux!

@lorne_mitchellI sent the data to them last Friday.

I'm having the same problem. I tried cleaning the browser data and reinstalling Edge with no success. The "Reset Sync" button never finishes processing apparently. I have Edge installed on a laptop and a desktop, both Ubuntu 21.04 and both with this sync issue.



Instead of "Sync is on", I see "Not syncing" with a banner saying "We're having trouble syncing browsing data across your signed-in devices. Learn more." The Learn More link points to this article instructing to press the Reset Sync button, which seems to never finish executing, even after following the instruction of logging off other devices.


I believe the issue appeared at some point after installing and syncing Edge on a second device (the laptop). Now even after logging off the laptop and removing Edge from it altogether, the desktop will not sync again. The Reset Sync button never worked in either machine.



  • Edge: Version 92.0.902.9 (Official build) beta (64-bit)
  • OS: Kubuntu 21.04 x86_64

Modified flags:

  • Impulse-style scroll animations [ disabled ]


Same issue here. I tried cleaning the browser data and reinstalling Edge with no success like other users without success. The "Reset Sync" button never finishes processing, apparently. I have Edge installed on Manjaro Gnome all system up to date and this issue it happens randomly, it's really annoying.