Microsoft Edge crashing after a few seconds

Copper Contributor

When opening Microsoft Edge, after a few seconds it crashes

I see it was updated yesterday (11/02/2023) dd/mm/yyyy to version 110.0.1587.41

I have run a repair but no changes


Win 11 Home

Version 22H2

OS build 22621.1194

10 Replies
I have the same problem since today. This happened after edge updated to version 110.0.1587.41

I'm using Windows 10 Pro
OS build 19045.2546
I have the same problem.

@Jat999 I'm having the exact same issue. It's driving me crazy, as I follow every guide that worked for everyone else, but the issue comes back in less than 60 seconds. Microsoft needs to fix this, and fast!

Tried, Reseting, reinstaling, reinstaling from powershell etc none worked. But weirdly In private browser or webview works.

Try removing or disabling (edge://extensions/) the components you have on Edge. You could reactivate or reinstall them one by one afterwards to find out which one is causing the problem. Kind regards

@Hans Le RoyNo extensions installed, still crashing...


I have the same exact issue here. edge crash and close itself after a few seconds.

in the event viewer I get the following:

Log Name: Application
Source: edgeupdatem
Date: 2/13/2023 12:19:48 AM
Event ID: 0
Task Category: None
Level: Information
Keywords: Classic
User: N/A
Computer: ****
Service stopped.
Event Xml:
<Event xmlns="">
<Provider Name="edgeupdatem" />
<EventID Qualifiers="0">0</EventID>
<TimeCreated SystemTime="2023-02-12T20:49:48.4176765Z" />
<Correlation />
<Execution ProcessID="0" ThreadID="0" />
<Security />
<Data>Service stopped</Data>


Information 2/13/2023 12:19:48 AM edgeupdatem Service stopped.

Found the solution:
It is ESET incompatibility with version 110:
please disable "enable protected websites redirection" as said in this link.
it fixed my problem.
best response confirmed by Jat999 (Copper Contributor)
Yay! Thank you bro, it's fixed for me too.



Thanks - Yes this seems to have solved it. 

Many thanks - John

1 best response

Accepted Solutions
best response confirmed by Jat999 (Copper Contributor)
Yay! Thank you bro, it's fixed for me too.

View solution in original post