Manual: How to set up IE Mode (Internet Explorer Integration) in Edge C (Updated)

Highlighted
Contributor

Update (08/2020): Some things changed since I firstly wrote this, so here is the revamped version. For more detailed info, view Microsoft's article About IE mode

 

So, since it took me almost a day to collect all necessary info and successfully set up IE Mode in Edge, I thought it may be helpful to post a step-by-step manual and some useful notes. 

 

Prerequisites: 

 

1. The flags aren't there anymore in current Edge Stable, Dev and Canary, so you can skip this one. 

To activate IE Mode open Edge Dev and go to experimental features by typing edge://flags/ (Note: Edge Canary doesn't support IE Mode by now)

  • Under Enable IE Integration select IE mode (Note: don't choose "NeedIE" as it has no effect by now)
  • Optionally you can set Enable enhanced hang resistance for IE Integration to Enabled
  • Optionally you can set Enable IE window hang resistance for IE Integration to Enabled

 

2. If you don't have an Enterprise Mode site list download the Enterprise Mode Site List Manger v2 from https://www.microsoft.com/en-us/download/details.aspx?id=49974

(Note: the site list xml has to use the v2 scheme to work with Edge Chromium)

  • To create a site list open the Manager, click Add and type the domain that should use IE Mode (Note: just enter the plain domain, eg "test.contoso.com" without the leading http:// or https://)
  • Under Compat Mode select IE8 Enterprise Mode
  • Under Open in select IE11 to open the site in Edge with IE Mode (Note: options "None" or "MSEdge" will open the site without IE Mode)
  • Click File > Save to XML and publish the site list in IIS or for testing just use the xml as local file on your PC

 

3. Download the Edge Chromium group policy template files from https://www.microsoftedgeinsider.com/de-de/enterprise 

  • Open the .zip file and go to policy_templates > windows > admx
  • Copy msedge.admx to C:\Windows\PolicyDefinitions\
  • Copy all *.adml files from your language folder (eg. "en-US") to C:\Windows\PolicyDefinitions\<your language folder>\

 

4. Open the Local Group Policy Editor and edit the following entries in Computer Configuration > Administrative Templates: 

  • Enable Microsoft Edge > Configure Internet Explorer configuration and set it to Internet Explorer mode
  • Enable Windows Components > Internet Explorer > Use the Enterprise Mode IE website list and set the path to your XML-sitelist, either as URL (eg. https://test.contoso.com/list.xml) or as UNC if you're using a local XML file (eg. file:///C:\test\list.xml) 
  • On some machines I had to enable Microsoft Edge > Configure the Enterprise Mode Site List and set the path to the XML-sitelist too, to get IE Mode to work. 

 

Optional, but not needed for IE Mode: For compatibility, you can set the following, so Enterprise sites visited in Classic Edge will open in Internet Explorer.

  • Enable Windows Components > Microsoft Edge > Use the Enterprise Mode IE website list and set the path to your XML-sitelist, either as URL (eg. https://test.contoso.com/list.xml) or as UNC if you're using a local XML file (eg. file:///C:\test\list.xml)

 

The 4 policies above can be also set via registry: 

  • HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Edge >  
    InternetExplorerIntegrationLevel (REG_DWORD) with value 1 (or decimal: 0x00000001) 
  • HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Internet Explorer\Main\EnterpriseMode >  
    SiteList (REG_SZ) with path to your XML-sitelist (eg. https://test.contoso,com/list.xml)
  • HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Edge >  
    InternetExplorerIntegrationSiteList (REG_SZ) with path to your XML-sitelist (eg. https://test.contoso,com/list.xml)
  • HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\MicrosoftEdge\Main\EnterpriseMode >  
    SiteList (REG_SZ) with path to your XML-sitelist (eg. https://test.contoso,com/list.xml)

 

Force update of the policies to take effect immediately by either running gpupdate /force on an elevated prompt or rebooting your machine. 

To check if Edge is recognizing your sitelist correctly, type edge://compat in the address bar. This will show all entries from your XML-sitelist.
More diagnostics for IE mode can be viewed in edge://compat/iediagnostic

 

This worked for me on different machines using Windows 8.1 (Pro and non-pro) and Windows 10 (1909, 1903, 1809) with Edge Stable, Dev and Canary.
Please get back to me if I missed something so I can update the manual. 

 

10 Replies
Highlighted

The only missed step would be a system restart/reboot after all the Registry changes are completed. At least that was what I needed to do before Edgeium took the changes.

 

Here is the Microsoft URL documenting the steps using IE Mode for Edge Enterprise.

Highlighted

@Neon01 

So to enable IE mode you need to configure group policies under Administrative Templates > Windows Components > Microsoft Edge > Use the Enterprise Mode IE website list > Configure Internet explorer Integration and under Administrative Templates > Windows Components > Microsoft Edge > Use the Enterprise Mode IE website list

 

Will the GPO for Edge chromium be split into these two location in the final release ?

Highlighted

@LMichel 

 

Hi LMichel, 

 

I'm pretty sure it will, because

  • "Configure Internet explorer Integration" policy in the Chromium GPOs only tells Edge Chrome to basically enable IE Mode
  • whereas the "Use the Enterprise Mode IE website list" policy in the Internet Explorer GPOs enables site lists for both, Edge and IE (which is afaik needed to launch IE Mode in Edge properly, because it uses the IE engine) 

But I'm not a developer, so please don't quote me on that. 

 

Btw., the "Use the Enterprise Mode IE website list" policy in the Classic Edge GPOs is not needed for IE Mode to work on Edge Chromium Dev and Beta. I just added it in the manual for compatibility issues, so that Enterprise sites visited in Edge Classic will open in IE (I've updated the manual to work this out).

 

Best regards

 

Highlighted

@Neon01 Thank you so much sir to share this great information.

I am using Windows 10 Home Edition 64 Bit, since group policy related settings are not available in Home Edition, so in step 2, I added more than one website and skipped step 3 and 4, directly go to registry editior(regedit) method and opened directory:

HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft

 

1. Created new key Edge, so it would be

HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Edge

created new DWORD without any mistake InternetExplorerIntegrationLevel and set it's value to 1

 

2. Again go to following directory

HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft

Just create another following keys under Microsoft

HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Internet Explorer\Main\EnterpriseMode

HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\MicrosoftEdge\Main\EnterpriseMode

and close registry editor, sign-out and again sign-in PC, then internet explorer mode will work for all sites. 

 

Highlighted

@Gaurav_Sahare 

I tried your way and mine didn't do anything.

Highlighted

Hi @dany20mh 

can you tell me what Edge version you use and which OS your machine is on? 

Did you do the necessary updates according to About IE mode ?

What is edge://compat and edge://compat/iediagnostic showing?

Highlighted

@Neon01 

Hello,

I have MS Edge Version 84.0.522.61 (Official build) (64-bit) on Windows 10 build 1809 (17763.1339)

I tried to follow your steps to enable IE integration and was not able to find this from step 4.

Enable Microsoft Edge > Configure Internet Explorer configuration and set it to Internet Explorer mode

Here is what I see:

 

IE mode GP Settings 1.jpg

If I go to Windows Components, I see Microsoft Edge, but no Configure Internet Explorer Configuration:

 

IE mode GP Settings 2.jpg

Also in the registry I don't see HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Edge >  
InternetExplorerIntegrationLevel

 

IE mode GP Settings 3.jpg

 

and HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Edge >  
InternetExplorerIntegrationSiteList

 

Should I just create them manually?

 

Thanks

 

 

 

Highlighted

Hi @Vlad_Testiler 

if you can't see the the Edge policies in the MMC (Microsoft Management Console) policy manager, either you didn't implement the policy files correctly or you copied them while the MMC was open. This is a known bug, if you copy new policy files while MMC is opened, they won't be recognized. 

Anyway, just create the registry entries manually, that's what the policy does too. 

Btw, what you found under "Windows Components" are the policy settings for classic Edge (Edge HTML). 

Highlighted

Hi @Neon01 

I verified that I have msedge.adml in C:\Windows\PolicyDefinitions and msedge.adml,  msedgeupdate.adml in C:\Windows\PolicyDefinitions\en-US. Restarted gpedit and still could see not see MSEdge under Computer Configuration=>Administrative Templates.

Should I reboot my machine for it to work?

My machine is on the company domain and it is possible that some GPOs causing this.

I'll try to add to the registry directly, if still not there after reboot. 

Thank you for a quick response.

 

Highlighted

Hi @Neon01,

I added Reg keys and rebooted machine an everything working now.

Thank you.