Mac Edge - Turn off video auto play

%3CLINGO-SUB%20id%3D%22lingo-sub-2197665%22%20slang%3D%22en-US%22%3EMac%20Edge%20-%20Turn%20off%20video%20auto%20play%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2197665%22%20slang%3D%22en-US%22%3E%3CP%3EI%20have%20seen%20a%20couple%20suggestions%20to%20turn%20off%26nbsp%3B%20video%20autoplay%2C%20but%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3BThis%20does%20NOT%20work%20-%20posted%20on%20other%20sites%3C%2FP%3E%3COL%3E%3CLI%3ELoad%20edge%3A%2F%2Fflags%2F%20in%20the%20Microsoft%20Edge%20address%20bar.%3C%2FLI%3E%3CLI%3ESearch%20for%20autoplay.%3C%2FLI%3E%3CLI%3ESet%20the%20experimental%20flag%20%22Show%20block%20option%20in%20autoplay%20settings%22%20to%20enabled.%3C%2FLI%3E%3CLI%3ERestart%20the%20browser.%3C%2FLI%3E%3CLI%3EOpen%20the%20Autoplay%20Site%20Settings%20in%20Edge%20after%20the%20restart%3A%20edge%3A%2F%2Fsettings%2Fcontent%2FmediaAutoplay.%3C%2FLI%3E%3CLI%3ESet%20the%20setting%20to%20%22Block%22.%26nbsp%3B%20%3CSTRONG%3EMac%20DOES%20NOT%20HAVE%20THIS%20OPTION%3C%2FSTRONG%3E%3C%2FLI%3E%3C%2FOL%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-2197683%22%20slang%3D%22en-US%22%3ERe%3A%20Mac%20Edge%20-%20Turn%20off%20video%20auto%20play%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2197683%22%20slang%3D%22en-US%22%3EHi%2C%3CBR%20%2F%3Ethis%20is%20an%20experimental%20feature%20that%20is%20not%20fully%20implemented%20yet.%3CBR%20%2F%3Eyou%20can%20see%20in%20the%20top%20feedbacks%20list%20that%20it%20is%20planned%20for%20March%3CBR%20%2F%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fdiscussions%2Ftop-feedback-summary-for-march-9%2Fm-p%2F2196984%22%20target%3D%22_blank%22%3Ehttps%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fdiscussions%2Ftop-feedback-summary-for-march-9%2Fm-p%2F2196984%3C%2FA%3E%3CBR%20%2F%3E%3C%2FLINGO-BODY%3E
New Contributor

I have seen a couple suggestions to turn off  video autoplay, but 

 

 This does NOT work - posted on other sites

  1. Load edge://flags/ in the Microsoft Edge address bar.
  2. Search for autoplay.
  3. Set the experimental flag "Show block option in autoplay settings" to enabled.
  4. Restart the browser.
  5. Open the Autoplay Site Settings in Edge after the restart: edge://settings/content/mediaAutoplay.
  6. Set the setting to "Block".  Mac DOES NOT HAVE THIS OPTION

 

 

4 Replies
Hi,
this is an experimental feature that is not fully implemented yet.
you can see in the top feedbacks list that it is planned for March
https://techcommunity.microsoft.com/t5/discussions/top-feedback-summary-for-march-9/m-p/2196984

@HotCakeX      Well that's great.  Sure glad  I didnt ask 81 weeks ago  and had to wait.

The flag was there for quite a while, i don't remember exactly but probably a year, it works, but not on all websites, but I've tested it on YouTube and news websites. I think (and i hope) what they are trying to do is to make it work on all websites.

in my opinion, autoplay blocking is not enough if it doesn't block video preloading.
when I set autoplay blocking to block, it stops YouTube videos from playing automatically, but the website still downloads the video in the background, waiting for me to hit the play button.
this consumes unnecessary internet bandwidth.
I have exactly the same problem ... but on a Windows PC.
The auto-play videos are so irritating that I've now set Firefox as my default browser, even though I LOVED everything else about Edge :(