link to local file

%3CLINGO-SUB%20id%3D%22lingo-sub-1002013%22%20slang%3D%22en-US%22%3Elink%20to%20local%20file%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1002013%22%20slang%3D%22en-US%22%3E%3CP%3EI%20have%20a%20intranet%20website%2C%20where%20i%20link%20to%20some%20local%20files%20i.e.%26nbsp%3Bfile%3A%2F%2F%2FY%3A%2FFoldername%2F16349.docx%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EIn%20internet%20Explorer%20this%20works%20fine.%20In%20Google%20Chrome%20local%20files%20are%20not%20supported%2C%20but%20a%20workaround%20is%20to%20use%20an%20extension%20called%20IE-tab%2C%20which%20opens%20the%20link%20in%20a%20IE-tab%20in%20Chrome.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20thought%20that%20i%20could%20use%20the%20IE%20mode%20in%20Edge%20to%20do%20the%20same%20trick%20through%20a%20group%20policy%2C%20but%20using%20the%20Enterprise%20Mode%20Site%20List%20Manager%2C%20it%20will%20not%20accept%20a%20url%20like%20%22file%3A%2F%2F%2FY%3A%2FFoldername%2F*%22%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EDoes%20anyone%20know%20how%20to%20make%20edge%20open%20local%20file%20links%20in%20IE%20mode%20%3F%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1002562%22%20slang%3D%22en-US%22%3ERe%3A%20link%20to%20local%20file%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1002562%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F455268%22%20target%3D%22_blank%22%3E%40ThueMj%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20can%20get%20this%20without%20IE%20mode%20using%20Edge%20insider%20canary%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-center%22%20style%3D%22width%3A%20238px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Fgxcuf89792.i.lithium.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F156476i8CF6F7E387929BFB%2Fimage-size%2Flarge%3Fv%3D1.0%26amp%3Bpx%3D999%22%20alt%3D%22Annotation%202019-11-12%20192222.png%22%20title%3D%22Annotation%202019-11-12%20192222.png%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3Eand%20as%20far%20as%20i%20remember%2C%20when%20i%20was%20looking%20at%20my%20enterprise%20site%20list%20for%20IE%20mode%20implementation%2C%20Edge%20insider%20canary%20was%20loading%20that%20file%20correctly.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3Etry%20not%20to%20use%20%22%3CSPAN%3Efile%3A%2F%2F%2FY%3A%2FFol%22%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%3CSPAN%3Euse%20%22server%2Fcomputername%22%20and%20the%20rest%20of%20the%20file%20path.%20or%20better%20yet%2C%20create%20a%20virtual%20directory%20in%20your%20web%20server%20IIS%20and%20put%20your%20files%20in%20there%2C%20i%20can%20confirm%20it%20works%20this%20way.%3C%2FSPAN%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1004607%22%20slang%3D%22en-US%22%3ERe%3A%20link%20to%20local%20file%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1004607%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F310193%22%20target%3D%22_blank%22%3E%40HotCakeX%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThank%20you%20for%20your%20answer.%3C%2FP%3E%3CP%3EAnd%20your%20solutions%20works%20without%20IE%20mode%2C%20but%20unfortunately%20they%20do%20not%20solve%20my%20problem.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EIf%20i%20have%20a%20hypelink%3A%3CBR%20%2F%3E%3CA%20href%3D%22%26quot%3By%3A%5CFolderName%5C10000.docx%26quot%3B%22%20target%3D%22%26quot%3B_blank%26quot%3B%22%20rel%3D%22nofollow%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%22%3Elink%20to%20file%3C%2FA%3E%3CBR%20%2F%3Eand%20click%20on%20it%20from%20Internet%20Explorer%2C%20the%20file%20will%20be%20opened%20with%20Microsoft%20Word%20from%20that%20location.%20The%20user%20can%20then%20edit%20the%20document%20and%20save%20the%20changes%20without%20specifying%20the%20filename%20or%20dowloadning%20the%20file.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EIf%20i%20do%20the%20same%20with%20Chrome%20or%20Edge%20(Beta)%2C%20nothing%20happens%20when%20clicking%20the%20link.%20And%20looking%20at%20the%20console%20is%20see%20this%20message.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20style%3D%22width%3A%20400px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Fgxcuf89792.i.lithium.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F156789iEFA3CFA88322FA59%2Fimage-size%2Fmedium%3Fv%3D1.0%26amp%3Bpx%3D400%22%20alt%3D%22clipboard_image_0.png%22%20title%3D%22clipboard_image_0.png%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3EThe%20same%20happens%20if%20i%20change%20the%20path%20to%20servername...%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20can%20solve%20it%20using%20an%20extension%20called%20IE-tab%2C%20but%20i%20thought%20that%20i%20could%20do%20it%20smarter%20without%20an%20extension%20in%20Edge%20due%20to%20its%20IE-Mode%20and%20the%20site%20liste%2C%20by%20forcing%20edge%20to%20open%20local%20file%20links%20in%20IE%20mode.%3C%2FP%3E%3CP%3EIf%20i%20paste%20the%20url%20in%20the%20browser%20like%20your%20suggestions%2C%20the%20file%20will%20be%20downoladed%20locally%20which%20i%20dont%20want%2C%20because%20it%20is%20then%20no%20longer%20a%20shared%20file%20in%20a%20shared%20folder.%20I%20use%20the%20intranetsite%20for%20managing%20a%20lot%20of%20documents%2C%20where%20the%20users%20can%20edit%20these.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1004760%22%20slang%3D%22en-US%22%3ERe%3A%20link%20to%20local%20file%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1004760%22%20slang%3D%22en-US%22%3EI%20understand%2C%3CBR%20%2F%3Esorry%20I%20don't%20think%20I%20know%20how%20to%20solve%20that.%3CBR%20%2F%3E%3CBR%20%2F%3EIf%20I%20had%20to%20do%20that%2C%20I%20would%20use%20Sharepoint%20and%20Office365%20to%20not%20rely%20on%20Internet%20explorer%20and%20older%20software.%3CBR%20%2F%3E%3CBR%20%2F%3Ep.s%20Sharepoint%20has%20been%20around%20since%202001%3CBR%20%2F%3E%3CA%20href%3D%22https%3A%2F%2Fproducts.office.com%2Fen-us%2Fsharepoint%2Fcollaboration%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%22%3Ehttps%3A%2F%2Fproducts.office.com%2Fen-us%2Fsharepoint%2Fcollaboration%3C%2FA%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1004797%22%20slang%3D%22en-US%22%3ERe%3A%20link%20to%20local%20file%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1004797%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F310193%22%20target%3D%22_blank%22%3E%40HotCakeX%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThank%20you%20for%20trying%26nbsp%3B%3CIMG%20class%3D%22lia-deferred-image%20lia-image-emoji%22%20src%3D%22https%3A%2F%2Fgxcuf89792.i.lithium.com%2Fhtml%2Fimages%2Femoticons%2Fsmile_40x40.gif%22%20alt%3D%22%3Asmile%3A%22%20title%3D%22%3Asmile%3A%22%20%2F%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ESharepoint%20is%20not%20an%20option%20in%20this%20case.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1644137%22%20slang%3D%22en-US%22%3ERe%3A%20link%20to%20local%20file%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1644137%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F310193%22%20target%3D%22_blank%22%3E%40HotCakeX%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EHello%2C%20we%20are%20experiencing%20a%20similar%20issue.%20We%20have%20a%20SharePoint%20site%20with%20links%20to%20a%20fileshare%20where%20we%20have%20scripts%20used%20by%20support%20teams.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EMicrosoft'%20promise%20was%20if%20it%20works%20with%20edge%20legacy%20it%20will%20work%20with%20the%20new%20edge%20and%20in%20this%20case%20it%20works%20with%20edge%20legacy.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EOpening%20my%20SharePoint%20site%20in%20IE%20mode%20is%20of%20course%20not%20an%20option%20!%3C%2FP%3E%3C%2FLINGO-BODY%3E
Highlighted
Occasional Contributor

I have a intranet website, where i link to some local files i.e. file:///Y:/Foldername/16349.docx

 

In internet Explorer this works fine. In Google Chrome local files are not supported, but a workaround is to use an extension called IE-tab, which opens the link in a IE-tab in Chrome.

 

I thought that i could use the IE mode in Edge to do the same trick through a group policy, but using the Enterprise Mode Site List Manager, it will not accept a url like "file:///Y:/Foldername/*"

 

Does anyone know how to make edge open local file links in IE mode ?

 

5 Replies
Highlighted

@ThueMj 

I can get this without IE mode using Edge insider canary

Annotation 2019-11-12 192222.png

 

and as far as i remember, when i was looking at my enterprise site list for IE mode implementation, Edge insider canary was loading that file correctly.

 

try not to use "file:///Y:/Fol"

use "server/computername" and the rest of the file path. or better yet, create a virtual directory in your web server IIS and put your files in there, i can confirm it works this way.

Highlighted

@HotCakeX 

 

Thank you for your answer.

And your solutions works without IE mode, but unfortunately they do not solve my problem.

 

If i have a hypelink:
<a href="y:\FolderName\10000.docx" target="_blank" >link to file</a>
and click on it from Internet Explorer, the file will be opened with Microsoft Word from that location. The user can then edit the document and save the changes without specifying the filename or dowloadning the file.

 

If i do the same with Chrome or Edge (Beta), nothing happens when clicking the link. And looking at the console is see this message.

 

clipboard_image_0.png

The same happens if i change the path to servername...

 

I can solve it using an extension called IE-tab, but i thought that i could do it smarter without an extension in Edge due to its IE-Mode and the site liste, by forcing edge to open local file links in IE mode.

If i paste the url in the browser like your suggestions, the file will be downoladed locally which i dont want, because it is then no longer a shared file in a shared folder. I use the intranetsite for managing a lot of documents, where the users can edit these.

 

Highlighted
I understand,
sorry I don't think I know how to solve that.

If I had to do that, I would use Sharepoint and Office365 to not rely on Internet explorer and older software.

p.s Sharepoint has been around since 2001
https://products.office.com/en-us/sharepoint/collaboration
Highlighted

@HotCakeX 

 

Thank you for trying :smile:

 

Sharepoint is not an option in this case.

Highlighted

@HotCakeX 

 

Hello, we are experiencing a similar issue. We have a SharePoint site with links to a fileshare where we have scripts used by support teams.

 

Microsoft' promise was if it works with edge legacy it will work with the new edge and in this case it works with edge legacy.

 

Opening my SharePoint site in IE mode is of course not an option !