Home

LastPass Vault is slow as a turtle

%3CLINGO-SUB%20id%3D%22lingo-sub-1067756%22%20slang%3D%22en-US%22%3ELastPass%20Vault%20is%20slow%20as%20a%20turtle%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1067756%22%20slang%3D%22en-US%22%3E%3CP%3EI've%20got%20over%20300%20passwords%20and%20login%20entries%20in%20my%20Lastpass%20Vault%2C%20opening%20it%20in%20Edge%20slows%20down%20the%20browser%20to%20a%20point%20that%20each%20scroll%20has%202%20seconds%20delay%2C%20it's%20painfully%20annoying.%20the%20CPU%20usage%20doesn't%20even%20go%20that%20high.%3C%2FP%3E%3CP%3E%3CSPAN%3EVersion%2081.0.363.0%20(Official%20build)%20canary%20(64-bit)%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%3CSPAN%3EI7%207700K%20CPU%2C%20Windows%2010%20latest%20version.%3C%2FSPAN%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-1067756%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EBrowser%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EEdge%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EInsider%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3Eslow%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1069066%22%20slang%3D%22en-US%22%3ERe%3A%20LastPass%20Vault%20is%20slow%20as%20a%20turtle%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1069066%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F310193%22%20target%3D%22_blank%22%3E%40HotCakeX%3C%2FA%3E%20Yes%2C%20that%20certainly%20does%20sound%20frustrating.%20To%20confirm%2C%20what%20happens%20if%20you%20run%20%3CA%20id%3D%22link_7%22%20class%3D%22page-link%20lia-link-navigation%20lia-custom-event%22%20style%3D%22background-color%3A%20transparent%3B%20box-sizing%3A%20border-box%3B%20color%3A%20%23333333%3B%20font-family%3A%20%26amp%3Bquot%3B%20segoeui%26amp%3Bquot%3B%2C%26amp%3Bquot%3Blato%26amp%3Bquot%3B%2C%26amp%3Bquot%3Bhelvetica%20neue%26amp%3Bquot%3B%2Chelvetica%2Carial%2Csans-serif%3B%20font-size%3A%2016px%3B%20font-style%3A%20normal%3B%20font-variant%3A%20normal%3B%20font-weight%3A%20300%3B%20letter-spacing%3A%20normal%3B%20line-height%3A%201.3333%3B%20orphans%3A%202%3B%20overflow-wrap%3A%20break-word%3B%20text-align%3A%20left%3B%20text-decoration%3A%20none%3B%20text-indent%3A%200px%3B%20text-transform%3A%20none%3B%20-webkit-text-stroke-width%3A%200px%3B%20white-space%3A%20normal%3B%20word-spacing%3A%200px%3B%22%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2FDiscussions%2FLastPass-Vault-is-slow-as-a-turtle%2Fm-p%2F1067756%22%20target%3D%22_blank%22%3ELastPass%20Vault%20on%20Chrome%3F%3C%2FA%3E%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3EFawkes%20(they%2Fthem)%3CBR%20%2F%3EProject%20%26amp%3B%20Community%20Manager%20-%20Microsoft%20Edge%3C%2FP%3E%0A%3CDIV%20id%3D%22tinyMceEditorclipboard_image_1%22%20class%3D%22mceNonEditable%20lia-copypaste-placeholder%22%3E%26nbsp%3B%3C%2FDIV%3E%0A%3CP%3E%3C%2FP%3E%0A%3CDIV%20id%3D%22tinyMceEditorclipboard_image_0%22%20class%3D%22mceNonEditable%20lia-copypaste-placeholder%22%3E%26nbsp%3B%3C%2FDIV%3E%0A%3CP%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1069160%22%20slang%3D%22en-US%22%3ERe%3A%20LastPass%20Vault%20is%20slow%20as%20a%20turtle%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1069160%22%20slang%3D%22en-US%22%3EHi%2C%20thank%20you%20for%20your%20response%20%3A)%3C%2Fimg%3E%3CBR%20%2F%3EWell%20I%20don't%20use%20Google%20chrome%20anymore%2C%20I%20uninstalled%20it%20a%20while%20ago%2C%20only%20using%20Firefox%20and%20the%20new%20Edge%20for%20now.%3CBR%20%2F%3Eon%20Firefox%20this%20problem%20doesn't%20happen%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1069180%22%20slang%3D%22en-US%22%3ERe%3A%20LastPass%20Vault%20is%20slow%20as%20a%20turtle%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1069180%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F310193%22%20target%3D%22_blank%22%3E%40HotCakeX%3C%2FA%3E%20For%20sure.%20%3A)%3C%2Fimg%3E%3C%2FP%3E%0A%3CP%3EGot%20it%2C%20thanks.%20We%20like%20to%20ask%20so%20that%20we%20can%20better%20determine%20whether%20the%20issue%20is%20affecting%20any%20other%20fully%20Chromium-based%20browsers%2C%20indicating%20that%20the%20bug%20might%20not%20have%20originated%20with%20Edge%20code.%20(But%20you%20seem%20very%20technically%20competent%2C%20so%20I'm%20sure%20you're%20very%20aware%20of%20that!)%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3EI'll%20make%20a%20note%20of%20this%2C%20but%20please%20let%20us%20know%20if%20you%20come%20across%20any%20similar%20situations.%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3EFawkes%20(they%2Fthem)%3CBR%20%2F%3EProject%20%26amp%3B%20Community%20Manager%20-%20Microsoft%20Edge%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1069227%22%20slang%3D%22en-US%22%3ERe%3A%20LastPass%20Vault%20is%20slow%20as%20a%20turtle%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1069227%22%20slang%3D%22en-US%22%3EOh%20thanks%20%3A)%3C%2Fimg%3E%3CBR%20%2F%3EI%20installed%20Chrome%20stable%20(Version%2079.0.3945.79%20(Official%20Build)%20(64-bit))%20and%20tested%20it%2C%20yes%20it's%20happening%20on%20Chrome%20too.%20but%20in%20both%20browsers%2C%20it%20starts%20happening%20after%20few%20minutes%2C%20with%20few%20tabs%20open%20and%20after%20using%20my%20Lastpass%20vault%20for%20some%20time.%3CBR%20%2F%3Eso%20Lastpass%20vault%20doesn't%20instantly%20slow%20down%20right%20after%20i%20open%20it%2C%20it%20gradually%20becomes%20slow%20after%20some%20usage.%3CBR%20%2F%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1069236%22%20slang%3D%22en-US%22%3ERe%3A%20LastPass%20Vault%20is%20slow%20as%20a%20turtle%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1069236%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F310193%22%20target%3D%22_blank%22%3E%40HotCakeX%3C%2FA%3E%20That's%20very%20helpful%2C%20thanks!%20That%20leads%20me%20to%20think%20it%20would%20be%20a%20Chromium%20issue%20as%20a%20whole%2C%20so%20hopefully%20it%20will%20be%20resolved%20in%20upcoming%20releases.%20I'll%20let%20you%20know%20if%20we%20gain%20any%20insights%2C%20though!%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3EFawkes%20(they%2Fthem)%3CBR%20%2F%3EProject%20%26amp%3B%20Community%20Manager%20-%20Microsoft%20Edge%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1069687%22%20slang%3D%22en-US%22%3ERe%3A%20LastPass%20Vault%20is%20slow%20as%20a%20turtle%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1069687%22%20slang%3D%22en-US%22%3EYes%20it's%20possible%2C%20Thank%20you!%3C%2FLINGO-BODY%3E
Highlighted
Honored Contributor

I've got over 300 passwords and login entries in my Lastpass Vault, opening it in Edge slows down the browser to a point that each scroll has 2 seconds delay, it's painfully annoying. the CPU usage doesn't even go that high.

Version 81.0.363.0 (Official build) canary (64-bit)

I7 7700K CPU, Windows 10 latest version.

6 Replies
Highlighted

@HotCakeX Yes, that certainly does sound frustrating. To confirm, what happens if you run LastPass Vault on Chrome?

 

Fawkes (they/them)
Project & Community Manager - Microsoft Edge

 

​​​​​​​

 

​​​​​​​

Highlighted
Hi, thank you for your response :)
Well I don't use Google chrome anymore, I uninstalled it a while ago, only using Firefox and the new Edge for now.
on Firefox this problem doesn't happen
Highlighted

@HotCakeX For sure. :)

Got it, thanks. We like to ask so that we can better determine whether the issue is affecting any other fully Chromium-based browsers, indicating that the bug might not have originated with Edge code. (But you seem very technically competent, so I'm sure you're very aware of that!)

 

I'll make a note of this, but please let us know if you come across any similar situations.

 

Fawkes (they/them)
Project & Community Manager - Microsoft Edge

Highlighted
Oh thanks :)
I installed Chrome stable (Version 79.0.3945.79 (Official Build) (64-bit)) and tested it, yes it's happening on Chrome too. but in both browsers, it starts happening after few minutes, with few tabs open and after using my Lastpass vault for some time.
so Lastpass vault doesn't instantly slow down right after i open it, it gradually becomes slow after some usage.
Highlighted

@HotCakeX That's very helpful, thanks! That leads me to think it would be a Chromium issue as a whole, so hopefully it will be resolved in upcoming releases. I'll let you know if we gain any insights, though!

 

Fawkes (they/them)
Project & Community Manager - Microsoft Edge

Highlighted
Yes it's possible, Thank you!